• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

    通達信大黑馬止損止贏主圖指標公式代碼源碼[通達信公式]

    相關標簽: 最準確的止盈止損指標 、 通達信止盈止損指標無未來 、 通達信止盈止損系統代碼 、 止損止盈主圖指標 、 移動止損主圖指標 、 止盈止損指標公式 、 止贏止損主圖指標 、 止贏止損型倍投方案 、 股票指標止損點 、 止損指標 、 階梯止損止盈指標 、 止贏止損什么意思 、

    ?

    通達信指標大黑馬止損止贏主圖

    原理解析:

    A0賦值:(最低價+最高價+收盤價*2)/4
    A1賦值:A0的14日指數移動平均畫黃色,線寬為2
    A1X賦值:(A1-1日前的A1)/1日前的A1*100,NODRAW
    A2X賦值:(A0的20日指數移動平均-1日前的A0的20日指數移動平均)/1日前的A0的20日指數移動平均*100
    G1賦值:上次A1X上穿0距今天數
    輸出買入止損:G1日前的A0,畫白色,線寬為1
    輸出脈沖:(A0-A1)/A1*100,NODRAW
    輸出斜脈沖:(A0-1日前的A0)/(A1-1日前的A1),NODRAW
    輸出買入盈利:(A0-買入止損)/買入止損*100,NODRAW
    Y1賦值:G1日前的A0*1.1,畫綠色
    Y2賦值:G1日前的A0*1.2,畫綠色
    Y3賦值:G1日前的A0*1.3,畫綠色
    Y4賦值:G1日前的A0*1.4,畫綠色
    Y5賦值:G1日前的A0*1.5,畫綠色
    Y6賦值:G1日前的A0*1.6,畫綠色
    Y7賦值:G1日前的A0*1.7,畫綠色
    輸出B1:如果A1X>=0,返回買入止損,否則返回無效數,畫紅色,線寬為1
    輸出B2:如果A1X>=0,返回A1,否則返回無效數,COLORFF33FF,線寬為2
    輸出①:如果最高價>=Y1,返回Y1,否則返回無效數,畫綠色,線寬為3
    輸出②:如果最高價>=Y2,返回Y2,否則返回無效數,畫綠色
    輸出③:如果最高價>=Y3,返回Y3,否則返回無效數,畫綠色,CIRCLEDOT
    輸出④:如果最高價>=Y4,返回Y4,否則返回無效數,畫綠色
    輸出⑤:如果最高價>=Y5,返回Y5,否則返回無效數,畫綠色
    輸出⑥:如果最高價>=Y6,返回Y6,否則返回無效數,畫綠色
    輸出⑦:如果最高價>=Y7,返回Y7,否則返回無效數,畫綠色
    ?

    源碼:

    A0:=(L+H+C*2)/4;
    A1:=EMA(A0,14)COLORYELLOW,LINETHICK2;
    A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
    A2X:=(EMA(A0,20)-REF(EMA(A0,20),1))/REF(EMA(A0,20),1)*100;
    G1:=BARSLAST(CROSS(A1X,0));
    買入止損:REF(A0,G1),COLORWHITE,LINETHICK1;
    脈沖:(A0-A1)/A1*100,NODRAW;
    斜脈沖:(A0-REF(A0,1))/(A1-REF(A1,1)),NODRAW;
    買入盈利:(A0-買入止損)/買入止損*100,NODRAW;
    Y1:=REF(A0,G1)*1.1,COLORGREEN;
    Y2:=REF(A0,G1)*1.2,COLORGREEN;
    Y3:=REF(A0,G1)*1.3,COLORGREEN;
    Y4:=REF(A0,G1)*1.4,COLORGREEN;
    Y5:=REF(A0,G1)*1.5,COLORGREEN;
    Y6:=REF(A0,G1)*1.6,COLORGREEN;
    Y7:=REF(A0,G1)*1.7,COLORGREEN;
    B1:IF(A1X>=0,買入止損,DRAWNULL),COLORRED,LINETHICK1;
    B2:IF(A1X>=0,A1,DRAWNULL),COLORFF33FF,LINETHICK2;
    ①:IF(H>=Y1,Y1,DRAWNULL),COLORGREEN,LINETHICK3;
    ②:IF(H>=Y2,Y2,DRAWNULL),COLORGREEN;
    ③:IF(H>=Y3,Y3,DRAWNULL),COLORGREEN,CIRCLEDOT;
    ④:IF(H>=Y4,Y4,DRAWNULL),COLORGREEN;
    ⑤:IF(H>=Y5,Y5,DRAWNULL),COLORGREEN;
    ⑥:IF(H>=Y6,Y6,DRAWNULL),COLORGREEN;
    ⑦:IF(H>=Y7,Y7,DRAWNULL),COLORGREEN;

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

    怎么收費,代編流程等詳情請點擊查閱!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>