• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 其他>> 其他軟件公式>>正文內容

    LTHLZH終結獲利縱橫指標公式源碼[其他軟件公式]

    相關標簽:成交量指標公式 、 換手率指標公式 、 分時指標公式 、 文華指標公式 、 金蜘蛛指標公式 、 麟龍指標公式 、 波段指標公式 、 趨勢指標公式 、 逃頂指標公式 、 指標公式源碼 、 期貨指標公式 、

    ?

    {公式名稱:LT-HLZH終結}

    原理解析:

    輸出【獲利縱橫】:以收盤價計算的獲利盤比例*60的5日指數移動平均,線寬為1,PRECISION1,COLORFFFF
    輸出【活籌】:(以收盤價*1.08計算的獲利盤比例-以收盤價*0.92計算的獲利盤比例)*80的5日指數移動平均,線寬為1,PRECISION1,COLORFFFFFF
    RSV賦值:(收盤價-9日內最低價的最低值)/(9日內最高價的最高值-9日內最低價的最低值)*100
    K賦值:RSV的3日[1日權重]移動平均
    D賦值:K的3日[1日權重]移動平均
    J賦值:2.5*K-3*D
    VAR1賦值:收盤價14%的之字轉向
    VA2賦值:以收盤價計算的獲利盤比例*收盤價的3日指數移動平均的3日指數移動平均
    控籌賦值:(VA2-1日前的VA2)/1日前的VA2*1000
    VAR2賦值:27日內最低價的最低值
    VAR3賦值:34日內最高價的最高值
    VAR4賦值:(收盤價-VAR2)/(VAR3-VAR2)*4的4日指數移動平均*25
    輸出【決殺B點】:如果2日前的VAR1>1日前的VAR1ANDVAR1>1日前的VAR1AND控籌>1日前的控籌ANDJ>1日前的J,返回40,否則返回10,線寬為1,PRECISION0,COLORFF
    輸出【決殺S點】:如果2日前的VAR1<1日前的VAR1ANDVAR1<1日前的VAR1AND控籌<1日前的控籌ANDJ<1日前的J,返回40,否則返回55,PRECISION0,COLORFF00
    當滿足條件【決殺B點】上穿40時,在9位置書寫文字,COLORFF
    當滿足條件【決殺S點】上穿40時,在60位置書寫文字,COLORFF00
    輸出建倉:如果VAR4<10,返回-6,否則返回0,線寬為2,PRECISION0,COLORFFFFBB
    輸出低吸:如果VAR4<30,返回-6,否則返回0,線寬為2,PRECISION0,COLORFFFF00
    輸出警戒:如果VAR4>92,返回-6,否則返回0,線寬為0,PRECISION0,COLORFF00BB
    VAR5賦值:100-3*(收盤價-72日內最低價的最低值)/(72日內最高價的最高值-72日內最低價的最低值)*100的20日[1日權重]移動平均+2*(收盤價-72日內最低價的最低值)/(72日內最高價的最高值-72日內最低價的最低值)*100的20日[1日權重]移動平均的15日[1日權重]移動平均
    VAR6賦值:100-3*(開盤價-72日內最低價的最低值)/(72日內最高價的最高值-72日內最低價的最低值)*100的20日[1日權重]移動平均+2*(開盤價-72日內最低價的最低值)/(72日內最高價的最高值-72日內最低價的最低值)*100的20日[1日權重]移動平均的15日[1日權重]移動平均
    VAR7賦值:VAR5<1日前的VAR6 AND 成交量(手)>1日前的成交量(手) AND 收盤價>1日前的收盤價
    當滿足條件VAR7ANDCOUNT(VAR7,30)=1時,在40位置書寫文字,COLOR99FF
    VAR8賦值:100*(收盤價-34日內收盤價的最低值)/(34日內最高價的最高值-34日內最低價的最低值)的5日簡單移動平均-20
    VAR9賦值:2*VAR8的絕對值
    輸出【加倉資金】:如果VAR8<0,返回VAR9,否則返回0,線寬為0,PRECISION1,COLORCCFF
    當滿足條件【加倉資金】>0時,在0和4位置之間畫柱狀線,寬度為6,0不為0則畫空心柱.,COLORCCFF
    當滿足條件警戒時,在-0和-4位置之間畫柱狀線,寬度為6,0不為0則畫空心柱.,COLORFF00BB
    輸出【BS有未來】:40,POINTDOT,PRECISION1,COLORCCCCCC
    0,線寬為2,COLORCCCCCC
    ?

    源碼:

    【獲利縱橫】:EMA(WINNER(CLOSE)*60,5),LINETHICK1,PRECISION1,colorFFFF;
    【活籌】:EMA((WINNER(CLOSE*1.08)-WINNER(CLOSE*0.92))*80,5),LINETHICK1,PRECISION1,colorFFFFFF;
    RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
    K:=SMA(RSV,3,1);
    D:=SMA(K,3,1);
    J:=2.5*K-3*D;
    VAR1:=ZIG(3,14);
    VA2:=EMA(EMA(WINNER(CLOSE)*CLOSE,3),3);
    控籌:=(VA2-REF(VA2,1))/REF(VA2,1)*1000;
    VAR2:=LLV(LOW,27);
    VAR3:=HHV(HIGH,34);
    VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*25;
    【決殺B點】:IF(REF(VAR1,2)>REF(VAR1,1) AND VAR1>REF(VAR1,1) AND 控籌>REF(控籌,1) AND J>REF(J,1),40,10),LINETHICK1,PRECISION0,colorFF;
    【決殺S點】:IF(REF(VAR1,2)<REF(VAR1,1) AND VAR1<REF(VAR1,1) AND 控籌<REF(控籌,1) AND J<REF(J,1),40,55),PRECISION0,colorFF00;
    DRAWTEXT(CROSS(【決殺B點】,40),9,'〖買入〗'),colorFF;
    DRAWTEXT(CROSS(【決殺S點】,40),60,'〖賣出〗'),colorFF00;
    建倉:IF(VAR4<10,-6,0),LINETHICK2,PRECISION0,colorFFFFBB;
    低吸:IF(VAR4<30,-6,0),LINETHICK2,PRECISION0,colorFFFF00;
    警戒:IF(VAR4>92,-6,0),LINETHICK0,PRECISION0,colorFF00BB;
    VAR5:=100-3*SMA((CLOSE-LLV(LOW,72))/(HHV(HIGH,72)-LLV(LOW,72))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,72))/(HHV(HIGH,72)-LLV(LOW,72))*100,20,1),15,1);
    VAR6:=100-3*SMA((OPEN-LLV(LOW,72))/(HHV(HIGH,72)-LLV(LOW,72))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,72))/(HHV(HIGH,72)-LLV(LOW,72))*100,20,1),15,1);
    VAR7:=VAR5<REF(VAR6,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
    DRAWTEXT(VAR7 AND COUNT(VAR7,30)=1,40,'▲〖大資金進場〗'),color99FF;
    VAR8:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
    VAR9:=2*ABS(VAR8);
    【加倉資金】:IF(VAR8<0,VAR9,0),LINETHICK0,PRECISION1,colorCCFF;
    STICKLINE(【加倉資金】>0,0,4,6,0),colorCCFF;
    STICKLINE(警戒,-0,-4,6,0),colorFF00BB;
    【BS有未來】:40,POINTDOT,PRECISION1,colorCCCCCC;
    0,LINETHICK2,colorCCCCCC;

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

    怎么收費,代編流程等詳情請點擊查閱!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>