• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

    超級主力建倉副圖指標公式源碼[通達信公式]

    相關標簽: 主力建倉主圖指標公式 、 監控主力增倉減倉指標 、 通達信主力買賣指標 、 通達信zljc指標源碼 、 通達信最牛主升浪指標 、 通達信達小盤股輪動指標 、 主力游資進入指標源碼 、 通達信超級主力建倉指標 、 超級主力指標 、 機構游資建倉出貨指標 、 主力機構超級單指標 、 縮短就漲指標公式 、

    ?

    超級主力建倉(源碼 副圖 通達信 貼圖)

    原理解析:

    VAR1賦值:9日內最高價的最高值-9日內最低價的最低值
    VAR2賦值:9日內最高價的最高值-收盤價
    VAR3賦值:收盤價-9日內最低價的最低值
    VAR4賦值:((VAR2)/(VAR1))*(100)-70
    VAR6賦值:((2)*(收盤價)+最高價+最低價)/(4)
    VAR7賦值:((VAR3)/(VAR1))*(100)的3日[1日權重]移動平均
    VAR8賦值:34日內最低價的最低值
    VAR9賦值:VAR7的3日[1日權重]移動平均-VAR4的9日[1日權重]移動平均
    VAR10賦值:如果(VAR9>100),返回VAR9-100,否則返回0
    VAR11賦值:34日內最高價的最高值
    B1賦值:((VAR6-VAR8)/(VAR11-VAR8))*(100)的8日指數移動平均
    機構趨勢賦值:B1的13日指數移動平均
    當滿足條件B1-機構趨勢>0時,在B1和機構趨勢位置之間畫柱狀線,寬度為3,1不為0則畫空心柱.,COLOR0000FF
    當滿足條件B1-機構趨勢<0時,在B1和機構趨勢位置之間畫柱狀線,寬度為3,0不為0則畫空心柱.,COLOR00FF00
    V1賦值:(收盤價*2+最高價+最低價)/4*10
    V2賦值:V1的13日指數移動平均-V1的34日指數移動平均
    V3賦值:V2的5日指數移動平均
    V4賦值:2*(V2-V3)*5.5
    V11賦值:3*(收盤價-55日內最低價的最低值)/(55日內最高價的最高值-55日內最低價的最低值)*100的5日[1日權重]移動平均-2*(收盤價-55日內最低價的最低值)/(55日內最高價的最高值-55日內最低價的最低值)*100的5日[1日權重]移動平均的3日[1日權重]移動平均
    V12賦值:(V11的3日指數移動平均-1日前的V11的3日指數移動平均)/1日前的V11的3日指數移動平均*100
    當滿足條件V11的3日指數移動平均<=13ANDV12>13時,在0和50位置之間畫柱狀線,寬度為3,0不為0則畫空心柱.,畫紅色
    BBO賦值: (V11的3日指數移動平均<=13 AND V12>13) AND (V11的3日指數移動平均<=13ANDV12>13)的10日過濾
    當滿足條件BBO時,在60位置書寫文字,畫白色
    當滿足條件V11的3日指數移動平均>60ANDEMA(V11,3)>1日前的V11的3日指數移動平均時,在100和95位置之間畫柱狀線,寬度為15,1不為0則畫空心柱.,畫綠色
    CCO賦值:(V11的3日指數移動平均>=90 AND V12) AND (V11的3日指數移動平均>=90ANDV12)的10日過濾
    AA賦值:(開盤價+最高價+最低價+收盤價)/4
    BB賦值:AA的3日簡單移動平均
    CC賦值:如果AA>1日前的AA,返回AA*成交量(手),否則返回0的4日累和/如果AA<1日前的AA,返回AA*成交量(手),否則返回0的4日累和
    DD賦值:1日前的100-(100/(1+CC))
    A1N賦值:10日內AA的最高值
    A2N賦值:30日內AA的最低值
    A3N賦值:A1N-A2N
    A4N賦值:(AA-A2N)/A3N的1日指數移動平均*100
    B1N賦值:16日內AA的最高值
    B2N賦值:90日內AA的最低值
    B3N賦值:B1N-B2N
    B4N賦值:(AA-B2N)/B3N的1日指數移動平均*100
    當滿足條件A4N>90ANDB4N>70時,在86和94位置之間畫柱狀線,寬度為3,0不為0則畫空心柱.,畫黃色
    當滿足條件A4N>90ANDB4N>70時,在90位置畫1號圖標
    VARE賦值:1日前的最低價*0.9
    VARF賦值:最低價*0.9
    VAR12賦值:(VARF*成交量(手)+VARE*(當前流通股本(手)-成交量(手)))/當前流通股本(手)
    VAR13賦值:VAR12的30日指數移動平均
    VAR14賦值:收盤價-1日前的收盤價
    VAR15賦值:VAR14和0的較大值
    VAR16賦值:VAR14的絕對值
    VAR17賦值:VAR15的7日[1日權重]移動平均/VAR16的7日[1日權重]移動平均*100
    VAR18賦值:VAR15的13日[1日權重]移動平均/VAR16的13日[1日權重]移動平均*100
    VAR19賦值:收盤價的有效數據周期數
    VAR20賦值:VAR14和0的較大值的6日[1日權重]移動平均/VAR14的絕對值的6日[1日權重]移動平均*100
    VAR21賦值:(-200)*(60日內最高價的最高值-收盤價)/(60日內最高價的最高值-60日內最低價的最低值)+100
    VAR1A賦值:(收盤價-15日內最低價的最低值)/(15日內最高價的最高值-15日內最低價的最低值)*100
    VAR1B賦值:(VAR1A的4日[1日權重]移動平均-50)*2的3日[1日權重]移動平均
    VAR1C賦值:(大盤的收盤價-14日內大盤的最低價的最低值)/(14日內大盤的最高價的最高值-14日內大盤的最低價的最低值)*100
    VAR1D賦值:VAR1C的4日[1日權重]移動平均
    VAR1E賦值:VAR1D的3日[1日權重]移動平均
    VAR1F賦值:(30日內最高價的最高值-收盤價)/收盤價*100
    VAR22賦值:VAR20<=25 AND VAR21<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-收盤價>=-0.25 AND VAR17<22 AND VAR18<28 AND VAR19>50
    當滿足條件VAR22時,在0和70位置之間畫柱狀線,寬度為3,0不為0則畫空心柱.,畫洋紅色
    當滿足條件VAR22上穿0.5ANDCOUNT(VAR22=1,10)=1時,在80位置書寫文字 , 畫洋紅色
    VAREX賦值:100*(收盤價-34日內收盤價的最低值)/(34日內最高價的最高值-34日內最低價的最低值)的5日簡單移動平均-20
    VARFX賦值:100-3*(收盤價-75日內最低價的最低值)/(75日內最高價的最高值-75日內最低價的最低值)*100的20日[1日權重]移動平均+2*(收盤價-75日內最低價的最低值)/(75日內最高價的最高值-75日內最低價的最低值)*100的20日[1日權重]移動平均的15日[1日權重]移動平均
    VAR10X賦值:100-3*(開盤價-75日內最低價的最低值)/(75日內最高價的最高值-75日內最低價的最低值)*100的20日[1日權重]移動平均+2*(開盤價-75日內最低價的最低值)/(75日內最高價的最高值-75日內最低價的最低值)*100的20日[1日權重]移動平均的15日[1日權重]移動平均
    VAR11X賦值:VARF<1日前的VAR10X AND 成交量(手)>1日前的成交量(手) AND 收盤價>1日前的收盤價
    當滿足條件VAR11XANDCOUNT(VAR11X,30)=1時,在70位置書寫文字,線寬為1,畫黃色
    當滿足條件VAR11XANDCOUNT(VAR11X,30)=1時,在1和60位置之間畫柱狀線,寬度為3,0不為0則畫空心柱.,畫黃色
    ?

    源碼:

    VAR1:=HHV(HIGH,9)-LLV(LOW,9);VAR2:=HHV(HIGH,9)-CLOSE;VAR3:=CLOSE-LLV(LOW,9);VAR4:=((VAR2)/(VAR1))*(100)-70;VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);VAR8:=LLV(LOW,34);VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);VAR10:=IF((VAR9>100),VAR9-100,0);VAR11:=HHV(HIGH,34);B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);機構趨勢:=EMA(B1,13);STICKLINE(B1-機構趨勢>0,B1,機構趨勢,3,1),COLOR0000FF;STICKLINE(B1-機構趨勢<0,B1,機構趨勢,3,0),COLOR00FF00;{分析家公式網www.8 8gs.co m}V1:=(C*2+H+L)/4*10;V2:=EMA(V1,13)-EMA(V1,34);V3:=EMA(V2,5);V4:=2*(V2-V3)*5.5;V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);V12:=(EMA(V11,3)-REF(EMA(V11,3),1))/REF(EMA(V11,3),1)*100;STICKLINE(EMA(V11,3)<=13 AND V12>13,0,50,3,0),COLORRED;BBO:= (EMA(V11,3)<=13 AND V12>13) AND FILTER((EMA(V11,3)<=13 AND V12>13),10);DRAWTEXT (BBO,60,'主力進'),COLORWHITE;STICKLINE(EMA(V11,3)>60 AND EMA(V11,3)>REF(EMA(V11,3),1),100,95,15,1),COLORGREEN;CCO:=(EMA(V11,3)>=90 AND V12) AND FILTER((EMA(V11,3)>=90 AND V12),10);AA:=(O+H+L+C)/4;BB:=MA(AA,3);CC:=SUM(IF(AA>REF(AA,1),AA*VOL,0),4)/SUM(IF(AA<REF(AA,1),AA*VOL,0),4);DD:=REF(100-(100/(1+CC)),1);A1N:=HHV(AA,10);A2N:=LLV(AA,30);A3N:=A1N-A2N;A4N:=EMA((AA-A2N)/A3N,1)*100;B1N:=HHV(AA,16);B2N:=LLV(AA,90);B3N:=B1N-B2N;B4N:=EMA((AA-B2N)/B3N,1)*100;STICKLINE(A4N>90 AND B4N>70,86,94,3,0),COLORYELLOW;DRAWICON(A4N>90 AND B4N>70,90,1);VARE:=REF(LOW,1)*0.9;VARF:=LOW*0.9;VAR12:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;VAR13:=EMA(VAR12,30);VAR14:=CLOSE-REF(CLOSE,1);VAR15:=MAX(VAR14,0);VAR16:=ABS(VAR14);VAR17:=SMA(VAR15,7,1)/SMA(VAR16,7,1)*100;VAR18:=SMA(VAR15,13,1)/SMA(VAR16,13,1)*100;VAR19:=BARSCOUNT(CLOSE);VAR20:=SMA(MAX(VAR14,0),6,1)/SMA(ABS(VAR14),6,1)*100;VAR21:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;VAR1D:=SMA(VAR1C,4,1);VAR1E:=SMA(VAR1D,3,1);VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;VAR22:=VAR20<=25 AND VAR21<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR17<22 AND VAR18<28 AND VAR19>50;STICKLINE(VAR22,0,70,3,0),COLORMAGENTA;DRAWTEXT(CROSS(VAR22,0.5) AND COUNT(VAR22=1,10)=1,80,'超級主力建倉!') , COLORMAGENTA;VAREX:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;VARFX:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);VAR10X:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);VAR11X:=VARF<REF(VAR10X,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);DRAWTEXT(VAR11X AND COUNT(VAR11X,30)=1,70,'大資金進場'),LINETHICK1,COLORYELLOW;STICKLINE(VAR11X AND COUNT(VAR11X,30)=1,1,60,3,0),COLORYELLOW;

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

    怎么收費,代編流程等詳情請點擊查閱!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>