• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

    乾坤線指標公式代碼[大智慧公式]

    相關標簽: 通達信乾坤線指標 、 乾坤線指標用法 、 三線定乾坤指標源碼 、 乾坤三線指標公式 、 通達信乾坤線主圖指標公式 、 大智慧乾坤線指標公式 、 能抓板的乾坤線指標公式 、 主力乾坤指標線怎么看 、 雙龍乾坤線指標公式 、 乾坤線指標公式源代碼 、 乾坤線為多少日均線 、 通達信乾坤趨勢線指標公式 、

    原理解析:

    VAR1賦值:如果(日期<1090601)AND(日期>931208),返回1,否則返回0
    HH賦值:250日內最高價的最高值
    LL賦值:250日內最低價的最低值
    E賦值:(HH-LL)/(100)
    GJ賦值:如果(收盤價>=100),返回(收盤價+最高價+最低價+開盤價)/(4),否則返回((成交額(元))/(成交量(手)+0.01))/(100)
    明日阻力賦值:最低價+GJ-最低價+收盤價-最低價
    明日支撐賦值:最低價+收盤價-GJ
    今日阻力賦值:1日前的明日阻力
    今日支撐賦值:1日前的明日支撐
    輸出價值中樞:VAR1,COLOR00B700
    輸出價格中樞:(最高價的5日指數移動平均的5日指數移動平均的4日指數移動平均)*(VAR1),COLOR00B700
    CJ賦值:(((3)*(收盤價)+最低價+開盤價+最高價)/(6))*(VAR1)
    波段線賦值:(((20)*(CJ)+(19)*(1日前的CJ)+(18)*(2日前的CJ)+(17)*(3日前的CJ)+(16)*(4日前的CJ)+(15)*(5日前的CJ)+(14)*(6日前的CJ)+(13)*(7日前的CJ)+(12)*(8日前的CJ)+(11)*(9日前的CJ)+(10)*(10日前的CJ)+(9)*(11日前的CJ)+(8)*(12日前的CJ)+(7)*(13日前的CJ)+(6)*(14日前的CJ)+(5)*(15日前的CJ)+(4)*(16日前的CJ)+(3)*(17日前的CJ)+(2)*(18日前的CJ)+20日前的CJ)/(210))*(VAR1)
    VAR11賦值:((最高價+最低價+開盤價+收盤價)/(4))*(VAR1)
    頂線賦值:((最高價的5日指數移動平均的5日指數移動平均的4日指數移動平均)*(1.1))*(VAR1)
    界賦值:收盤價的21日簡單移動平均
    上限賦值:界+(2)*(收盤價的20日估算標準差)
    底線賦值:界-(2)*(收盤價的20日估算標準差)
    QSX賦值:((3)*(VAR11)-(2)*(VAR11的2日[1日權重]移動平均)的12日指數移動平均)*(VAR1)
    當滿足條件(收盤價<波段線)時,在HH+HH和0位置之間畫柱狀線,寬度為8,0不為0則畫空心柱.,COLOR002800
    當滿足條件(收盤價>=波段線)時,在HH+HH和0位置之間畫柱狀線,寬度為8,0不為0則畫空心柱.,COLOR640032
    KDJMACD1賦值:(最高價+最低價+開盤價+收盤價)/(4)
    KDJMACD3賦值:(2)*(8日內KDJMACD1的最低值的13日指數移動平均)-KDJMACD1
    輸出趨勢線:QSX,COLOR008000
    輸出乾坤線:(3)*(KDJMACD3)-(2)*(KDJMACD3的9日[1日權重]移動平均),COLOR00B700
    X2賦值:收盤價
    X3賦值:乾坤線
    當滿足條件(X2>=X3)時,在最低價和最高價位置之間畫柱狀線,寬度為0.1,0不為0則畫空心柱.,COLOR0000FF
    當滿足條件(X2>=X3)時,在收盤價和開盤價位置之間畫柱狀線,寬度為4.5,0不為0則畫空心柱.,COLOR0000AA
    當滿足條件(X2>=X3)時,在收盤價和開盤價位置之間畫柱狀線,寬度為3,0不為0則畫空心柱.,COLOR0000CC
    當滿足條件(X2>=X3)時,在收盤價和開盤價位置之間畫柱狀線,寬度為2,0不為0則畫空心柱.,COLOR0000DD
    當滿足條件(X2>=X3)時,在收盤價和開盤價位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,COLOR0000FF
    當滿足條件(X2<X3)時,在收盤價和開盤價位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,COLOREEEE00
    當滿足條件(X2<X3)時,在收盤價和開盤價位置之間畫柱狀線,寬度為2,0不為0則畫空心柱.,COLORDDDD00
    當滿足條件(X2<X3)時,在收盤價和開盤價位置之間畫柱狀線,寬度為3,0不為0則畫空心柱.,COLORCCCC00
    當滿足條件(X2<X3)時,在收盤價和開盤價位置之間畫柱狀線,寬度為4.5,0不為0則畫空心柱.,COLORAAAA00
    當滿足條件(X2<X3)時,在最低價和最高價位置之間畫柱狀線,寬度為0.1,0不為0則畫空心柱.,COLORFFFF00
    ?

    源碼:

    VAR1:=IF((DATE<1090601) AND (DATE>931208),1,0);
    HH:=HHV(HIGH,250);
    LL:=LLV(LOW,250);
    E:=(HH-LL)/(100);
    GJ:=IF((CLOSE>=100),(CLOSE+HIGH+LOW+OPEN)/(4),((AMOUNT)/(VOL+0.01))/(100));
    明日阻力:=LOW+GJ-LOW+CLOSE-LOW;
    明日支撐:=LOW+CLOSE-GJ;
    今日阻力:=REF(明日阻力,1);
    今日支撐:=REF(明日支撐,1);
    價值中樞:VAR1,CoLor00B700;
    價格中樞:(EMA(EMA(EMA(HIGH,5),5),4))*(VAR1),CoLor00B700;
    CJ:=(((3)*(CLOSE)+LOW+OPEN+HIGH)/(6))*(VAR1);
    波段線:=(((20)*(CJ)+(19)*(REF(CJ,1))+(18)*(REF(CJ,2))+(17)*(REF(CJ,3))+(16)*(REF(CJ,4))+(15)*(REF(CJ,5))+(14)*(REF(CJ,6))+(13)*(REF(CJ,7))+(12)*(REF(CJ,8))+(11)*(REF(CJ,9))+(10)*(REF(CJ,10))+(9)*(REF(CJ,11))+(8)*(REF(CJ,12))+(7)*(REF(CJ,13))+(6)*(REF(CJ,14))+(5)*(REF(CJ,15))+(4)*(REF(CJ,16))+(3)*(REF(CJ,17))+(2)*(REF(CJ,18))+REF(CJ,20))/(210))*(VAR1);
    VAR11:=((HIGH+LOW+OPEN+CLOSE)/(4))*(VAR1);
    頂線:=((EMA(EMA(EMA(HIGH,5),5),4))*(1.1))*(VAR1);
    界:=MA(CLOSE,21);
    上限:=界+(2)*(STD(CLOSE,20));
    底線:=界-(2)*(STD(CLOSE,20));
    QSX:=(EMA((3)*(VAR11)-(2)*(SMA(VAR11,2,1)),12))*(VAR1);
    STICKLINE((CLOSE<波段線),HH+HH,0,8,0),CoLor002800;
    STICKLINE((CLOSE>=波段線),HH+HH,0,8,0),CoLor640032;
    KDJMACD1:=(HIGH+LOW+OPEN+CLOSE)/(4);
    KDJMACD3:=(2)*(EMA(LLV(KDJMACD1,8),13))-KDJMACD1;
    趨勢線:QSX,CoLor008000;
    乾坤線:(3)*(KDJMACD3)-(2)*(SMA(KDJMACD3,9,1)),CoLor00B700;
    X2:=CLOSE;
    X3:=乾坤線;
    STICKLINE((X2>=X3),LOW,HIGH,0.1,0),CoLor0000FF;
    STICKLINE((X2>=X3),CLOSE,OPEN,4.5,0),CoLor0000AA;
    STICKLINE((X2>=X3),CLOSE,OPEN,3,0),CoLor0000CC;
    STICKLINE((X2>=X3),CLOSE,OPEN,2,0),CoLor0000DD;
    STICKLINE((X2>=X3),CLOSE,OPEN,1,0),CoLor0000FF;
    STICKLINE((X2<X3),CLOSE,OPEN,1,0),CoLorEEEE00;
    STICKLINE((X2<X3),CLOSE,OPEN,2,0),CoLorDDDD00;
    STICKLINE((X2<X3),CLOSE,OPEN,3,0),CoLorCCCC00;
    STICKLINE((X2<X3),CLOSE,OPEN,4.5,0),CoLorAAAA00;
    STICKLINE((X2<X3),LOW,HIGH,0.1,0),CoLorFFFF00;

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

    怎么收費,代編流程等詳情請點擊查閱!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>