• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 其他>> 其他軟件公式>>正文內容

    千鈞贏富【升級版】[其他軟件公式]

    相關標簽:止贏止損線指標公式 、 文華財經順贏指標公式 、 贏在龍頭指標公式大全 、 啟富主圖指標公式 、 大智慧超贏指標公式 、 贏富數據 、 贏富網 、 富贏天下 、 操盤軟件富贏版 、 操盤軟件富贏版v8 、 操盤手富贏版v7 、 操盤手富贏版v8 、

    ?

    千鈞贏富【升級版】---公式需要擴展數據和引用公式,否則不會顯示首先向千鈞老師致謝!!!長期來本人一直關注你的原創,并一直用上.自你的贏富升級版推出,就覺得什么地方可以改進,于是馬上改了一傍晚,相對滿意.但應時間已有一個多月,大致修改思路:1\能顯示到最新交易周期;
    2\增加當天分筆圖形;
    3\修改顯示值百分比,以看直觀.
    4\不改變千鈞老師的原碼.
    下面是原碼和帖圖以饗千鈞徒,請千鈞老師斧正:
    {程序化交易 www.planetbokep.com }
    {程序化交易 www.planetbokep.com }
    原碼:

    {千鈞贏富【升級版】---本人優化版}
    流通:FINANCE(7)/10000,LINETHICK0,PRECISION2,Color00BFFF;
    換手:v/FINANCE(7),PRECISION2,LINETHICK0;
    qj1:=EXTDATA(9);qj2:=EXTDATA(10);qj3:=EXTDATA(11);
    qj4:=EXTDATA(12);qj5:=EXTDATA(13);
    ZL:=qj1+qj2+qj3;SH:=qj4+qj5;昨日:=REF(qj1+qj2+qj3,1);
    總:=(ABS(qj1)+ABS(qj2)+ABS(qj3)+ABS(qj4)+ABS(qj5))*1.6;
    日增:=ZL;
    周倉:=SUM(日增,5);月倉:=SUM(日增,22);年倉:=SUM(日增,240);
    上周:=REF(周倉,1);上月:=REF(月倉,1);上年:=REF(年倉,1);
    周增:=周倉-上周;月增:=月倉-上月;年增:=年倉-上年;
    CM:=sum(zl,5);ZJ:=sum(昨日,5);
    ZSA:=cm/IF(CAPITAL=0,ESTDATA(12),FINANCE(7));
    ZSB:=(cm-ZJ)/IF(CAPITAL=0,ESTDATA(12),FINANCE(7));
    {取點}
    DIFF:=MA(CLOSE,5)-EMA(CLOSE,55);
    DEA:=MA(DIFF,14);
    jg:=((close-llv(L,34))/(HHV(h,34)-llV(L,34)))*100;
    yh:=CROSS(diff,dea) and jg<20;
    bh:=CROSS(dea,diff) and jg>60;
    SW:=yh=1;SS:=bh=1;
    VERTLINE(sw),COLOR0000FF,LINEDOT;
    VERTLINE(ss),COLOR00FF00,LINEDOT;A:=barslast(SW);B:=barslast(SS);
    起點:=if(A>1 and A<=B,A,0);終點:=if(B>1 and B<=A,B,0);
    主力成本:=SUM(C*zl*100,5)/SUM(zl,5)/100;
    {控制畫線高度}
    n1:=sysparam(3);nn:=n1-sysparam(2)+1;
    hh:=hhv(總,nn);
    ll:=llv(總,nn);
    最高:=hh[n1];最低:=ll[n1];中:=最低+(最高-最低)*0.5;
    {方框豎線}
    {框內黑底}
    STICKLINE(BARPOS=SYSPARAM(1)-20,0,中,200,0),SHIFT10,COLOR000000;
    STICKLINE(BARPOS=SYSPARAM(1)-20,0,中*2.1,200,0),SHIFT10,COLOR000000;
    {加右框}
    STICKLINE(ISLASTBAR AND CLOSE>0,中/9,中*17/9,80,1),SHIFT5,COLORred;
    STICKLINE(ISLASTBAR AND CLOSE>0,中/9,中*17/9,28,1),SHIFT8,COLORred;

    {豎線}
    VERTLINE(BARPOS=SYSPARAM(1)),COLOREE00EE,LINETHICK2;
    VERTLINE(BARPOS=SYSPARAM(1)-20),{SHIFT20,}COLOREE00EE,LINETHICK2;
    {顯示時間}
    variable:wday[7]='星期六';wday[1]:='星期日';wday[2]:='星期一';
    wday[3]:='星期二';wday[4]:='星期三';wday[5]:='星期四';wday[6]:='星期五';
    fy:=年份;fm:=月份;fd:=日期;wd:=星期;p:=系統參數(1);
    str1:=''+numtostr(fy[p],0)+'年'+numtostr(fm[p],0)+'月'+數字轉化為字符串(fd[p],0)+'日 '+wday[wd[p]+1];
    DRAWTEXTEX(c,1,180,0,str1),ColorffFF00;

    {贏富柱}
    {STICKLINE(BARPOS=SYSPARAM(1),中*2.1,中*2.1,200,0),COLOREE00EE,SHIFT10;
    STICKLINE(BARPOS=SYSPARAM(1),中,中,200,0),COLOR660066,SHIFT10;
    STICKLINE(BARPOS=SYSPARAM(1),中*0.0001,中*0.0001,200,0),COLOREE00EE,SHIFT10;
    STICKLINE(BARPOS=SYSPARAM(1)+2 and qj1>0,中,(中+qj1),30,0),COLOR0000FF;
    STICKLINE(BARPOS=SYSPARAM(1)+2 and qj1<0,中,中+(qj1*-1),30,0),COLORFF6600;
    STICKLINE(BARPOS=SYSPARAM(1)+6 and qj2>0,中,(中+qj2),30,0),COLOR0000FF;
    STICKLINE(BARPOS=SYSPARAM(1)+6 and qj2<0,中,中+(qj2*-1),30,0),COLORFF6600;
    STICKLINE(BARPOS=SYSPARAM(1)+10 and qj3>0,中,(中+qj3),30,0),COLOR0000ff;
    STICKLINE(BARPOS=SYSPARAM(1)+10 and qj3<0,中,中+(qj3*-1),30,0),COLORFF6600;
    STICKLINE(BARPOS=SYSPARAM(1)+14 and qj4>0,中,中+(qj4),30,0),COLOR0000FF;
    STICKLINE(BARPOS=SYSPARAM(1)+14 and qj4<0,中,中+(qj4*-1),30,0),COLORFF6600;
    STICKLINE(BARPOS=SYSPARAM(1)+18 and qj5>0,中,中+(qj5),30,0),COLOR0000FF;
    STICKLINE(BARPOS=SYSPARAM(1)+18 and qj5<0,中,中+(qj5*-1),30,0),COLORFF0000;}
    {贏富柱修改}
    {橫線}
    STICKLINE(BARPOS=SYSPARAM(1)-10,中*2.1,中*2.1,200,0),COLOREE00EE{,SHIFT10};
    STICKLINE(BARPOS=SYSPARAM(1)-10,中,中,200,0),COLOR660066{,SHIFT10};
    STICKLINE(BARPOS=SYSPARAM(1)-10,中*0.0001,中*0.0001,200,0),COLOREE00EE{,SHIFT10};

    STICKLINE(BARPOS=SYSPARAM(1)-18 and qj1>0,中,(中+qj1),30,0),COLOR0000FF;
    STICKLINE(BARPOS=SYSPARAM(1)-18 and qj1<0,中,中+(qj1*-1),30,0),COLORFF6600;
    STICKLINE(BARPOS=SYSPARAM(1)-14 and qj2>0,中,(中+qj2),30,0),COLOR0000FF;
    STICKLINE(BARPOS=SYSPARAM(1)-14 and qj2<0,中,中+(qj2*-1),30,0),COLORFF6600;
    STICKLINE(BARPOS=SYSPARAM(1)-10 and qj3>0,中,(中+qj3),30,0),COLOR0000ff;
    STICKLINE(BARPOS=SYSPARAM(1)-10 and qj3<0,中,中+(qj3*-1),30,0),COLORFF6600;
    STICKLINE(BARPOS=SYSPARAM(1)-6 and qj4>0,中,中+(qj4),30,0),COLOR0000FF;
    STICKLINE(BARPOS=SYSPARAM(1)-6 and qj4<0,中,中+(qj4*-1),30,0),COLORFF6600;
    STICKLINE(BARPOS=SYSPARAM(1)-2 and qj5>0,中,中+(qj5),30,0),COLOR0000FF;
    STICKLINE(BARPOS=SYSPARAM(1)-2 and qj5<0,中,中+(qj5*-1),30,0),COLORFF0000;

    {DRAWTEXT(BARPOS=SYSPARAM(1)+1,中,'機\n構\n'+NUMTOSTR(qj1[SYSPARAM(1)]/v,2)),PXDN12,COLORWHITE;
    DRAWTEXT(BARPOS=SYSPARAM(1)+5,中,'券\n商\n'+NUMTOSTR(qj2[SYSPARAM(1)]/v,2)),PXDN12,COLORWHITE;
    DRAWTEXT(BARPOS=SYSPARAM(1)+9,中,'大\n戶\n'+NUMTOSTR(qj3[SYSPARAM(1)]/v,2)),PXDN12,COLORWHITE;
    DRAWTEXT(BARPOS=SYSPARAM(1)+13,中,'中\n戶\n'+NUMTOSTR(qj4[SYSPARAM(1)]/v,2)),PXDN12,COLORWHITE;
    DRAWTEXT(BARPOS=SYSPARAM(1)+17,中,'散\n戶\n'+NUMTOSTR(qj5[SYSPARAM(1)]/v,2)),PXDN12,COLORWHITE;}

    DRAWTEXT(BARPOS=SYSPARAM(1)-19,中,'機\n構\n'+NUMTOSTR(qj1[SYSPARAM(1)]/v,2)),PXDN12,COLORWHITE;
    DRAWTEXT(BARPOS=SYSPARAM(1)-15,中,'券\n商\n'+NUMTOSTR(qj2[SYSPARAM(1)]/v,2)),PXDN12,COLORWHITE;
    DRAWTEXT(BARPOS=SYSPARAM(1)-11,中,'大\n戶\n'+NUMTOSTR(qj3[SYSPARAM(1)]/v,2)),PXDN12,COLORWHITE;
    DRAWTEXT(BARPOS=SYSPARAM(1)-7,中,'中\n戶\n'+NUMTOSTR(qj4[SYSPARAM(1)]/v,2)),PXDN12,COLORWHITE;
    DRAWTEXT(BARPOS=SYSPARAM(1)-3,中,'散\n戶\n'+NUMTOSTR(qj5[SYSPARAM(1)]/v,2)),PXDN12,COLORWHITE;
    {柱上顯示數值}
    {DRAWTEXT(BARPOS=SYSPARAM(1)-20{ and qj1>0},(中+qj1),NUMTOSTR(qj1[SYSPARAM(1)]/100,2)),PXUP38,ALIGN1,COLORWHITE;}

    STICKLINE(SH>0,0,SH,8,0),Coloraa00aa;
    STICKLINE(SH>0,0,SH,6,0),Colorcc00cc;
    STICKLINE(SH>0,0,SH,3,0),Coloree00ee;
    散戶買:STICKLINE(SH>0,0,SH,1,0),Colorff00FF;
    STICKLINE(SH<0,0,-SH,8,0),ColorFF4400;
    STICKLINE(SH<0,0,-SH,6,0),ColorFF8800;
    STICKLINE(SH<0,0,-SH,3,0),ColorFFaa00;
    散戶賣:STICKLINE(SH<0,0,-SH,1,0),ColorFFcc00;
    STICKLINE(ZL>0,0,ZL,8,0),Color000044;
    STICKLINE(ZL>0,0,ZL,6,0),Color000088;
    STICKLINE(ZL>0,0,ZL,3,0),Color0000aa;
    主力買:STICKLINE(ZL>0,0,ZL,1,0),Color0000FF;
    STICKLINE(ZL<0,0,-ZL,8,0),Color004400;
    STICKLINE(ZL<0,0,-ZL,6,0),Color008800;
    STICKLINE(ZL<0,0,-ZL,3,0),Color00aa00;
    主力賣:STICKLINE(ZL<0,0,-ZL,1,0),Color00FF00;

    DRAWTEXTEX(c,1,25,0,STKLABEL+' '+STKNAME+''),ColorffFF00;
    DRAWTEXTEX(c,1,400,100,'估算籌碼:'+NUMTOSTR(ZSA[P],2)+'%'),COLOR00FF00;
    DRAWTEXTEX(c,1,180,100,'籌碼增減:'+NUMTOSTR(ZSB[P],2)+'%'),COLOR00FF00;
    DRAWTEXTEX(c,1,590,0,'主力開始進入:'+NUMTOSTR(起點[P],0)+'(天) '),COLORFFFF00;
    DRAWTEXTEX(c,1,400,0,'主力進入回吐:'+NUMTOSTR(終點[P],0)+'(天) '),COLORFFFF00;
    DRAWTEXTEX(c,1,590,100,'主力成本:'+NUMTOSTR(主力成本[SYSPARAM(1)],2)+'元'),COLOR00FF00;
    DRAWTEXTEX(SH>ZL and SH>0,1,40,100,'本日散戶主買'),COLOREEEEEE;
    DRAWTEXTEX(ZL>SH and ZL>0,1,40,100,'本日主力主買'),COLOR00FFFF;
    DRAWTEXTEX(SH<ZL and SH<0,1,40,230,'本日散戶主賣'),COLORFFEE00;
    DRAWTEXTEX(ZL<SH and ZL<0,1,40,230,'本日主力主賣'),COLOR00FF00;
    //機構線:ma(ZL,5);散戶線:ema(機構線,5);
    {增減倉}
    日均:=AMOUNT/vol/100;周均:=ref(日均,BARSLAST(WEEKDAY>ref(WEEKDAY,1)));
    月均:=ref(日均,BARSLAST(MONTH>ref(MONTH,1)));
    年均:=ref(日均,BARSLAST(YEAR>ref(YEAR,1)));
    {解盤}
    EXPLAIN(1,'==================================='),colorwhite;EXPLAIN(1,'本日主力凈買:'+NUMTOSTR((ZL*100)/10000,2)+' 萬股'),COLOrffff00;
    EXPLAIN(1,'昨日主力增減:'+NUMTOSTR(昨日*100*日均/10000,2)+' 萬元'),ColorFF8B00;
    EXPLAIN(1,'==================================='),colorwhite;EXPLAIN(1,'上周:'+NUMTOSTR(上周*100/10000,2)+' 萬股'),COLORred;
    EXPLAIN(1,'增減:'+NUMTOSTR(周增*100*周均/10000,2)+' 萬元'),COLORred;
    EXPLAIN(1,'==================================='),colorwhite;EXPLAIN(1,'上月:'+NUMTOSTR(上月*100/10000,2)+' 萬股'),COLORFF00FF;
    EXPLAIN(1,'增減:'+NUMTOSTR(月增*100*月均/10000,2)+' 萬元'),COLORFF00FF;
    EXPLAIN(1,'==================================='),colorwhite;EXPLAIN(1,'上年:'+NUMTOSTR(上年*100/10000,2)+' 萬股'),COLOR00EE00;
    EXPLAIN(1,'增減:'+NUMTOSTR(年增*100*年均/10000,2)+' 萬元'),COLOR00EE00;
    EXPLAIN(1,'==================================='),colorwhite;qj2dt:=STKINDI('','券商.券商',0,0);
    qj3dt:=STKINDI('','大戶.大戶',0,0);
    qj4dt:=STKINDI('','中戶.中戶',0,0);
    qj5dt:=STKINDI('','散戶.散戶',0,0);
    zldt:=qj1dt+qj2dt+qj3dt;
    shdt:=qj4dt+qj5dt;
    {柱}
    STICKLINE(ISLASTBAR AND CLOSE>0 and qj1dt>0 ,中,中+qj1dt,8,0),COLORRED,SHIFT2;
    STICKLINE(ISLASTBAR AND CLOSE>0 and qj2dt>0,中,中+qj2dt,8,0),COLORRED,SHIFT3;
    STICKLINE(ISLASTBAR AND CLOSE>0 and qj3dt>0,中,中+qj3dt,8,0),COLORRED,SHIFT4;
    STICKLINE(ISLASTBAR AND CLOSE>0 and qj4dt>0,中,中+qj4dt,8,0),COLORRED,SHIFT5;
    STICKLINE(ISLASTBAR AND CLOSE>0 and qj5dt>0,中,中+qj5dt,8,0),COLORRED,SHIFT6;

    STICKLINE(ISLASTBAR AND CLOSE>0 and qj1dt<0 ,中,中+(0-qj1dt),8,0),COLORblue,SHIFT2;
    STICKLINE(ISLASTBAR AND CLOSE>0 and qj2dt<0,中,中+(0-qj2dt),8,0),COLORblue,SHIFT3;
    STICKLINE(ISLASTBAR AND CLOSE>0 and qj3dt<0,中,中+(0-qj3dt),8,0),COLORblue,SHIFT4;
    STICKLINE(ISLASTBAR AND CLOSE>0 and qj4dt<0,中,中+(0-qj4dt),8,0),COLORblue,SHIFT5;
    STICKLINE(ISLASTBAR AND CLOSE>0 and qj5dt<0,中,中+(0-qj5dt),8,0),COLORblue,SHIFT6;

    {STICKLINE(ISLASTBAR AND CLOSE>0 and zldt>0,中/2,中/2+zldt,6,0),COLOR22aabb,SHIFT7;
    STICKLINE(ISLASTBAR AND CLOSE>0 and shdt>0,中/2,中/2+shdt,6,0),COLOR22aabb,SHIFT8;}
    STICKLINE(ISLASTBAR AND CLOSE>0 and zldt>0,中/2,中/2+zldt,5,0),COLOR33bbcc,SHIFT7;
    STICKLINE(ISLASTBAR AND CLOSE>0 and shdt>0,中/2,中/2+shdt,5,0),COLOR33bbcc,SHIFT8;
    STICKLINE(ISLASTBAR AND CLOSE>0 and zldt>0,中/2,中/2+zldt,4,0),COLOR44ccdd,SHIFT7;
    STICKLINE(ISLASTBAR AND CLOSE>0 and shdt>0,中/2,中/2+shdt,4,0),COLOR44ccdd,SHIFT8;
    STICKLINE(ISLASTBAR AND CLOSE>0 and zldt>0,中/2,中/2+zldt,3,0),COLOR55ddee,SHIFT7;
    STICKLINE(ISLASTBAR AND CLOSE>0 and shdt>0,中/2,中/2+shdt,3,0),COLOR55ddee,SHIFT8;
    STICKLINE(ISLASTBAR AND CLOSE>0 and zldt>0,中/2,中/2+zldt,2,0),COLOR66eeee,SHIFT7;
    STICKLINE(ISLASTBAR AND CLOSE>0 and shdt>0,中/2,中/2+shdt,2,0),COLOR66eeee,SHIFT8;
    STICKLINE(ISLASTBAR AND CLOSE>0 and zldt>0,中/2,中/2+zldt,1,0),COLOR77ffee,SHIFT7;
    STICKLINE(ISLASTBAR AND CLOSE>0 and shdt>0,中/2,中/2+shdt,1,0),COLOR77ffee,SHIFT8;

    {STICKLINE(ISLASTBAR AND CLOSE>0 and zldt<0,中/2,中/2+(0-zldt),6,0),COLORffaa11,SHIFT7;
    STICKLINE(ISLASTBAR AND CLOSE>0 and shdt<0,中/2,中/2+(0-shdt),6,0),COLORffaa11,SHIFT8;}
    STICKLINE(ISLASTBAR AND CLOSE>0 and zldt<0,中/2,中/2+(0-zldt),5,0),COLORffbb11,SHIFT7;
    STICKLINE(ISLASTBAR AND CLOSE>0 and shdt<0,中/2,中/2+(0-shdt),5,0),COLORffbb11,SHIFT8;
    STICKLINE(ISLASTBAR AND CLOSE>0 and zldt<0,中/2,中/2+(0-zldt),4,0),COLORffcc22,SHIFT7;
    STICKLINE(ISLASTBAR AND CLOSE>0 and shdt<0,中/2,中/2+(0-shdt),4,0),COLORffcc22,SHIFT8;
    STICKLINE(ISLASTBAR AND CLOSE>0 and zldt<0,中/2,中/2+(0-zldt),3,0),COLORffdd22,SHIFT7;
    STICKLINE(ISLASTBAR AND CLOSE>0 and shdt<0,中/2,中/2+(0-shdt),3,0),COLORffdd22,SHIFT8;
    STICKLINE(ISLASTBAR AND CLOSE>0 and zldt<0,中/2,中/2+(0-zldt),2,0),COLORffee33,SHIFT7;
    STICKLINE(ISLASTBAR AND CLOSE>0 and shdt<0,中/2,中/2+(0-shdt),2,0),COLORffee33,SHIFT8;
    STICKLINE(ISLASTBAR AND CLOSE>0 and zldt<0,中/2,中/2+(0-zldt),1,0),COLORffff33,SHIFT7;
    STICKLINE(ISLASTBAR AND CLOSE>0 and shdt<0,中/2,中/2+(0-shdt),1,0),COLORffff33,SHIFT8;

    DRAWTEXT(ISLASTBAR AND CLOSE>0,中,'機\n構\n'+NUMTOSTR(qj1dt*100/v,1)),PXDN12,COLORWHITE,SHIFT2;
    DRAWTEXT(ISLASTBAR AND CLOSE>0,中,'券\n商\n'+NUMTOSTR(qj2dt*100/v,1)),PXDN12,COLORWHITE,SHIFT3;
    DRAWTEXT(ISLASTBAR AND CLOSE>0,中,'大\n戶\n'+NUMTOSTR(qj3dt*100/v,1)),PXDN12,COLORWHITE,SHIFT4;
    DRAWTEXT(ISLASTBAR AND CLOSE>0,中,'中\n戶\n'+NUMTOSTR(qj4dt*100/v,1)),PXDN12,COLORWHITE,SHIFT5;
    DRAWTEXT(ISLASTBAR AND CLOSE>0,中,'散\n戶\n'+NUMTOSTR(qj5dt*100/v,1)),PXDN12,COLORWHITE,SHIFT6;

    DRAWTEXT(ISLASTBAR AND CLOSE>0,中/2,'主\n力\n'+NUMTOSTR(zldt*100/v,1)),PXDN12,COLORWHITE,SHIFT7;
    DRAWTEXT(ISLASTBAR AND CLOSE>0,中/2,'中\n小\n'+NUMTOSTR(shdt*100/v,1)),PXDN12,COLORWHITE,SHIFT8;

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

    怎么收費,代編流程等詳情請點擊查閱!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>