• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

    大牛市準確度90%通達信指標公式[通達信公式]

    相關標簽:

    ?

    通達信指標大牛市準確度90%主圖

    原理解析:

    M1賦值:10
    M2賦值:60
    輸出所屬地域:當滿足條件是否最后一個周期時,在橫軸0.08縱軸0.01位置書寫文字,畫黃色
    輸出所屬行業:當滿足條件是否最后一個周期時,在橫軸0.1縱軸0.01位置書寫文字,畫黃色
    漲跌停賦值:(收盤價-1日前的收盤價)/1日前的收盤價*100
    當滿足條件漲跌停>9.8時,在開盤價和收盤價位置之間畫柱狀線,寬度為3,0不為0則畫空心柱.,畫洋紅色
    當滿足條件漲跌停<-9.8時,在開盤價和收盤價位置之間畫柱狀線,寬度為3,0不為0則畫空心柱.,畫綠色
    HHJSJDA賦值:(3*收盤價+開盤價+最低價+最高價)/6
    輸出HHJSJDB:(20*HHJSJDA+18*1日前的HHJSJDA+18*2日前的HHJSJDA+17*3日前的HHJSJDA+16*4日前的HHJSJDA+15*5日前的HHJSJDA+14*6日前的HHJSJDA+13*7日前的HHJSJDA+12*8日前的HHJSJDA+11*9日前的HHJSJDA+10*10日前的HHJSJDA+9*11日前的HHJSJDA+8*12日前的HHJSJDA+7*13日前的HHJSJDA+6*14日前的HHJSJDA+5*15日前的HHJSJDA+4*16日前的HHJSJDA+3*17日前的HHJSJDA+2*18日前的HHJSJDA+20日前的HHJSJDA)/210,畫黃色
    輸出HHJSJDC:HHJSJDB的5日簡單移動平均,畫紅色
    輸出EXP1:收盤價的M1日指數移動平均,DOTLINE,畫淡藍色
    輸出EXP2:收盤價的M2日指數移動平均,DOTLINE,畫黃色
    VAR1賦值:(收盤價>1日前的收盤價 AND 收盤價>2日前的收盤價)
    VAR2賦值:(1日前的VAR1 AND 收盤價<=1日前的收盤價 AND 收盤價>=2日前的收盤價)
    VAR3賦值:(1日前的VAR2 AND 收盤價>=1日前的收盤價 AND 收盤價<=2日前的收盤價)
    VAR4賦值:(1日前的VAR3 AND 收盤價<=1日前的收盤價 AND 收盤價>=2日前的收盤價)
    VAR5賦值:(1日前的VAR4 AND 收盤價>=1日前的收盤價 AND 收盤價<=2日前的收盤價)
    VAR6賦值:(1日前的VAR5 AND 收盤價<=1日前的收盤價 AND 收盤價>=2日前的收盤價)
    VAR7賦值:(1日前的VAR6 AND 收盤價>=1日前的收盤價 AND 收盤價<=2日前的收盤價)
    VAR8賦值:(1日前的VAR7 AND 收盤價<=1日前的收盤價 AND 收盤價>=2日前的收盤價)
    VAR9賦值:(1日前的VAR8 AND 收盤價>=1日前的收盤價 AND 收盤價<=2日前的收盤價)
    VARA賦值:(1日前的VAR9 AND 收盤價<=1日前的收盤價 AND 收盤價>=2日前的收盤價)
    VARB賦值:(1日前的VARA AND 收盤價>=1日前的收盤價 AND 收盤價<=2日前的收盤價)
    VARC賦值:(1日前的VARB AND 收盤價<=1日前的收盤價 AND 收盤價>=2日前的收盤價)
    VARD賦值:(收盤價<1日前的收盤價 AND 收盤價<2日前的收盤價)
    VARE賦值:(1日前的VARD AND 收盤價>=1日前的收盤價 AND 收盤價<=2日前的收盤價)
    VARF賦值:(1日前的VARE AND 收盤價<=1日前的收盤價 AND 收盤價>=2日前的收盤價)
    VAR10賦值:(1日前的VARF AND 收盤價>=1日前的收盤價 AND 收盤價<=2日前的收盤價)
    VAR11賦值:(1日前的VAR10 AND 收盤價<=1日前的收盤價 AND 收盤價>=2日前的收盤價)
    VAR12賦值:(1日前的VAR11 AND 收盤價>=1日前的收盤價 AND 收盤價<=2日前的收盤價)
    VAR13賦值:(1日前的VAR12 AND 收盤價<=1日前的收盤價 AND 收盤價>=2日前的收盤價)
    VAR14賦值:(1日前的VAR13 AND 收盤價>=1日前的收盤價 AND 收盤價<=2日前的收盤價)
    VAR15賦值:(1日前的VAR14 AND 收盤價<=1日前的收盤價 AND 收盤價>=2日前的收盤價)
    VAR16賦值:(1日前的VAR15 AND 收盤價>=1日前的收盤價 AND 收盤價<=2日前的收盤價)
    VAR17賦值:(1日前的VAR16 AND 收盤價<=1日前的收盤價 AND 收盤價>=2日前的收盤價)
    VAR18賦值:(1日前的VAR17 AND 收盤價>=1日前的收盤價 AND 收盤價<=2日前的收盤價)
    VAR19賦值:((1日前的VARDORVAREORVARFORVAR10ORVAR11ORVAR12ORVAR13ORVAR14ORVAR15ORVAR16ORVAR17ORVAR18) AND VAR1)
    VAR1A賦值:((1日前的VAR1ORVAR2ORVAR3ORVAR4ORVAR5ORVAR6ORVAR7ORVAR8ORVAR9ORVARAORVARBORVARC) AND VARD)
    當滿足條件VAR19時,在最低價-0.1位置畫1號圖標,COLOR33FFCC
    ?

    源碼:

    M1:=10;
    M2:=60;
    所屬地域:DRAWTEXT_FIX(ISLASTBAR ,0.08,0.01,1,DYBLOCK),COLORYELLOW;
    所屬行業:DRAWTEXT_FIX(ISLASTBAR ,0.1,0.01,0,HYBLOCK),COLORYELLOW;
    漲跌停:=(C-REF(C,1))/REF(C,1)*100;
    STICKLINE(漲跌停>9.8,O,C,3,0),COLORMAGENTA;
    STICKLINE(漲跌停<-9.8,O,C,3,0),COLORGREEN;
    HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
    HHJSJDB:(20*HHJSJDA+18*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
    +13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
    +7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
    REF(HHJSJDA,20))/210,COLORYELLOW;
    HHJSJDC:MA(HHJSJDB,5),COLORRED;
    EXP1:EMA(CLOSE,M1),DOTLINE,COLORLIBLUE;
    EXP2:EMA(CLOSE,M2),DOTLINE,COLORYELLOW;
    VAR1:=(C>REF(C,1) AND C>REF(C,2));
    VAR2:=(REF(VAR1,1) AND C<=REF(C,1) AND C>=REF(C,2));
    VAR3:=(REF(VAR2,1) AND C>=REF(C,1) AND C<=REF(C,2));
    VAR4:=(REF(VAR3,1) AND C<=REF(C,1) AND C>=REF(C,2));
    VAR5:=(REF(VAR4,1) AND C>=REF(C,1) AND C<=REF(C,2));
    VAR6:=(REF(VAR5,1) AND C<=REF(C,1) AND C>=REF(C,2));
    VAR7:=(REF(VAR6,1) AND C>=REF(C,1) AND C<=REF(C,2));
    VAR8:=(REF(VAR7,1) AND C<=REF(C,1) AND C>=REF(C,2));
    VAR9:=(REF(VAR8,1) AND C>=REF(C,1) AND C<=REF(C,2));
    VARA:=(REF(VAR9,1) AND C<=REF(C,1) AND C>=REF(C,2));
    VARB:=(REF(VARA,1) AND C>=REF(C,1) AND C<=REF(C,2));
    VARC:=(REF(VARB,1) AND C<=REF(C,1) AND C>=REF(C,2));
    VARD:=(C<REF(C,1) AND C<REF(C,2));
    VARE:=(REF(VARD,1) AND C>=REF(C,1) AND C<=REF(C,2));
    VARF:=(REF(VARE,1) AND C<=REF(C,1) AND C>=REF(C,2));
    VAR10:=(REF(VARF,1) AND C>=REF(C,1) AND C<=REF(C,2));
    VAR11:=(REF(VAR10,1) AND C<=REF(C,1) AND C>=REF(C,2));
    VAR12:=(REF(VAR11,1) AND C>=REF(C,1) AND C<=REF(C,2));
    VAR13:=(REF(VAR12,1) AND C<=REF(C,1) AND C>=REF(C,2));
    VAR14:=(REF(VAR13,1) AND C>=REF(C,1) AND C<=REF(C,2));
    VAR15:=(REF(VAR14,1) AND C<=REF(C,1) AND C>=REF(C,2));
    VAR16:=(REF(VAR15,1) AND C>=REF(C,1) AND C<=REF(C,2));
    VAR17:=(REF(VAR16,1) AND C<=REF(C,1) AND C>=REF(C,2));
    VAR18:=(REF(VAR17,1) AND C>=REF(C,1) AND C<=REF(C,2));
    VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
    VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
    DRAWICON(VAR19,L-0.1,1),COLOR33FFCC;

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

    怎么收費,代編流程等詳情請點擊查閱!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>