• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

    背離主圖指標公式(公式、源碼)[大智慧公式]

    相關標簽: cci指標背離提示公式 、 macd背離最準指標公式 、 macd頂底背離指標源碼 、 macd精品背離指標公式 、 macd頂底背離指標公式 、 最新最精確頂底背離副圖 、 wr底背離公式 、 macd金叉頂底背離指標公式 、 macd面積背離指標公式 、 macd背離指標選股公式 、 macd指標底背離公式 、 macd頂背離指標公式 、

    原理解析:

    SAT賦值:如果(成交額(元)/收盤價)/(20日內成交額(元)的最高值/20日內收盤價的最高值)*100>100,返回100,否則返回(成交額(元)/收盤價)/(20日內成交額(元)的最高值/20日內收盤價的最高值)*100
    輸出AA10:收盤價的8日簡單移動平均,COLOR0000FF
    輸出AA12:收盤價的12日簡單移動平均,COLOR0000FF
    BB10賦值:(((AA10-1日前的AA10)的反正切 * 3.1416) * 10)
    BB12賦值:(((AA12-1日前的AA12)的反正切 * 3.1416) * 10)
    MA13賦值:收盤價的13日簡單移動平均
    當滿足條件(((AA12<=AA10)AND(BB12>=1))AND(BB10>=1))時,在AA10和AA12位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,COLOR0080FF
    當滿足條件(((AA12>=AA10)AND(BB10<=1))AND(BB10<=1))時,在AA10和AA12位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,COLOR00FF00
    X1賦值:(收盤價+最低價+最高價)/3
    BB13賦值:X1的13日指數移動平均-1日前的X1的13日指數移動平均的反正切*3.1416*10
    EMA8賦值:收盤價的8日指數移動平均
    當滿足條件BB13>1ANDEMA(X1,13)>1日前的X1的8日指數移動平均的10日過濾時,在EMA8位置書寫文字,畫白色
    輸出分析家公式網HTTP://WWW.70822.COM整理:1日前的30日內收盤價的最高值的2日簡單移動平均,COLOR9DFFFF
    輸出支撐:1日前的30日內收盤價的最低值的2日簡單移動平均,COLORABFF46
    AA1賦值:成交額(元)/成交量(手)
    BB1賦值:最低價<AA1*0.9
    CC1賦值:(收盤價-1日前的收盤價)/1日前的收盤價*100>1.2
    DD1賦值:最低價<收盤價的5日簡單移動平均*0.921
    EE1賦值:成交量(手)<成交量(手)的5日簡單移動平均*1.5
    FF1賦值:BB1 AND CC1 AND DD1 AND EE1
    當滿足條件FF1時,在(最低價*0.99)位置書寫文字,COLOR4080FF
    A51賦值:3*(收盤價-55日內最低價的最低值)/(55日內最高價的最高值-55日內最低價的最低值)*100的5日[1日權重]移動平均-2*(收盤價-55日內最低價的最低值)/(55日內最高價的最高值-55日內最低價的最低值)*100的5日[1日權重]移動平均
    黑馬線賦值:A51的5日指數移動平均
    A54賦值:((收盤價-21日內最低價的最低值)/(21日內最高價的最高值-21日內最低價的最低值))*100
    趨勢線賦值:(3*A54的6日[1日權重]移動平均-2*A54的5日[1日權重]移動平均的5日[1日權重]移動平均的2日簡單移動平均)
    當滿足條件趨勢線上穿0AND黑馬線<40時,在(最高價*0.97)位置書寫文字,畫黃色
    LC賦值:1日前的收盤價
    RSI賦值:(((收盤價-LC)和0的較大值的3日[1日權重]移動平均 / (收盤價-LC)的絕對值的3日[1日權重]移動平均) * 100)
    FF賦值:收盤價的3日指數移動平均
    MA15賦值:收盤價的21日指數移動平均
    當滿足條件FF上穿MA15時,在(最低價*0.99)位置書寫文字,COLORA6E500
    當滿足條件88上穿RSI時,在(最高價*1.02)位置書寫文字,COLOR1880FF
    VAR2賦值:27日內最低價的最低值
    VAR3賦值:34日內最高價的最高值
    VAR4賦值:(收盤價-VAR2)/(VAR3-VAR2)*4的4日指數移動平均*25
    注意買賦值:如果(VAR4<10),返回80,否則返回100
    RSV賦值:(收盤價-9日內最低價的最低值)/(9日內最高價的最高值-9日內最低價的最低值)*100
    K賦值:RSV的3日[1日權重]移動平均
    D賦值:K的3日[1日權重]移動平均
    J賦值:3*K-2*D
    超跌賦值:如果J<0,返回10,否則返回0
    BDDD賦值:2日內J的最低值=8日內J的最低值
    買入賦值:如果J上穿1日前的J+0.01ANDBDDDANDJ<20,返回30,否則返回0
    當滿足條件買入AND注意買=100AND超跌=0時,在最低價位置書寫文字,COLOR8000FF
    MTM賦值:收盤價-1日前的收盤價
    DX賦值:100*MTM的6日指數移動平均的6日指數移動平均/MTM的絕對值的6日指數移動平均的6日指數移動平均
    買賦值:如果2日內DX的最低值=7日內DX的最低值ANDCOUNT(DX<0,2)ANDCROSS(DX,DX的2日簡單移動平均),返回1,否則返回0
    當滿足條件買=1的5日過濾時,在最低價-0.03位置書寫文字,COLORFFDE00
    ?

    源碼:

    ?

    {背離主圖}
    SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
    AA10:MA(CLOSE,8),COLOR0000FF;AA12:MA(CLOSE,12),COLOR0000FF;BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);
    BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);MA13:=MA(CLOSE,13);
    STICKLINE((((AA12 <= AA10) AND (BB12 >= 1)) AND (BB10 >= 1)),AA10,AA12,4,0),COLOR0080FF;
    STICKLINE((((AA12 >= AA10) AND (BB10 <= 1)) AND (BB10 <= 1)),AA10,AA12,4,0),COLOR00FF00;
    X1:=(C+L+H)/3;BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
    EMA8:=EMA(C,8);DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
    EMA8,'∠45上升'),COLORWHITE;壓力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;
    支撐:MA(REF(LLV(C,30),1),2),COLORABFF46; AA1:=AMOUNT/V;BB1:=L<AA1*0.9;
    CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;DD1:=L<MA(C,5)*0.921;EE1:=V<MA(V,5)*1.5;
    FF1:=BB1 AND CC1 AND DD1 AND EE1;DRAWTEXT(FF1,(LOW* 0.99),'老鼠倉'),COLOR4080FF;
    A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
    黑馬線:=EMA(A51,5);A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
    趨勢線:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
    DRAWTEXT(CROSS(趨勢線,0)AND 黑馬線<40,(HIGH* 0.97),'▲大黑馬'),COLORYELLOW;{http://cxh99.com}
    LC:=REF(CLOSE,1);RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
    FF:=EMA(CLOSE,3);MA15:=EMA(CLOSE,21);DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'底背離'),COLORA6E500;
    DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'頂背離'),COLOR1880FF;
    VAR2:=LLV(LOW,27);VAR3:=HHV(HIGH,34);VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*25;
    注意買:=IF((VAR4<10),80,100);RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
    K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;超跌:=IF(J<0,10,0);BDDD:=LLV(J,2)=LLV(J,8);
    買入:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND J<20,30,0);
    DRAWTEXT(買入 AND 注意買=100 AND 超跌=0,LOW,'短線'),COLOR8000FF;
    MTM:=C-REF(C,1);DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
    買:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
    DRAWTEXT(FILTER(買=1,5),LOW-0.03,'拉升'),COLORFFDE00;

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

    怎么收費,代編流程等詳情請點擊查閱!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>