• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 其他>> 其他軟件公式>>正文內容

    zhouqi模型指標公式[其他軟件公式]

    相關標簽:macd指標公式 、 量比指標公式 、 短線指標公式 、 成交量指標公式 、 換手率指標公式 、 分時指標公式 、 文華指標公式 、 金蜘蛛指標公式 、 麟龍指標公式 、 波段指標公式 、 趨勢指標公式 、

    原理解析:

    B賦值:100/(SYSPARAM(4)-SYSPARAM(5))
    Y賦值:(SYSPARAM(4)+SYSPARAM(5))*B/2-50
    FC賦值:收盤價-1日前的收盤價
    當滿足條件開盤價<CLOSEOROPEN=CLOSEANDFC>0時,在最低價*B-Y和最高價*B-Y位置之間畫柱狀線,寬度為0.1,0不為0則畫空心柱.,COLOR4A3A46
    當滿足條件開盤價<CLOSEOROPEN=CLOSEANDFC>0時,在開盤價*B-Y和收盤價*B-Y位置之間畫柱狀線,寬度為6,1不為0則畫空心柱.,COLOR4A3A46
    當滿足條件開盤價>CLOSEOROPEN=CLOSEANDFC<0時,在最低價*B-Y和最高價*B-Y位置之間畫柱狀線,寬度為0.1,0不為0則畫空心柱.,COLOR4A3A46
    當滿足條件開盤價>CLOSEOROPEN=CLOSEANDFC<0時,在開盤價*B-Y和收盤價*B-Y位置之間畫柱狀線,寬度為6,0不為0則畫空心柱.,COLOR4A3A46
    KK賦值:BARPOS
    K賦值:SYSPARAM(1)=BARPOS
    輸出VARIABLE:TEST=1
    BEGINTEST賦值:TEST AND 最高價>I日后的最高價
    END
    COND賦值:TEST AND 最高價=60日內最高價的最高值
    HH賦值:如果COND,返回KK,否則返回0
    輸出VARIABLE:TEST=1
    BEGINTEST賦值:TEST AND 最低價<I日后的最低價
    END
    COND1賦值:TEST AND 最低價=60日內最低價的最低值
    LL賦值:如果COND1,返回KK,否則返回0
    HL賦值:(如果HH>0,返回107,否則返回0)+(如果LL>0,返回-1,否則返回0)
    當滿足條件HL>0ORHL=-1時,在HL位置書寫數字
    頂底數賦值:如果HH>0,返回1,否則返回如果LL>0,返回1,否則返回0的歷史累和
    底數賦值:如果LL>0,返回1,否則返回0的歷史累和
    頂數賦值:如果HH>0,返回1,否則返回0的歷史累和
    輸出VARIABLE:TEST=1
    BEGINTEST賦值:TEST AND 最高價>I日后的最高價
    END
    COND賦值:TEST AND 最高價=3日內最高價的最高值
    HHH賦值:如果COND,返回1,否則返回0
    輸出VARIABLE:TEST=1
    BEGINTEST賦值:TEST AND 最低價<I日后的最低價
    END
    COND1賦值:TEST AND 最低價=3日內最低價的最低值
    LLL賦值:如果COND1,返回1,否則返回0
    W1賦值:0日內如果日期=模型1ANDHHH,返回KK,否則返回0的最高值
    當滿足條件日期=模型1時,在最低價*B-Y和0位置之間畫柱狀線,寬度為0.8,1不為0則畫空心柱.,COLORFF00
    月日賦值:日期-1000000
    模1賦值:如果W1*2-(如果W1>18,返回18,否則返回0)=KKORW1*2-(如果W1>35,返回35,否則返回0)=KKORW1*2-(如果W1>45,返回45,否則返回0)=KKORW1*2-(如果W1>145,返回145,否則返回0)=KKORW1*2-(如果W1>104,返回104,否則返回0)=KKORW1*2-(如果W1>135,返回135,否則返回0)=K,返回ORW1*2-(如果W1>200,返回200,否則返回0)=KKORW1*2-(如果W1>364,返回364,否則返回0)=KKORW1*2-(如果W1>473,返回473,否則返回0)=KKORW1*2-(如果W1>420,返回420,否則返回0)=KKORW1*2-(如果W1>439,返回439,否則返回0)=KKORW1*2-(如果W1>476,返回4,否則返回?,否則返回6,0))=KKORW1*2-(如果W1>443,返回443,否則返回0)=KKORW1*2-(如果W1>500,返回500,否則返回0)=KKORW1*2-(如果W1>576,返回576,否則返回0)=KKORW1*2-(如果W1>562,返回562,否則返回0)=KKORW1*2-(如果W1>504,返回504,否則返回0)=KKORW1*2-(如果?,返回?,否則返回?
    當滿足條件日期=模型1時,在最高價*B-Y位置畫5號圖標
    當滿足條件模1>0時,在50和0位置之間畫柱狀線,寬度為0.8,1不為0則畫空心柱.,COLORFF00
    當滿足條件日期=模型1ANDHHH時,在10位置書寫文字,COLORFF00
    當滿足條件模1>0時,在10位置書寫數字,COLORFFFFFF
    WA賦值:0日內如果日期=模型2ANDLLL,返回KK,否則返回0的最高值
    當滿足條件日期=模型2時,在100和最高價*B-Y位置之間畫柱狀線,寬度為0.8,1不為0則畫空心柱.,COLORFFFF
    輸出模型一:如果模1>0,返回KK,否則返回0,線寬為0,COLORFF00
    模2賦值:如果WA*2-(如果WA>18,返回18,否則返回0)=KKORWA*2-(如果WA>35,返回35,否則返回0)=KKORWA*2-(如果WA>45,返回45,否則返回0)=KKORWA*2-(如果WA>145,返回145,否則返回0)=KKORWA*2-(如果WA>104,返回104,否則返回0)=KKORWA*2-(如果WA>135,返回135,否則返回0)=K,返回ORWA*2-(如果WA>200,返回200,否則返回0)=KKORWA*2-(如果WA>364,返回364,否則返回0)=KKORWA*2-(如果WA>473,返回473,否則返回0)=KKORWA*2-(如果WA>420,返回420,否則返回0)=KKORWA*2-(如果WA>439,返回439,否則返回0)=KKORWA*2-(如果WA>476,返回4,否則返回?,否則返回6,0))=KKORWA*2-(如果WA>443,返回443,否則返回0)=KKORWA*2-(如果WA>500,返回500,否則返回0)=KKORWA*2-(如果WA>576,返回576,否則返回0)=KKORWA*2-(如果WA>562,返回562,否則返回0)=KKORWA*2-(如果WA>504,返回504,否則返回0)=KKORWA*2-(如果?,返回?,否則返回?
    當滿足條件日期=模型2時,在最高價*B-Y位置畫4號圖標
    當滿足條件模2>0時,在50和100位置之間畫柱狀線,寬度為0.8,1不為0則畫空心柱.,COLORFFFF
    當滿足條件模2>0時,在80位置書寫數字,COLORFFFFFF
    前頂賦值:上次HH距今天數+1日前的KK+1
    前底賦值:上次LL距今天數+1日前的KK+1
    當滿足條件日期=模型2ANDLLL時,在90位置書寫文字,COLORFF00
    輸出模型二:如果模2>0,返回KK,否則返回0,線寬為0,COLORFFFF
    W2賦值:0日內如果日期=模型3,返回KK,否則返回0的最高值
    當滿足條件日期=模型3時,在最低價*B-Y和0位置之間畫柱狀線,寬度為0.8,1不為0則畫空心柱.,COLORFF00FF
    前D賦值:0日內如果日期=模型3ANDHHH,返回1日前的前頂,否則返回0的最高值
    模3賦值:如果W2+前D-(如果前D>18,返回18,否則返回0)=KKORW2+前D-(如果前D>35,返回35,否則返回0)=KKORW2+前D-(如果前D>45,返回45,否則返回0)=KKORW2+前D-(如果前D>145,返回145,否則返回0)=KKORW2+前D-(如果前D>104,返回104,否則返回0)=KKORW2+前D-(條件判斷,返回前D>135,135,0))=KKORW2+前D-(如果前D>200,返回200,否則返回0)=KKORW2+前D-(如果前D>364,返回364,否則返回0)=KKORW2+前D-(如果前D>473,返回473,否則返回0)=KKORW2+前D-(如果前D>420,返回420,否則返回0)=KKORW2+前D-(如果前D>,返回?,否則返回?,否則返回39,439,0))=KKORW2+前D-(如果前D>476,返回476,否則返回0)=KKORW2+前D-(如果前D>443,返回443,否則返回0)=KKORW2+前D-(如果前D>500,返回500,否則返回0)=KKORW2+前D-(如果前D>576,返回576,否則返回0)=KKORW2+前D-(如果前D>562,返回5,否則返回?
    當滿足條件日期=模型3時,在最高價*B-Y位置畫5號圖標
    當滿足條件模3>0時,在50和0位置之間畫柱狀線,寬度為0.8,1不為0則畫空心柱.,COLORFF00FF
    當滿足條件日期=模型3ANDHHH時,在20位置書寫文字,COLORFF00
    當滿足條件模3>0時,在20位置書寫數字,COLORFFFFFF
    輸出模型三:如果模3>0,返回KK,否則返回0,線寬為0,COLORFF00FF
    W3賦值:0日內如果日期=模型4,返回KK,否則返回0的最高值
    當滿足條件日期=模型4時,在100和最高價*B-Y位置之間畫柱狀線,寬度為0.8,1不為0則畫空心柱.,COLORFF
    前I賦值:0日內如果日期=模型4ANDLLL,返回1日前的前底,否則返回0的最高值
    模4賦值:如果W3+前I-(如果前I>18,返回18,否則返回0)=KKORW3+前I-(如果前I>35,返回35,否則返回0)=KKORW3+前I-(如果前I>45,返回45,否則返回0)=KKORW3+前I-(如果前I>145,返回145,否則返回0)=KKORW3+前I-(如果前I>104,返回104,否則返回0)=KKORW3+前I-(條件判斷,返回前I>135,135,0))=KKORW3+前I-(如果前I>200,返回200,否則返回0)=KKORW3+前I-(如果前I>364,返回364,否則返回0)=KKORW3+前I-(如果前I>473,返回473,否則返回0)=KKORW3+前I-(如果前I>420,返回420,否則返回0)=KKORW3+前I-(如果前I>,返回?,否則返回?,否則返回39,439,0))=KKORW3+前I-(如果前I>476,返回476,否則返回0)=KKORW3+前I-(如果前I>443,返回443,否則返回0)=KKORW3+前I-(如果前I>500,返回500,否則返回0)=KKORW3+前I-(如果前I>576,返回576,否則返回0)=KKORW3+前I-(如果前I>562,返回5,否則返回?
    當滿足條件日期=模型4時,在最高價*B-Y位置畫4號圖標
    當滿足條件模4>0時,在50和100位置之間畫柱狀線,寬度為0.8,1不為0則畫空心柱.,COLORFF
    當滿足條件日期=模型4ANDLLL時,在80位置書寫文字,COLORFF00
    當滿足條件模4>0時,在60位置書寫數字,COLORFFFFFF
    輸出模型四:如果模4>0,返回KK,否則返回0,線寬為0,COLORFF
    QD賦值:SYSPARAM(2)=BARPOS
    當滿足條件QD時,在107位置書寫文字,ALIGN1,COLORFFFFFF
    當滿足條件QD時,在80位置書寫文字,ALIGN1,COLORFFFFFF
    當滿足條件QD時,在29位置書寫文字,ALIGN1,COLORFFFFFF
    當滿足條件QD時,在-1位置書寫文字,ALIGN1,COLORFFFFFF
    當滿足條件QD時,在107位置書寫文字,ALIGN1,COLOR4441FF
    當滿足條件QD時,在80位置書寫文字,ALIGN1,COLOR4441FF
    當滿足條件QD時,在29位置書寫文字,ALIGN1,COLOR4441FF
    當滿足條件QD時,在-1位置書寫文字,ALIGN1,COLOR4441FF
    輸出███:0,SHIFT3,COLOR4441FF
    -8,SHIFT3,COLOR4441FF
    50,SHIFT3,COLOR4441FF
    108,SHIFT3,COLOR4441FF
    100,SHIFT3,COLOR4441FF
    ?

    源碼:

    ?

    B:=100/(SYSPARAM(4)-SYSPARAM(5));
    Y:=(SYSPARAM(4)+SYSPARAM(5))*B/2-50;
    FC:=CLOSE-REF(CLOSE,1);
    STICKLINE(OPEN<CLOSE OR OPEN=CLOSE AND FC>0,LOW*B-Y,HIGH*B-Y,0.1,0),color4A3A46;
    STICKLINE(OPEN<CLOSE OR OPEN=CLOSE AND FC>0,OPEN*B-Y,CLOSE*B-Y,6,1),color4A3A46;
    STICKLINE(OPEN>CLOSE OR OPEN=CLOSE AND FC<0,LOW*B-Y,HIGH*B-Y,0.1,0),color4A3A46;
    STICKLINE(OPEN>CLOSE OR OPEN=CLOSE AND FC<0,OPEN*B-Y,CLOSE*B-Y,6,0),color4A3A46;
    KK:=BARPOS;
    K:=SYSPARAM(1)=BARPOS;
    VARIABLE:TEST=1;
    FOR I=1 TO 60 DO BEGIN
    TEST:=TEST AND HIGH>REFX(HIGH,I);
    END;
    COND:=TEST AND HIGH=HHV(HIGH,60);
    HH:=IF(COND,KK,0);
    VARIABLE:TEST=1;
    FOR I=1 TO 60 DO BEGIN
    TEST:=TEST AND LOW<REFX(LOW,I);
    END;
    COND1:=TEST AND LOW=LLV(LOW,60);
    LL:=IF(COND1,KK,0);
    HL:=(IF(HH>0,107,0))+(IF(LL>0,-1,0));
    DRAWNUMBER(HL>0 OR HL=-1,HL,KK,0);
    頂底數:=SUM(IF(HH>0,1,IF(LL>0,1,0)),0);
    底數:=SUM(IF(LL>0,1,0),0);
    頂數:=SUM(IF(HH>0,1,0),0);
    VARIABLE:TEST=1;
    FOR I=1 TO 3 DO BEGIN
    TEST:=TEST AND HIGH>REFX(HIGH,I);
    END;
    COND:=TEST AND HIGH=HHV(HIGH,3);
    HHH:=IF(COND,1,0);
    VARIABLE:TEST=1;
    FOR I=1 TO 3 DO BEGIN
    TEST:=TEST AND LOW<REFX(LOW,I);
    END;
    COND1:=TEST AND LOW=LLV(LOW,3);
    LLL:=IF(COND1,1,0);
    W1:=HHV(IF(DATE=模型1 AND HHH,KK,0),0);
    STICKLINE(DATE=模型1,LOW*B-Y,0,0.8,1),colorFF00;
    月日:=DATE-1000000;
    模1:=IF(W1*2-(IF(W1>18,18,0))=KK OR W1*2-(IF(W1>35,35,0))=KK OR W1*2-(IF(W1>45,45,0))=KK OR W1*2-(IF(W1>145,145,0))=KK OR W1*2-(IF(W1>104,104,0))=KK OR W1*2-(IF(W1>135,135,0))=KK OR W1*2-(IF(W1>200,200,0))=KK OR W1*2-(IF(W1>364,364,0))=KK OR W1*2-(IF(W1>473,473,0))=KK OR W1*2-(IF(W1>420,420,0))=KK OR W1*2-(IF(W1>439,439,0))=KK OR W1*2-(IF(W1>476,476,0))=KK OR W1*2-(IF(W1>443,443,0))=KK OR W1*2-(IF(W1>500,500,0))=KK OR W1*2-(IF(W1>576,576,0))=KK OR W1*2-(IF(W1>562,562,0))=KK OR W1*2-(IF(W1>504,504,0))=KK OR W1*2-(IF(W1>532,532,0))=KK OR W1*2-(IF(W1>529,529,0))=KK OR W1*2-(IF(W1>601,601,0))=KK OR W1*2-(IF(W1>664,664,0))=KK OR W1*2-(IF(W1>626,626,0))=KK OR W1*2-(IF(W1>659,659,0))=KK,100,0);
    DRAWICON(DATE=模型1,HIGH*B-Y,5);
    STICKLINE(模1>0,50,0,0.8,1),colorFF00;
    DRAWTEXT(DATE=模型1 AND HHH,10,'模型一'),colorFF00;
    DRAWNUMBER(模1>0,10,月日,0),colorFFFFFF;
    WA:=HHV(IF(DATE=模型2 AND LLL,KK,0),0);
    STICKLINE(DATE=模型2,100,HIGH*B-Y,0.8,1),colorFFFF;
    模型一:IF(模1>0,KK,0),LINETHICK0,colorFF00;
    模2:=IF(WA*2-(IF(WA>18,18,0))=KK OR WA*2-(IF(WA>35,35,0))=KK OR WA*2-(IF(WA>45,45,0))=KK OR WA*2-(IF(WA>145,145,0))=KK OR WA*2-(IF(WA>104,104,0))=KK OR WA*2-(IF(WA>135,135,0))=KK OR WA*2-(IF(WA>200,200,0))=KK OR WA*2-(IF(WA>364,364,0))=KK OR WA*2-(IF(WA>473,473,0))=KK OR WA*2-(IF(WA>420,420,0))=KK OR WA*2-(IF(WA>439,439,0))=KK OR WA*2-(IF(WA>476,476,0))=KK OR WA*2-(IF(WA>443,443,0))=KK OR WA*2-(IF(WA>500,500,0))=KK OR WA*2-(IF(WA>576,576,0))=KK OR WA*2-(IF(WA>562,562,0))=KK OR WA*2-(IF(WA>504,504,0))=KK OR WA*2-(IF(WA>532,532,0))=KK OR WA*2-(IF(WA>529,529,0))=KK OR WA*2-(IF(WA>601,601,0))=KK OR WA*2-(IF(WA>664,664,0))=KK OR WA*2-(IF(WA>626,626,0))=KK OR WA*2-(IF(WA>659,659,0))=KK,100,0);
    DRAWICON(DATE=模型2,HIGH*B-Y,4);
    STICKLINE(模2>0,50,100,0.8,1),colorFFFF;
    DRAWNUMBER(模2>0,80,月日,0),colorFFFFFF;
    前頂:=REF(KK,BARSLAST(HH)+1)+1;
    前底:=REF(KK,BARSLAST(LL)+1)+1;
    DRAWTEXT(DATE=模型2 AND LLL,90,'模型二'),colorFF00;
    模型二:IF(模2>0,KK,0),LINETHICK0,colorFFFF;
    W2:=HHV(IF(DATE=模型3,KK,0),0);
    STICKLINE(DATE=模型3,LOW*B-Y,0,0.8,1),colorFF00FF;
    前D:=HHV(IF(DATE=模型3 AND HHH,REF(前頂,1),0),0);
    模3:=IF(W2+前D-(IF(前D>18,18,0))=KK OR W2+前D-(IF(前D>35,35,0))=KK OR W2+前D-(IF(前D>45,45,0))=KK OR W2+前D-(IF(前D>145,145,0))=KK OR W2+前D-(IF(前D>104,104,0))=KK OR W2+前D-(IF(前D>135,135,0))=KK OR W2+前D-(IF(前D>200,200,0))=KK OR W2+前D-(IF(前D>364,364,0))=KK OR W2+前D-(IF(前D>473,473,0))=KK OR W2+前D-(IF(前D>420,420,0))=KK OR W2+前D-(IF(前D>439,439,0))=KK OR W2+前D-(IF(前D>476,476,0))=KK OR W2+前D-(IF(前D>443,443,0))=KK OR W2+前D-(IF(前D>500,500,0))=KK OR W2+前D-(IF(前D>576,576,0))=KK OR W2+前D-(IF(前D>562,562,0))=KK OR W2+前D-(IF(前D>504,504,0))=KK OR W2+前D-(IF(前D>532,532,0))=KK OR W2+前D-(IF(前D>529,529,0))=KK OR W2+前D-(IF(前D>601,601,0))=KK OR W2+前D-(IF(前D>664,664,0))=KK OR W2+前D-(IF(前D>626,626,0))=KK OR W2+前D-(IF(前D>659,659,0))=KK,100,0);
    DRAWICON(DATE=模型3,HIGH*B-Y,5);
    STICKLINE(模3>0,50,0,0.8,1),colorFF00FF;
    DRAWTEXT(DATE=模型3 AND HHH,20,'模型三'),colorFF00;
    DRAWNUMBER(模3>0,20,月日,0),colorFFFFFF;
    模型三:IF(模3>0,KK,0),LINETHICK0,colorFF00FF;
    W3:=HHV(IF(DATE=模型4,KK,0),0);
    STICKLINE(DATE=模型4,100,HIGH*B-Y,0.8,1),colorFF;
    前I:=HHV(IF(DATE=模型4 AND LLL,REF(前底,1),0),0);
    模4:=IF(W3+前I-(IF(前I>18,18,0))=KK OR W3+前I-(IF(前I>35,35,0))=KK OR W3+前I-(IF(前I>45,45,0))=KK OR W3+前I-(IF(前I>145,145,0))=KK OR W3+前I-(IF(前I>104,104,0))=KK OR W3+前I-(IF(前I>135,135,0))=KK OR W3+前I-(IF(前I>200,200,0))=KK OR W3+前I-(IF(前I>364,364,0))=KK OR W3+前I-(IF(前I>473,473,0))=KK OR W3+前I-(IF(前I>420,420,0))=KK OR W3+前I-(IF(前I>439,439,0))=KK OR W3+前I-(IF(前I>476,476,0))=KK OR W3+前I-(IF(前I>443,443,0))=KK OR W3+前I-(IF(前I>500,500,0))=KK OR W3+前I-(IF(前I>576,576,0))=KK OR W3+前I-(IF(前I>562,562,0))=KK OR W3+前I-(IF(前I>504,504,0))=KK OR W3+前I-(IF(前I>532,532,0))=KK OR W3+前I-(IF(前I>529,529,0))=KK OR W3+前I-(IF(前I>601,601,0))=KK OR W3+前I-(IF(前I>664,664,0))=KK OR W3+前I-(IF(前I>626,626,0))=KK OR W3+前I-(IF(前I>659,659,0))=KK,100,0);
    DRAWICON(DATE=模型4,HIGH*B-Y,4);
    STICKLINE(模4>0,50,100,0.8,1),colorFF;
    DRAWTEXT(DATE=模型4 AND LLL,80,'模型四'),colorFF00;
    DRAWNUMBER(模4>0,60,月日,0),colorFFFFFF;
    模型四:IF(模4>0,KK,0),LINETHICK0,colorFF;
    QD:=SYSPARAM(2)=BARPOS;
    DRAWTEXT(QD,107,'███████'),ALIGN1,colorFFFFFF;
    DRAWTEXT(QD,80,'██████'),ALIGN1,colorFFFFFF;
    DRAWTEXT(QD,29,'██████'),ALIGN1,colorFFFFFF;
    DRAWTEXT(QD,-1,'███████'),ALIGN1,colorFFFFFF;
    DRAWTEXT(QD,107,'頂部拐點序列數'),ALIGN1,color4441FF;
    DRAWTEXT(QD,80,'模型2~4時間:'),ALIGN1,color4441FF;
    DRAWTEXT(QD,29,'模型1~3時間'),ALIGN1,color4441FF;
    DRAWTEXT(QD,-1,'底部拐點序列數'),ALIGN1,color4441FF;
    ███:0,SHIFT3,color4441FF;
    -8,SHIFT3,color4441FF;
    50,SHIFT3,color4441FF;
    108,SHIFT3,color4441FF;
    100,SHIFT3,color4441FF;

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

    怎么收費,代編流程等詳情請點擊查閱!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>