• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 其他>> 其他軟件公式>>正文內容

    老狐貍**【三要素】公式[其他軟件公式]

    相關標簽:三龍會師指標公式 、 lr性能指標的三大要素 、 老狐貍馬林 、 色彩三要素 、 議論文三要素 、 生產力三要素 、 小說三要素 、 力的三要素 、 切削三要素相關公式 、 在三要素法公式中 、 電工三要素法公式 、 一階電路三要素公式 、 電路三要素法公式 、

    原理解析:

    A賦值:收盤價的3日指數移動平均
    B賦值:收盤價的5日指數移動平均
    Z賦值:收盤價的15日指數移動平均
    資本賦值:Z日前的B日內A的最高值
    運作賦值:A
    體系賦值:運作的5日簡單移動平均
    【▲】Z賦值:Z的7日簡單移動平均
    填充背景
    填充背景
    填充背景
    獲利盤賦值:以收盤價計算的獲利盤比例*100
    套牢盤賦值:100-獲利盤
    WIN1賦值:獲利盤為85%的成本分布
    WIN2賦值:獲利盤為15%的成本分布
    股票賣出價預測賦值:套牢盤的89日簡單移動平均*0.618/50+收盤價
    股票買進價預測賦值:收盤價-套牢盤的60日簡單移動平均*0.618/100
    轉折價明日賦值:2日前的收盤價*2-5日前的收盤價
    轉折價后日賦值:1日前的收盤價*2-4日前的收盤價
    轉折價大后日賦值:收盤價*2-3日前的收盤價
    高賦值:0日內最高價的最高值
    低賦值:0日內最低價的最低值
    DCFL賦值:獲利盤為95%的成本分布
    SCFL賦值:獲利盤為55%的成本分布
    JCFL賦值:獲利盤為15%的成本分布
    CH賦值:獲利盤為5%的成本分布
    DI賦值:獲利盤為0.38%的成本分布
    M賦值:58
    X賦值:3
    P賦值:SYSPARAM(1)
    WS賦值:BARPOS
    WS1賦值:如果WS<M,返回WS,否則返回M
    WSP賦值:P-WS1+1
    WSP1賦值:WS1-1
    H1賦值:WS1日內最高價的最高值
    L1賦值:WS1日內最低價的最低值
    HP賦值:H1[P]
    LP賦值:L1[P]
    HLPX賦值:(HP-LP)/X
    條件判斷 WS1[P]>1 THEN BEGINDRAWSL(WS=WSP[P],HP,0,WSP1[P],3),POINTDOT,線寬為1
    當滿足條件WS=WSP[P]時,在LP位置畫斜線0斜率WSP1[P]長度,3方向.,POINTDOT,線寬為1
    當滿足條件WS=WSP[P]時,在LP+HLPX位置畫斜線0斜率WSP1[P]長度,3方向.,POINTDOT,線寬為1
    當滿足條件WS=WSP[P]時,在LP+HLPX*2位置畫斜線0斜率WSP1[P]長度,3方向.,POINTDOT,線寬為1,COLORAAAAAA
    當滿足條件WS=WSP[P]時,在HP位置書寫數字,SHIFT38,COLORFF
    當滿足條件WS=WSP[P]時,在LP位置書寫數字,SHIFT38,COLORFF00
    當滿足條件WS=WSP[P]時,在LP+HLPX位置書寫數字,SHIFT38,COLORFFFF
    當滿足條件WS=WSP[P]時,在LP+HLPX*2位置書寫數字,SHIFT38,COLORFFFFFF
    END
    X1賦值:(收盤價+最低價+最高價)/3
    挑戰巔峰賦值:X1的5日簡單移動平均
    JCZT賦值:如果體系上穿【▲】Z,返回1,否則返回0
    SCZT賦值:如果【▲】Z上穿體系,返回2,否則返回0
    A賦值:SYSPARAM(1)=BARPOS
    時間賦值:如果A>0,返回日期,否則返回體系
    MM賦值:上次日期=時間距今天數
    HH賦值:MM+1日內最高價的最高值
    LL賦值:MM+1日內最低價的最低值
    MID賦值:(HH+LL)/2
    RENQ賦值:【▲】Z-(HH-LL)/6
    加權移平均賦值:收盤價的5日加權移動平均
    JNYY賦值:以成交量(手)/當前流通股本(手)為權重加權移平均的動態移動平均
    個Z賦值:JNYY的3日指數移動平均
    十Z賦值:JNYY的5日指數移動平均
    百Z賦值:JNYY的7日指數移動平均
    千Z賦值:JNYY的9日指數移動平均
    菷Z賦值:JNYY的11日指數移動平均
    PARTLINE(個Z<1日前的個Z,個Z),POINTDOT,線寬為1,COLORFFAA11
    PARTLINE(十Z<1日前的十Z,十Z),POINTDOT,線寬為1,COLORFFBB22
    PARTLINE(百Z<1日前的百Z,百Z),POINTDOT,線寬為1,COLORFFCC33
    PARTLINE(千Z<1日前的千Z,千Z),POINTDOT,線寬為1,COLORFFDD44
    PARTLINE(菷Z<1日前的菷Z,菷Z),POINTDOT,線寬為1,COLORFFEE55
    PARTLINE(個Z>1日前的個Z,個Z),POINTDOT,線寬為1,COLORFF00FF
    PARTLINE(十Z>1日前的十Z,十Z),POINTDOT,線寬為1,COLORFF99FF
    PARTLINE(百Z>1日前的百Z,百Z),POINTDOT,線寬為1,COLORFF88FF
    PARTLINE(千Z>1日前的千Z,千Z),POINTDOT,線寬為1,COLORFF77FF
    PARTLINE(菷Z>1日前的菷Z,菷Z),POINTDOT,線寬為1,COLORFF66FF
    個賦值:挑戰巔峰的3日指數移動平均
    十賦值:挑戰巔峰的5日指數移動平均
    百賦值:挑戰巔峰的7日指數移動平均
    千賦值:挑戰巔峰的9日指數移動平均
    菷賦值:挑戰巔峰的11日指數移動平均
    PARTLINE(個<1日前的個,個),線寬為1,COLORAA00
    PARTLINE(十<1日前的十,十),線寬為1,COLORBB00
    PARTLINE(百<1日前的百,百),線寬為1,COLORCC00
    PARTLINE(千<1日前的千,千),線寬為1,COLORDD00
    PARTLINE(菷<1日前的菷,菷),線寬為1,COLOREE00
    PARTLINE(個>1日前的個,個),線寬為1,COLORAA
    PARTLINE(十>1日前的十,十),線寬為1,COLORBB
    PARTLINE(百>1日前的百,百),線寬為1,COLORCC
    PARTLINE(千>1日前的千,千),線寬為1,COLORDD
    PARTLINE(菷>1日前的菷,菷),線寬為1,COLOREE
    當滿足條件開盤價>=收盤價時,在最高價和最低價位置之間畫柱狀線,寬度為0.2,0不為0則畫空心柱.,COLORFFCC00
    當滿足條件開盤價>=收盤價時,在收盤價和開盤價位置之間畫柱狀線,寬度為8,0不為0則畫空心柱.,COLORFF9F68
    當滿足條件開盤價>=收盤價時,在收盤價和開盤價位置之間畫柱狀線,寬度為7,0不為0則畫空心柱.,COLORFF9900
    當滿足條件開盤價>=收盤價時,在收盤價和開盤價位置之間畫柱狀線,寬度為6,0不為0則畫空心柱.,COLORFFAA11
    當滿足條件開盤價>=收盤價時,在收盤價和開盤價位置之間畫柱狀線,寬度為5,0不為0則畫空心柱.,COLORFFBB11
    當滿足條件開盤價>=收盤價時,在收盤價和開盤價位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,COLORFFCC22
    當滿足條件開盤價>=收盤價時,在收盤價和開盤價位置之間畫柱狀線,寬度為3,0不為0則畫空心柱.,COLORFFDD22
    當滿足條件開盤價>=收盤價時,在收盤價和開盤價位置之間畫柱狀線,寬度為2,0不為0則畫空心柱.,COLORFFEE33
    當滿足條件開盤價>=收盤價時,在收盤價和開盤價位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,COLORFFFF33
    當滿足條件收陽線時,在最高價和最低價位置之間畫柱狀線,寬度為0.2,0不為0則畫空心柱.,COLORFF
    當滿足條件收陽線時,在收盤價和開盤價位置之間畫柱狀線,寬度為8,0不為0則畫空心柱.,COLORCC
    當滿足條件收陽線時,在收盤價和開盤價位置之間畫柱狀線,寬度為7,0不為0則畫空心柱.,COLOR3300CC
    當滿足條件收陽線時,在收盤價和開盤價位置之間畫柱狀線,寬度為6,0不為0則畫空心柱.,COLOR33CC
    當滿足條件收陽線時,在收盤價和開盤價位置之間畫柱狀線,寬度為5,0不為0則畫空心柱.,COLOR6633CC
    當滿足條件收陽線時,在收盤價和開盤價位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,COLOR3333FF
    當滿足條件收陽線時,在收盤價和開盤價位置之間畫柱狀線,寬度為3,0不為0則畫空心柱.,COLOR6633FF
    當滿足條件收陽線時,在收盤價和開盤價位置之間畫柱狀線,寬度為2,0不為0則畫空心柱.,COLOR3366FF
    當滿足條件收陽線時,在收盤價和開盤價位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,COLOR6666FF
    當滿足條件SCZT時,在HH位置畫直線起點,當滿足條件RENQ時,在HH位置畫直線終點,1表示是否延長.,線寬為1,COLORCCDD77
    歷史最高賦值:高
    當滿足條件BARPOS=SYSPARAM(2)時,在最高價位置書寫文字,ALIGN4,COLORFF00FF
    歷史最低賦值:低
    當滿足條件BARPOS=SYSPARAM(2)時,在最高價位置書寫文字,ALIGN4,COLORFFFFFF
    獲利賦值:獲利盤
    當滿足條件BARPOS=SYSPARAM(2)時,在最高價位置書寫文字,ALIGN5,COLORFF00
    套牢賦值:套牢盤
    當滿足條件BARPOS=SYSPARAM(2)時,在最高價位置書寫文字,ALIGN5,COLORFFFFFF
    近賣預測賦值:股票賣出價預測
    當滿足條件BARPOS=SYSPARAM(2)時,在最高價位置書寫文字,ALIGN5,COLORFF00
    近買預測賦值:股票買進價預測
    當滿足條件BARPOS=SYSPARAM(2)時,在最高價位置書寫文字,ALIGN5,COLORFF00CC
    【90%成本】賦值:WIN1
    當滿足條件BARPOS=SYSPARAM(2)時,在最高價位置書寫文字,ALIGN5,COLORFF
    【70%成本】賦值:WIN2
    當滿足條件BARPOS=SYSPARAM(2)時,在最高價位置書寫文字,ALIGN5,COLORFFFFFF
    底出擊賦值:DI
    當滿足條件BARPOS=SYSPARAM(2)時,在最高價位置書寫文字,ALIGN4,COLORFF00CC
    穩建倉賦值:CH
    當滿足條件BARPOS=SYSPARAM(2)時,在最高價位置書寫文字,ALIGN4,COLORCCCCFF
    快刀手賦值:JCFL
    當滿足條件BARPOS=SYSPARAM(2)時,在最高價位置書寫文字,ALIGN4,COLORFFFFFF
    預測賦值:DCFL
    當滿足條件BARPOS=SYSPARAM(2)時,在最高價位置書寫文字,ALIGN4,COLORFFFF
    升浪賦值:SCFL
    當滿足條件BARPOS=SYSPARAM(2)時,在最高價位置書寫文字,ALIGN4,COLOR3300CC
    ?

    源碼:

    ?

    A:=EMA(CLOSE,3);
    B:=EMA(CLOSE,5);
    Z:=EMA(CLOSE,15);
    資本:=REF(HHV(A,B),Z);
    運作:=A;
    體系:=MA(運作,5);
    【▲】Z:=MA(Z,7);
    DRAWGBK(CLOSE=CLOSE,COLORRGB(30,30,30),COLORRGB(130,130,130),1);
    DRAWGBK(CLOSE>OPEN,COLORRGB(110,0,0),COLORRGB(0,0,0),0);
    DRAWGBK(CLOSE<OPEN,COLORRGB(0,110,0),COLORRGB(0,0,0),0);
    獲利盤:=WINNER(CLOSE)*100;
    套牢盤:=100-獲利盤;
    WIN1:=COST(85);
    WIN2:=COST(15);
    股票賣出價預測:=MA(套牢盤,89)*0.618/50+CLOSE;
    股票買進價預測:=CLOSE-MA(套牢盤,60)*0.618/100;
    轉折價明日:=REF(CLOSE,2)*2-REF(CLOSE,5);
    轉折價后日:=REF(CLOSE,1)*2-REF(CLOSE,4);
    轉折價大后日:=CLOSE*2-REF(CLOSE,3);
    高:=HHV(HIGH,0);
    低:=LLV(LOW,0);
    DCFL:=COST(95);
    SCFL:=COST(55);
    JCFL:=COST(15);
    CH:=COST(5);
    DI:=COST(0.38);
    M:=58;
    X:=3;
    P:=SYSPARAM(1);
    WS:=BARPOS;
    WS1:=IF(WS<M,WS,M);
    WSP:=P-WS1+1;
    WSP1:=WS1-1;
    H1:=HHV(HIGH,WS1);
    L1:=LLV(LOW,WS1);
    HP:=H1[P];
    LP:=L1[P];
    HLPX:=(HP-LP)/X;
    IF WS1[P]>1 THEN BEGIN
    DRAWSL(WS=WSP[P],HP,0,WSP1[P],3),POINTDOT,LINETHICK1;
    DRAWSL(WS=WSP[P],LP,0,WSP1[P],3),POINTDOT,LINETHICK1;
    DRAWSL(WS=WSP[P],LP+HLPX,0,WSP1[P],3),POINTDOT,LINETHICK1;
    DRAWSL(WS=WSP[P],LP+HLPX*2,0,WSP1[P],3),POINTDOT,LINETHICK1,colorAAAAAA;
    DRAWNUMBER(WS=WSP[P],HP,HP,2),SHIFT38,colorFF;
    DRAWNUMBER(WS=WSP[P],LP,LP,2),SHIFT38,colorFF00;
    DRAWNUMBER(WS=WSP[P],LP+HLPX,LP+HLPX,2),SHIFT38,colorFFFF;
    DRAWNUMBER(WS=WSP[P],LP+HLPX*2,LP+HLPX*2,2),SHIFT38,colorFFFFFF;
    END;
    X1:=(CLOSE+LOW+HIGH)/3;
    挑戰巔峰:=MA(X1,5);
    JCZT:=IF(CROSS(體系,【▲】Z),1,0);
    SCZT:=IF(CROSS(【▲】Z,體系),2,0);
    A:=SYSPARAM(1)=BARPOS;
    時間:=IF(A>0,DATE,體系);
    MM:=BARSLAST(DATE=時間);
    HH:=HHV(HIGH,MM+1);
    LL:=LLV(LOW,MM+1);
    MID:=(HH+LL)/2;
    RENQ:=【▲】Z-(HH-LL)/6;
    加權移平均:=WMA(CLOSE,5);
    JNYY:=DMA(加權移平均,VOL/CAPITAL);
    個Z:=EMA(JNYY,3);
    十Z:=EMA(JNYY,5);
    百Z:=EMA(JNYY,7);
    千Z:=EMA(JNYY,9);
    萬Z:=EMA(JNYY,11);
    PARTLINE(個Z<REF(個Z,1),個Z),POINTDOT,LINETHICK1,colorFFAA11;
    PARTLINE(十Z<REF(十Z,1),十Z),POINTDOT,LINETHICK1,colorFFBB22;
    PARTLINE(百Z<REF(百Z,1),百Z),POINTDOT,LINETHICK1,colorFFCC33;
    PARTLINE(千Z<REF(千Z,1),千Z),POINTDOT,LINETHICK1,colorFFDD44;
    PARTLINE(萬Z<REF(萬Z,1),萬Z),POINTDOT,LINETHICK1,colorFFEE55;
    PARTLINE(個Z>REF(個Z,1),個Z),POINTDOT,LINETHICK1,colorFF00FF;
    PARTLINE(十Z>REF(十Z,1),十Z),POINTDOT,LINETHICK1,colorFF99FF;
    PARTLINE(百Z>REF(百Z,1),百Z),POINTDOT,LINETHICK1,colorFF88FF;
    PARTLINE(千Z>REF(千Z,1),千Z),POINTDOT,LINETHICK1,colorFF77FF;
    PARTLINE(萬Z>REF(萬Z,1),萬Z),POINTDOT,LINETHICK1,colorFF66FF;
    個:=EMA(挑戰巔峰,3);
    十:=EMA(挑戰巔峰,5);
    百:=EMA(挑戰巔峰,7);
    千:=EMA(挑戰巔峰,9);
    萬:=EMA(挑戰巔峰,11);
    PARTLINE(個<REF(個,1),個),LINETHICK1,colorAA00;
    PARTLINE(十<REF(十,1),十),LINETHICK1,colorBB00;
    PARTLINE(百<REF(百,1),百),LINETHICK1,colorCC00;
    PARTLINE(千<REF(千,1),千),LINETHICK1,colorDD00;
    PARTLINE(萬<REF(萬,1),萬),LINETHICK1,colorEE00;
    PARTLINE(個>REF(個,1),個),LINETHICK1,colorAA;
    PARTLINE(十>REF(十,1),十),LINETHICK1,colorBB;
    PARTLINE(百>REF(百,1),百),LINETHICK1,colorCC;
    PARTLINE(千>REF(千,1),千),LINETHICK1,colorDD;
    PARTLINE(萬>REF(萬,1),萬),LINETHICK1,colorEE;
    STICKLINE(OPEN>=CLOSE,HIGH,LOW,0.2,0),colorFFCC00;
    STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,8,0),colorFF9F68;
    STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,7,0),colorFF9900;
    STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,6,0),colorFFAA11;
    STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,5,0),colorFFBB11;
    STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,4,0),colorFFCC22;
    STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),colorFFDD22;
    STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2,0),colorFFEE33;
    STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1,0),colorFFFF33;
    STICKLINE(CLOSE>OPEN,HIGH,LOW,0.2,0),colorFF;
    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0),colorCC;
    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0),color3300CC;
    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0),color33CC;
    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0),color6633CC;
    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0),color3333FF;
    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),color6633FF;
    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0),color3366FF;
    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0),color6666FF;
    DRAWLINE(SCZT,HH,RENQ,HH,1),LINETHICK1,colorCCDD77;
    歷史最高:=高;
    DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,' 歷史最高'+NUMTOSTR(歷史最高[SYSPARAM(1)],2)),ALIGN4,colorFF00FF;
    歷史最低:=低;
    DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,' 歷史最低'+NUMTOSTR(歷史最低[SYSPARAM(1)],2)),ALIGN4,colorFFFFFF;
    獲利:=獲利盤;
    DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,'獲利'+NUMTOSTR(獲利[SYSPARAM(1)],2)),ALIGN5,colorFF00;
    套牢:=套牢盤;
    DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,' 套牢'+NUMTOSTR(套牢[SYSPARAM(1)],2)),ALIGN5,colorFFFFFF;
    近賣預測:=股票賣出價預測;
    DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,' 近賣預測'+NUMTOSTR(近賣預測[SYSPARAM(1)],2)),ALIGN5,colorFF00;
    近買預測:=股票買進價預測;
    DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,' 近買預測'+NUMTOSTR(近買預測[SYSPARAM(1)],2)),ALIGN5,colorFF00CC;
    【90%成本】:=WIN1;
    DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,' 【90%成本】'+NUMTOSTR(【90%成本】[SYSPARAM(1)],2)),ALIGN5,colorFF;
    【70%成本】:=WIN2;
    DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,' 【70%成本】'+NUMTOSTR(【70%成本】[SYSPARAM(1)],2)),ALIGN5,colorFFFFFF;
    底出擊:=DI;
    DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,'底出擊'+NUMTOSTR(底出擊[SYSPARAM(1)],2)),ALIGN4,colorFF00CC;
    穩建倉:=CH;
    DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,' 穩建倉'+NUMTOSTR(穩建倉[SYSPARAM(1)],2)),ALIGN4,colorCCCCFF;
    快刀手:=JCFL;
    DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,' 快刀手'+NUMTOSTR(快刀手[SYSPARAM(1)],2)),ALIGN4,colorFFFFFF;
    預測:=DCFL;
    DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,' 預測'+NUMTOSTR(預測[SYSPARAM(1)],2)),ALIGN4,colorFFFF;
    升浪:=SCFL;
    DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,' 升浪'+NUMTOSTR(升浪[SYSPARAM(1)],2)),ALIGN4,color3300CC;

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

    怎么收費,代編流程等詳情請點擊查閱!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>