• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 同花順>> 同花順公式>>正文內容

    機會提示主圖指標[同花順公式]

    相關標簽: 精準買賣點指標源碼 、 精準買賣點主圖指標 、 波段精準買賣指標源碼 、 通達信精準買賣點主圖公式 、 通達信精準買賣指標 、 超精準波段買賣點公式 、 趨勢指標買賣提示買賣點 、 買賣點提示指標公式 、 mt4指標最精準組合指標 、 100準的伏擊漲停指標 、 波段精準買賣指標公式 、 股票精準買賣點公式 、

    ?

    提示機會。出擊。逃頂。及時建倉和出倉。跟隨主力。吃中間那一段。

    原理解析:

    VAR1賦值:(收盤價-收盤價的7日指數移動平均)/收盤價的7日指數移動平均
    VAR2賦值:VAR1的3日指數移動平均的3日指數移動平均
    VAR3賦值:VAR1的3日指數移動平均的2日指數移動平均
    VAR4賦值:100*( VAR2+ VAR3)
    VAR5賦值:VAR4的2.5日指數移動平均
    BI賦值:100*(最高價+最低價)/2/收盤價的17日指數移動平均-100
    BUY1賦值:VAR4>1日前的VAR4 AND 1日前的VAR4<2日前的VAR4 AND 2日前的VAR4<3日前的VAR4
    BUY2賦值:1日前的BI>0 AND BUY1 AND VAR4<-2
    BUY3賦值:1日前的BI<0 AND BUY1 AND 1日前的VAR4<-3
    BUY4賦值:VAR4<0 AND VAR4上穿VAR5 AND BUY1
    BUY0賦值:(BUY2 OR BUY3 OR BUY4) AND (大盤的收盤價的5日指數移動平均>1日前的大盤的收盤價的5日指數移動平均 OR VAR4>=1日前的VAR4)
    當滿足條件BUY0時,在-130位置畫38號圖標
    100
    輸出//WWW..COM主力:(收盤價-收盤價的7日簡單移動平均)/收盤價的7日簡單移動平均*480的2日指數移動平均*5,畫綠色,線寬為1
    散戶賦值:(收盤價-收盤價的11日簡單移動平均)/收盤價的11日簡單移動平均*480的7日指數移動平均*5
    BT2賦值:主力上穿散戶 AND 主力<-10
    當滿足條件主力上穿散戶AND主力<-10時,在主力位置畫13號圖標
    如果主力>=1日前的主力,返回主力,否則返回無效數,畫紅色,線寬為1
    如果主力<=1日前的主力,返回主力,否則返回無效數,畫綠色,線寬為1
    BIAS1賦值:(收盤價-收盤價的6日簡單移動平均)/收盤價的6日簡單移動平均*100
    BIAS2賦值:(收盤價-收盤價的12日簡單移動平均)/收盤價的12日簡單移動平均*100
    BIAS3賦值:(收盤價-收盤價的24日簡單移動平均)/收盤價的24日簡單移動平均*100
    BIAS賦值:(BIAS1+2*BIAS2+3*BIAS3)/6
    當滿足條件收陽線時,在橫軸0.01縱軸0.9位置書寫文字,畫紅色
    乖離賦值:BIAS的10日簡單移動平均
    當滿足條件((BIAS上穿乖離AND乖離<-3))時,在108和100位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,畫白色
    當滿足條件(BIAS上穿乖離AND乖離<-3)時,在130位置書寫文字,畫白色
    LC賦值:1日前的收盤價
    RSI賦值:收盤價-LC和0的較大值的6日[1日權重]移動平均/收盤價-LC的絕對值的6日[1日權重]移動平均*100
    頂部賦值:80上穿RSI*35
    逃頂賦值:頂部
    頂賦值:如果逃頂>1日前的逃頂,返回35,否則返回0
    當滿足條件頂=35時,在170位置書寫文字,COLOR00FF00
    當滿足條件頂部時,在110和100位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,畫綠色
    VOLUME賦值:成交量(手)
    主力啟動線賦值:VOLUME的5日簡單移動平均
    主力洗盤線賦值:VOLUME的35日簡單移動平均
    資金異動線賦值:VOLUME的135日簡單移動平均
    輸出誘多:當滿足條件主力啟動線上穿資金異動線OR((主力洗盤線>資金異動線)ANDCROSS(主力啟動線,主力洗盤線))時,在108和100位置之間畫柱狀線,寬度為0.5,0不為0則畫空心柱.,COLORFFFF00
    VARR1賦值:收盤價-1日前的收盤價和0的較大值的6日[1日權重]移動平均/收盤價-1日前的收盤價的絕對值的6日[1日權重]移動平均*100
    當滿足條件82上穿VARR1時,在150位置書寫文字,畫黃色
    當滿足條件誘多時,在147位置書寫文字,COLORFFFF00
    BIASW賦值:(收盤價-收盤價的10日簡單移動平均)/收盤價的10日簡單移動平均*10
    Q賦值:(1日前的最近3日收盤價連跌 AND 收盤價>1日前的收盤價 AND BIASW>=1日前的BIASW)
    當滿足條件Q時,在170位置書寫文字,畫黃色
    當滿足條件Q時,在110和100位置之間畫柱狀線,寬度為0.5,0不為0則畫空心柱.,畫黃色
    AAWW賦值:收盤價-收盤價的6日簡單移動平均
    注賦值:0
    當滿足條件AAWW上穿注時,在90位置畫41號圖標
    TJ1賦值:統計5日中滿足(收陰線)的天數>=3
    TJ2賦值:(收盤價和開盤價的較小值-最低價)/(最高價-最低價)>=0.5
    TJ3賦值:最低價/收盤價和開盤價的較小值<=0.97
    TJ4賦值:(收盤價-收盤價的30日簡單移動平均)/收盤價的30日簡單移動平均*100<-10
    長下影買賦值:TJ1 AND TJ2 AND TJ3 AND TJ4
    當滿足條件長下影買時,在-120和-100位置之間畫柱狀線,寬度為0.1,2不為0則畫空心柱.,畫白色
    當滿足條件長下影買>0時,在-120位置書寫文字,COLORF8FFFF
    DIFF賦值:不定周期收盤價的12日指數移動平均-不定周期收盤價的26日指數移動平均
    DEAP賦值:DIFF的9日指數移動平均,COLORFFFF00
    MACD賦值:(DIFF-DEAP)*2
    A1賦值:上次1日前的DIFF上穿DEAP距今天數
    AR1賦值:1日前的收盤價
    AR2賦值:收盤價-AR1和0的較大值的7日[1日權重]移動平均/收盤價-AR1的絕對值的7日[1日權重]移動平均*100
    輸出特準:當滿足條件1日前的AR2<20ANDAR2>1日前的AR2的5日過濾時,在40和0位置之間畫柱狀線,寬度為1,1不為0則畫空心柱.,COLOR0066FF
    當滿足條件特準時,在35位置書寫文字,COLOR0066FF
    增減力度賦值:(收盤價的34.000日簡單移動平均 - 收盤價) / 收盤價的34.000日簡單移動平均 * 10.000
    當滿足條件1.700上穿增減力度時,在51和10位置之間畫柱狀線,寬度為0.1,0不為0則畫空心柱.,畫白色
    當滿足條件1.700上穿增減力度時,在63位置書寫文字,畫白色
    當滿足條件0.019100上穿增減力度的21日過濾時,在106和100位置之間畫柱狀線,寬度為0.5,0不為0則畫空心柱.,畫綠色
    當滿足條件0.019100上穿增減力度的21日過濾時,在120位置書寫文字,畫綠色
    AA賦值:收盤價的5日指數移動平均-收盤價的13日指數移動平均
    BBP賦值:AA的3日指數移動平均
    X賦值:AA>1日前的AA
    Y賦值:3日前的AA>=2日前的AA
    Z賦值:2日前的AA>=1日前的AA
    Z1賦值:AA<BBP
    注意賦值:X AND Y AND Z AND Z1?
    當滿足條件注意時,在1位置書寫文字,畫淡洋紅色
    當滿足條件注意時,在10位置畫1號圖標
    OSC賦值:100*(收盤價-收盤價的20日簡單移動平均)
    MAOSC賦值:OSC的6日指數移動平均
    BIASWP賦值:(收盤價-收盤價的20日簡單移動平均)/收盤價的20日簡單移動平均*100
    BIASMA賦值:BIASWP的6日簡單移動平均
    F賦值:100*(收盤價-1日前的收盤價)/1日前的收盤價
    P1賦值:如果收盤價<1日前的開盤價ANDF<0,返回1,否則返回0
    P2賦值:如果收盤價<2日前的開盤價ANDF<0,返回1,否則返回0
    LIN賦值:如果P1=0ANDREF(P1,1)=1ANDP2=0ANDREF(P2,1)=1,返回1,否則返回0
    SS1賦值:OSC上穿MAOSC AND LIN
    當滿足條件SS1時,在-20位置書寫文字,COLOR00FFFF
    當滿足條件SS1時,在-60和-20位置之間畫柱狀線,寬度為1,1不為0則畫空心柱.,COLOR00FFFF
    SS賦值:OSC上穿MAOSC AND BIASWP上穿BIASMA AND LIN
    當滿足條件SS時,在-60位置書寫文字,畫紅色
    當滿足條件SS時,在-70和-30位置之間畫柱狀線,寬度為0.2,0不為0則畫空心柱.,畫紅色
    A2賦值:上次1日前的"KDJ的K"(9,3,3)上穿"KDJ的D"(9,3,3)距今天數
    B2賦值:A2+1日前的收盤價>收盤價 AND A2+1日前的"KDJ的K"(9,3,3)<"KDJ的K"(9,3,3) AND "KDJ的K"(9,3,3)上穿"KDJ的D"(9,3,3)
    A3賦值:上次1日前的"RSI.RSI1"(6,12,24)上穿"RSI.RSI2"(6,12,24)距今天數
    B3賦值:A3+1日前的收盤價>收盤價 AND A3+1日前的"RSI.RSI1"(6,12,24)<"RSI.RSI1"(6,12,24) AND "RSI.RSI1"(6,12,24)上穿"RSI.RSI2"(6,12,24)
    當滿足條件B2>0時,在-146和-134位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,COLOR00FFFF
    當滿足條件B2>0時,在-138位置書寫文字,畫黃色
    當滿足條件B3>0時,在-94和-82位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,COLORFF00FF
    當滿足條件B3>0時,在-86位置書寫文字,COLORFF00FF
    FL賦值:成交量(手)>1日前的成交量(手) OR 成交量(手)>成交量(手)的5日簡單移動平均
    SZ賦值:(收盤價上穿收盤價的3日簡單移動平均 OR 收盤價上穿收盤價的5日簡單移動平均) AND 收盤價>=開盤價
    放量賦值:如果FLANDSZ,返回1,否則返回0
    當滿足條件放量時,在-120和-108位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,畫淡紅色
    當滿足條件放量時,在-112位置書寫文字,畫淡紅色
    弱轉強賦值:CCI上穿-200 AND CCI>1日前的CCI
    當滿足條件弱轉強時,在108和100位置之間畫柱狀線,寬度為0.5,0不為0則畫空心柱.,畫紅色
    當滿足條件弱轉強時,在125位置書寫文字,畫紅色
    ?

    源碼:

    VAR1:=(C-EMA(C,7))/EMA(C,7);VAR2:=EMA(EMA(VAR1,3),3);VAR3:=EMA(EMA(VAR1,3),2);VAR4:=100*( VAR2+ VAR3);VAR5:=EMA(VAR4,2.5);BI:=100*(H+L)/2/EMA(C,17)-100;BUY1:=VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2) AND REF(VAR4,2)<REF(VAR4,3);BUY2:=REF(BI,1)>0 AND BUY1 AND VAR4<-2;BUY3:=REF(BI,1)<0 AND BUY1 AND REF(VAR4,1)<-3;BUY4:=VAR4<0 AND CROSS(VAR4,VAR5) AND BUY1;BUY0:=(BUY2 OR BUY3 OR BUY4) AND (EMA(INDEXC,5)>REF(EMA(INDEXC,5),1) OR VAR4>=REF(VAR4,1));DRAWICON(BUY0,-130,38);100;//www..com主力:EMA( (CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2)*5,colorgreen,LINETHICK1;散戶:=EMA( (CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7)*5;BT2:=CROSS(主力,散戶) AND 主力<-10;DRAWICON(CROSS(主力,散戶) AND 主力<-10,主力,13);IF(主力>=REF(主力,1),主力,DRAWNULL),colorred,LINETHICK1;IF(主力<=REF(主力,1),主力,DRAWNULL),colorgreen,LINETHICK1;BIAS1:=(C-MA(C,6))/MA(C,6)*100;BIAS2:=(C-MA(C,12))/MA(C,12)*100;BIAS3:=(C-MA(C,24))/MA(C,24)*100;BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;DRAWTEXT_FIX(C>O,0.01,0.9,0,' www.guhai.com.cn '),colorred;乖離:=MA(BIAS,10);STICKLINE(((CROSS(BIAS,乖離)AND 乖離<-3)),108,100,1,0),colorwhite;DRAWTEXT((CROSS(BIAS,乖離)AND 乖離<-3),130,'←變'),colorwhite;LC:=REF(CLOSE,1);RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;頂部:=CROSS(80,RSI)*35;逃頂:=頂部;頂:=IF(逃頂>REF(逃頂,1),35,0);DRAWTEXT(頂=35,170,'←頂'),COLOR00FF00;STICKLINE(頂部,110,100,1,0),colorgreen;VOLUME:=VOL;主力啟動線:=MA(VOLUME,5);主力洗盤線:=MA(VOLUME,35);資金異動線:=MA(VOLUME,135);誘多:STICKLINE(CROSS(主力啟動線,資金異動線) OR ((主力洗盤線 > 資金異動線) AND CROSS(主力啟動線,主力洗盤線)),108,100,0.5,0),COLORFFFF00;VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;DRAWTEXT(CROSS(82,VARR1),150,'←逃'),coloryellow;DRAWTEXT(誘多,147,'←誘'),COLORFFFF00;BIASW:=(CLOSE-MA(CLOSE,10))/MA(CLOSE,10)*10;Q:=(REF(DOWNNDAY(CLOSE,3),1) AND C>REF(C,1) AND BIASW>=REF(BIASW,1));DRAWTEXT(Q,170,'←機會'),coloryellow;STICKLINE(Q,110,100,0.5,0),coloryellow;AAWW:=C-MA(C,6);注:=0;DRAWICON(CROSS(AAWW,注),90,41);TJ1:=COUNT((C<O),5)>=3;TJ2:=(MIN(C,O)-L)/(H-L)>=0.5;TJ3:=L/MIN(C,O)<=0.97;TJ4:=(C-MA(C,30))/MA(C,30)*100<-10;長下影買:=TJ1 AND TJ2 AND TJ3 AND TJ4;STICKLINE(長下影買,-120,-100,0.1,2),colorwhite;DRAWTEXT(長下影買>0,-120,'長下影買'),COLORF8FFFF;DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);DEAP:=EMA(DIFF,9),COLORFFFF00;MACD:=(DIFF-DEAP)*2;A1:=BARSLAST(REF(CROSS(DIFF,DEAP),1));AR1:=REF(CLOSE,1);AR2:=SMA(MAX(CLOSE-AR1,0),7,1)/SMA(ABS(CLOSE-AR1),7,1)*100;特準:STICKLINE(FILTER(REF(AR2,1)<20 AND AR2>REF(AR2,1),5),40,0,1,1),COLOR0066FF;DRAWTEXT(特準,35,'←絕殺'),COLOR0066FF;增減力度:=(MA(CLOSE,34.000) - CLOSE) / MA(CLOSE, 34.000) * 10.000;STICKLINE(CROSS( 1.700,增減力度), 51,10,0.1,0),colorwhite;DRAWTEXT(CROSS( 1.700,增減力度), 63,'←底'),colorwhite;STICKLINE(FILTER(CROSS(0.019100,增減力度),21),106,100,0.5,0),colorgreen;DRAWTEXT(FILTER(CROSS(0.019100,增減力度),21), 120,'←小心'),colorgreen;AA:=EMA(C,5)-EMA(C,13);BBP:=EMA(AA,3);X:=AA>REF(AA,1); Y:=REF(AA,3)>=REF(AA,2);Z:=REF(AA,2)>=REF(AA,1);Z1:=AA<BBP;注意:=X AND Y AND Z AND Z1 ;DRAWTEXT(注意,1,'啟動'),colorlimagenta;DRAWICON(注意,10,1);OSC:=100*(CLOSE-MA(CLOSE,20));MAOSC:=EMA(OSC,6);BIASWP:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100;BIASMA:=MA(BIASWP,6);F:=100*(C-REF(C,1))/REF(C,1);P1:=IF(C<REF(O,1) AND F<0,1,0);P2:=IF(C<REF(O,2) AND F<0,1,0);LIN:=IF(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,1,0);SS1:=CROSS(OSC,MAOSC) AND LIN;DRAWTEXT(SS1,-20,'←反彈'),COLOR00FFFF;STICKLINE(SS1,-60,-20,1,1),COLOR00FFFF;SS:=CROSS(OSC,MAOSC) AND CROSS(BIASWP,BIASMA) AND LIN;DRAWTEXT(SS,-60,'←激進'),colorred;STICKLINE(SS,-70,-30,0.2,0),colorred;A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));STICKLINE(B2>0,-146,-134,1,0),COLOR00FFFF;DRAWTEXT(B2>0,-138,'←啟動'),coloryellow;STICKLINE(B3>0,-94,-82,1,0),COLORFF00FF;DRAWTEXT(B3>0,-86,'←走強'),COLORFF00FF;FL:=V>REF(V,1) OR V>MA(V,5);SZ:=(CROSS(C,MA(C,3)) OR CROSS(C,MA(C,5))) AND C>=O;放量:=IF(FL AND SZ,1,0);STICKLINE(放量,-120,-108,1,0),colorlired;DRAWTEXT(放量,-112,'←放量'),colorlired;弱轉強:=CROSS(CCI,-200) AND CCI>REF(CCI,1);STICKLINE(弱轉強,108,100,0.5,0),colorred;DRAWTEXT(弱轉強,125,'←出擊'),colorred;

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

    可聯系技術人員 QQ: 1145508240  點擊這里給我發消息進行 有償 編寫!不貴!點擊查看價格!

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>