• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 同花順>> 同花順公式>>正文內容

    雷電KDJ指標公式源碼[同花順公式]

    相關標簽: 通達信macd指標公式 、 隨機指標kdj計算方法 、 kdj指標詳解圖解短線 、 通達信指標公式大全 、 kdj指標詳解買入絕技 、 kdj指標參數設置 、 股票kdj指標是什么意思 、 股市kdj線圖怎么看 、

    ?

    閃電KDJ使用說明1.K線向下交叉D值做賣,K線向上交叉D值做買。2 高檔連續二次向下交叉確認跌勢,低擋連續二次向上交叉 確認漲勢。3 J值<10%超賣,J值>90%超買。4 柱線反映短線波動的相對高低點,低位紅柱線提示買入,高位綠柱線提示賣出。5 紅色↑和綠色↓標志作為買入點和賣出點,具有一定參考價值,出現后宜以1/3 倉位操作,因為該指標(ZIG)引用了未來數據。

    {程序化交易 www.planetbokep.com }

    原理解析:

    輸出ZZ:50
    RSV=(收盤價-N日內最低價的最低值)/(N日內最高價的最高值-N日內最低價的最低值)*100
    A=RSV的M1日[1日權重]移動平均
    B=A的M2日[1日權重]移動平均
    E=3*A-2*B
    輸出KK:6,COLOR7777BF
    輸出KKK:94
    K賦值:A的3日簡單移動平均
    D賦值:B的3日簡單移動平均
    J賦值:E的3日簡單移動平均
    VARB1賦值:收盤價96/N54%的之字轉向
    輸出烏云:如果2日前的VARB1<1日前的VARB1ANDVARB1<1日前的VARB1,返回75,否則返回94,畫綠色
    當滿足條件2日前的VARB1<1日前的VARB1ANDVARB1<1日前的VARB1時,在73位置畫"賣出平倉"號圖標
    輸出獵豹: 如果2日前的VARB1>1日前的VARB1ANDVARB1>1日前的VARB1,返回25,否則返回6,畫紅色
    當滿足條件2日前的VARB1>1日前的VARB1ANDVARB1>1日前的VARB1時,在28位置畫"買入開倉"號圖標
    趨勢慢賦值:J的4日指數移動平均
    買入信號賦值: 如果J上穿趨勢慢,返回10,否則返回0
    輸出賣出信號: =如果趨勢慢上穿J,返回70,否則返回80
    當滿足條件買入信號=10AND趨勢慢<50時,在4和0位置之間畫柱狀線,寬度為20,0不為0則畫空心柱.,COLOR0000FF
    當滿足條件賣出信號=70AND趨勢慢>50時,在100和96位置之間畫柱狀線,寬度為20,0不為0則畫空心柱.,COLOR00FF00
    必升賦值:((收盤價-32日內最低價的最低值)/(32日內最高價的最高值-32日內最低價的最低值)*1.2*收盤價)*4
    升賦值:必升的3日指數移動平均
    繼續升賦值:必升的5日指數移動平均
    還要升賦值:必升的7日指數移動平均
    T1賦值:繼續升>=還要升 AND 升<1日前的升
    T2賦值:繼續升<還要升 AND 升>1日前的升
    當滿足條件升>=繼續升時,在還要升和升位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,COLOR0000FF
    當滿足條件升>=繼續升時,在還要升和1日前的升位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,COLOR0000FF
    當滿足條件升<繼續升時,在還要升和升位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,COLORFF9900
    當滿足條件升<繼續升時,在還要升和1日前的升位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,COLORFF9900
    當滿足條件T1時,在升和還要升位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,COLORFFDD55
    當滿足條件T1時,在升和1日前的還要升位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,COLORFFDD55
    當滿足條件T2時,在升和還要升位置之間畫柱狀線,寬度為6,0不為0則畫空心柱.,COLOR00FFFF
    當滿足條件T2時,在升和1日前的還要升位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,COLOR00FFFF
    ?

    源碼:

    zz:50;RSV=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;a=SMA(RSV,M1,1);b=SMA(a,M2,1);e=3*a-2*b;kk:6,Color7777bf;kkk:94;K:=MA(a,3);D:=MA(b,3);J:=MA(e,3);VarB1:=ZIG(3,96/N54);烏云:IF( REF(varB1,2)<REF(varB1,1) AND varB1<REF(varB1,1),75,94),colorgreen;DRAWICON(REF(varB1,2)<REF(varB1,1) AND varB1<REF(varB1,1),73,"sell");獵豹: IF(REF(VarB1,2)>REF(VarB1,1) AND VarB1>REF(VarB1,1),25,6),colorred;DRAWICON(REF(VarB1,2)>REF(VarB1,1) AND VarB1>REF(VarB1,1),28,"buy");趨勢慢:=EMA(j,4);買入信號:= IF(CROSS(j,趨勢慢),10,0);賣出信號: =IF(CROSS(趨勢慢,j),70,80);STICKLINE(買入信號=10 AND 趨勢慢<50 ,4,0,20,0),Color0000ff;STICKLINE(賣出信號=70 AND 趨勢慢>50 ,100,96,20,0),Color00ff00;必升:=((CLOSE-LLV(LOW,32))/(HHV(HIGH,32)-LLV(LOW,32))*1.2*CLOSE)*4;升:=EMA(必升,3);//www..com/繼續升:=EMA(必升,5);還要升:=EMA(必升,7);T1:=繼續升>=還要升 AND 升<REF(升,1);T2:=繼續升<還要升 AND 升>REF(升,1);STICKLINE(升>=繼續升,還要升,升,4,0),Color0000ff;STICKLINE(升>=繼續升,還要升,REF(升,1),1,0),Color0000ff;STICKLINE(升<繼續升,還要升,升,4,0),Colorff9900;STICKLINE(升<繼續升,還要升,REF(升,1),1,0),Colorff9900;STICKLINE(T1,升,還要升,4,0),Colorffdd55;STICKLINE(T1,升,REF(還要升,1),1,0),Colorffdd55;STICKLINE(T2,升,還要升,6,0),Color00ffff;STICKLINE(T2,升,REF(還要升,1),1,0),Color00ffff;

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

    可聯系技術人員 QQ: 1145508240  點擊這里給我發消息進行 有償 編寫!不貴!點擊查看價格!

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>