• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 同花順>> 同花順公式>>正文內容

    TY一分鐘漲跌指標公式[同花順公式]

    相關標簽: 通達信今買明賣指標公式 、 超牛的成交量指標公式 、 通達信均線指標公式 、 通達信波段指標公式 、 通達信趨勢線指標公式 、 今買明賣指標公式源碼 、

    ?

    當前成交量與前5個交易日同時段的成交量平均值的比值,以判斷當前是否在放量、縮量。

    原理解析:

    V1賦值:(收盤價*2+最高價+最低價)/4*10
    V2賦值:V1的13日指數移動平均-V1的34日指數移動平均
    V3賦值:V2的5日指數移動平均
    V4賦值:2*(V2-V3)*5.5
    輸出主力撤: 如果V4<=0,返回V4,否則返回0,畫藍色
    輸出主力進: 如果V4>=0,返回V4,否則返回0,COLORFF00FF
    V5賦值:(8日內大盤的最高價的最高值-大盤的收盤價)/(8日內大盤的最高價的最高值-8日內大盤的最低價的最低值)*8
    V6賦值:3*V5-2*V5的18日[1日權重]移動平均的5日指數移動平均
    V7賦值:(大盤的收盤價-8日內大盤的最低價的最低值)/(8日內大盤的最高價的最高值-8日內大盤的最低價的最低值)*10
    V8賦值:(大盤的收盤價*2+大盤的最高價+大盤的最低價)/4
    V9賦值:V8的13日指數移動平均-V8的34日指數移動平均
    VA賦值:V9的3日指數移動平均
    VB賦值:(V9-VA)/2
    輸出大盤資金進場:如果VB>=0,返回VB,否則返回0,
    輸出大盤資金撤走:如果VB<=0,返回VB,否則返回0,
    V11賦值:3*(收盤價-55日內最低價的最低值)/(55日內最高價的最高值-55日內最低價的最低值)*100的5日[1日權重]移動平均-2*(收盤價-55日內最低價的最低值)/(55日內最高價的最高值-55日內最低價的最低值)*100的5日[1日權重]移動平均的3日[1日權重]移動平均
    輸出趨勢線: V11的3日指數移動平均
    V12賦值:(趨勢線-1日前的趨勢線)/1日前的趨勢線*100
    輸出準備現金: 當滿足條件趨勢線<=13時,在0和25位置之間畫柱狀線,寬度為10,0不為0則畫空心柱.,COLORCC9900
    AA賦值:(趨勢線<=13) AND (趨勢線<=13)的15日過濾
    當滿足條件AA時,在30位置書寫文字,COLORCC9900
    輸出買入股票: 當滿足條件趨勢線<=13ANDV12>13時,在0和40位置之間畫柱狀線,寬度為10,0不為0則畫空心柱.,COLOR0099FF
    BB賦值: (趨勢線<=13 AND V12>13) AND (趨勢線<=13ANDV12>13)的10日過濾?
    當滿足條件BB時,在60位置書寫文字,COLOR0099FF
    輸出賣臨界: 當滿足條件趨勢線>90AND趨勢線>1日前的趨勢線時,在105和100位置之間畫柱狀線,寬度為15,1不為0則畫空心柱.,COLORFFFF00
    見頂清倉賦值:趨勢線>90AND趨勢線<1日前的趨勢線AND主力進<1日前的主力進的8日過濾
    當滿足條件見頂清倉時,在110位置書寫文字,畫黃色
    CC賦值:(趨勢線>=90 AND V12) AND (趨勢線>=90ANDV12)的10日過濾
    當滿足條件大盤資金進場AND趨勢線<13時,在0和20位置之間畫柱狀線,寬度為10,0不為0則畫空心柱.,畫紅色
    當滿足條件大盤資金撤走AND趨勢線>90時,在0和20位置之間畫柱狀線,寬度為10,0不為0則畫空心柱.,畫綠色
    當滿足條件主力進AND趨勢線<13時,在0和35位置之間畫柱狀線,寬度為10,0不為0則畫空心柱.,COLORFF00FF
    當滿足條件主力撤AND趨勢線>90時,在0和35位置之間畫柱狀線,寬度為10,0不為0則畫空心柱.,畫藍色
    R0賦值:((如果ISNULL(ZDMR[-1]),返回0,否則返回ZDMR+如果ISNULL(BDMR[-1]),返回0,否則返回BDMR)-(如果ISNULL(ZDMC[-1]),返回0,否則返回ZDMC+如果ISNULL(BDMC[-1]),返回0,否則返回BDMC))/SHGZG*100
    MA5賦值:R0的5日簡單移動平均
    中位線賦值:1.75
    最小值賦值:10日內最低價的最低值
    最大值賦值:25日內最高價的最高值
    波動線賦值:(收盤價-最小值)/(最大值-最小值)*4的4日指數移動平均
    平均線=波動線的3日指數移動平均
    PARTLINE(0,平均線>=1日前的平均線,畫紅色,平均線<1日前的平均線,畫綠色)
    主力動能賦值:R0的5日簡單移動平均
    主力攻擊賦值:R0-(1日前的R0的絕對值+2日前的R0的絕對值+3日前的R0的絕對值+4日前的R0的絕對值+5日前的R0的絕對值/2)>0 AND 平均線>=1日前的平均線 AND 1日前的平均線<2日前的平均線
    主力撤退賦值:-((R0+(1日前的R0的絕對值+2日前的R0的絕對值+3日前的R0的絕對值+4日前的R0的絕對值+5日前的R0的絕對值/2)<0) AND 平均線<=1日前的平均線 AND 1日前的平均線>2日前的平均線)
    當滿足條件主力攻擊>0時,在主力攻擊+25位置書寫文字,COLORF00FF0
    當滿足條件主力撤退<0時,在主力撤退+89位置書寫文字,畫綠色
    當滿足條件主力撤退<0時,在100和50位置之間畫柱狀線,寬度為10,0不為0則畫空心柱.,畫藍色,線寬為1
    當滿足條件主力攻擊>0時,在0和90位置之間畫柱狀線,寬度為10,0不為0則畫空心柱.,COLORF00FF0,線寬為1
    J賦值: (收盤價-30日內最低價的最低值)/(30日內最高價的最高值-30日內最低價的最低值)*100的5日指數移動平均?
    賦值:(收盤價-收盤價的6日簡單移動平均)/收盤價的6日簡單移動平均*100
    賦值:(收盤價-收盤價的12日簡單移動平均)/收盤價的12日簡單移動平均*100
    賦值:(收盤價-收盤價的24日簡單移動平均)/收盤價的24日簡單移動平均*100
    MM賦值:(BIAS1W+2*BIAS2W+3*BIAS3W)/6
    MN賦值:MM的3日簡單移動平均
    VAR24賦值:36日內最低價的最低值
    VAR25賦值:30日內最高價的最高值
    VAR26賦值:(收盤價-VAR24)/(VAR25-VAR24)*4的4日指數移動平均*25
    輸出/*股經:J,畫紅色,線寬為1
    底觀察賦值:如果MN<-4,返回10,否則返回0,畫淡藍色,線寬為1
    輸出底背離:如果(VAR26<10),返回90,否則返回100, 畫紅色,線寬為1
    輸出頂背離:如果(VAR26>90),返回10,否則返回0, 畫黃色,線寬為1
    當滿足條件VAR26>10ANDREF(VAR26,1)<10時,在95位置畫1號圖標
    當滿足條件VAR26<90ANDREF(VAR26,1)>90時,在5位置畫2號圖標
    LC賦值:1日前的收盤價
    WRSI賦值:收盤價-LC和0的較大值的9日[1日權重]移動平均/收盤價-LC的絕對值的9日[1日權重]移動平均*100
    當滿足條件20上穿WRSI時,在收盤價位置畫1號圖標
    當滿足條件WRSI上穿80時,在收盤價位置畫2號圖標
    RSV賦值:(收盤價-9日內最低價的最低值)/(9日內最高價的最高值-9日內最低價的最低值)*100
    K賦值:RSV的3日[1日權重]移動平均
    D賦值:K的3日[1日權重]移動平均
    J賦值:3*K-2*D
    VARV賦值:(2*收盤價+最高價+最低價)/4
    VARU賦值:30日內最低價的最低值
    VARA1賦值:30日內最高價的最高值
    B賦值:(VARV-VARU)/(VARA1-VARU)*100的8日指數移動平均
    B1賦值:B的5日指數移動平均
    當滿足條件B-B1>0時,在B和B1位置之間畫柱狀線,寬度為8,1不為0則畫空心柱.,畫紅色
    當滿足條件B-B1<0時,在B和B1位置之間畫柱狀線,寬度為8,1不為0則畫空心柱.,COLOR00FF00
    LC賦值:1日前的收盤價
    RSI賦值:收盤價-LC和0的較大值的6日[1日權重]移動平均/收盤價-LC的絕對值的6日[1日權重]移動平均*100
    低吸賦值:如果RSI上穿11,返回70,否則返回0,畫白色,POINTDOT
    當滿足條件低吸時,在70和0位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,畫白色
    VAR7賦值:成交額(元)/成交量(手)/100的3日指數移動平均
    VAR8賦值:VAR7的88日指數移動平均
    VAR9賦值:VAR7的88日指數移動平均*0.85
    VARA賦值:VAR9*0.87
    VARB賦值:最低價<VARA AND 收盤價>1日前的收盤價*1.02
    當滿足條件VARB的6日過濾時,在65和0位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,COLORFF00FF
    堅決買進賦值:如果VARB的6日過濾,返回65,否則返回0,COLORFF00FF,POINTDOT
    VARF賦值:(2*收盤價+最高價+最低價)/4
    VA4賦值:34日內最低價的最低值
    VA5賦值:34日內最高價的最高值
    VA6賦值:(VARF-VA4)/(VA5-VA4)*100的6日指數移動平均
    VA7賦值:0.667*1日前的VA6+0.333*VA6的4日指數移動平均
    出擊賦值:如果如果統計8日中滿足收盤價<1日前的收盤價的天數/8>0.3ANDCOUNT(VA6>VA7,3)ANDREF(最低價,1)=120日內最低價的最低值ANDCLOSE>開盤價,返回1,否則返回0,返回1,否則返回0,畫黃色,POINTDOT
    當滿足條件如果統計8日中滿足收盤價<1日前的收盤價的天數/8>0.3ANDCOUNT(VA6>VA7,3)ANDREF(最低價,1)=120日內最低價的最低值ANDCLOSE>開盤價,返回1,否則返回0時,在60和0位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,畫黃色
    A賦值:(3*收盤價+最低價+開盤價+最高價)/6
    D1賦值:(20*A+19*1日前的A+18*2日前的A+17*3日前的A+16*4日前的A+15*5日前的A+14*6日前的A+13*7日前的A+12*8日前的A+11*9日前的A+10*10日前的A+9*11日前的A+8*12日前的A+7*13日前的A+6*14日前的A+5*15日前的A+4*16日前的A+3*17日前的A+2*18日前的A+20日前的A)/211
    COMD2賦值:D1的2日指數移動平均
    D3賦值:D2的2日指數移動平均
    K1賦值:D3的2日指數移動平均
    多方趨勢賦值:7*(收盤價-27日內最低價的最低值)/(27日內最高價的最高值-27日內最低價的最低值)*30的4日[1日權重]移動平均-3*(收盤價-27日內最低價的最低值)/(27日內最高價的最高值-27日內最低價的最低值)*30的4日[1日權重]移動平均的3日[1日權重]移動平均-(收盤價-27日內最低價的最低值)/(27日內最高價的最高值-27日內最低價的最低值)*30的4日[1日權重]移動平均的3日[1日權重]移動平均的2日[1日權重]移動平均
    天線賦值:78.89
    當滿足條件天線上穿多方趨勢時,在95和100位置之間畫柱狀線,寬度為10,0不為0則畫空心柱.,COLOR00FF00
    ?

    源碼:

    V1:=(C*2+H+L)/4*10;V2:=EMA(V1,13)-EMA(V1,34);V3:=EMA(V2,5); V4:=2*(V2-V3)*5.5;主力撤: IF(V4<=0,V4,0),colorblue;主力進: IF(V4>=0,V4,0),COLORFF00FF;V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;V6:=EMA(3*V5-2*SMA(V5,18,1),5);V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;V8:=(INDEXC*2+INDEXH+INDEXL)/4;V9:=EMA(V8,13)-EMA(V8,34);VA:=EMA(V9,3);VB:=(V9-VA)/2;大盤資金進場:IF(VB>=0,VB,0),;大盤資金撤走:IF(VB<=0,VB,0),;V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);趨勢線: EMA(V11,3);V12:=(趨勢線-REF(趨勢線,1))/REF(趨勢線,1)*100;準備現金: STICKLINE(趨勢線<=13,0,25,10,0),COLORCC9900;AA:=(趨勢線<=13) AND FILTER((趨勢線<=13),15);DRAWTEXT (AA,30,'準備現金'),COLORCC9900;買入股票: STICKLINE(趨勢線<=13 AND V12>13,0,40,10,0),COLOR0099FF;BB:= (趨勢線<=13 AND V12>13) AND FILTER((趨勢線<=13 AND V12>13),10) ;DRAWTEXT (BB,60,'買入股票'),COLOR0099FF;賣臨界: STICKLINE(趨勢線>90 AND 趨勢線>REF(趨勢線,1),105,100,15,1),COLORFFFF00;見頂清倉:=FILTER(趨勢線>90 AND 趨勢線<REF(趨勢線,1) AND 主力進<REF(主力進,1),8);DRAWTEXT( 見頂清倉,110,'逃頂'),coloryellow;CC:=(趨勢線>=90 AND V12) AND FILTER((趨勢線>=90 AND V12),10);STICKLINE(大盤資金進場 AND 趨勢線<13,0,20,10,0),colorred;STICKLINE(大盤資金撤走 AND 趨勢線>90,0,20,10,0),colorgreen;STICKLINE(主力進 AND 趨勢線<13,0,35,10,0),COLORFF00FF;STICKLINE(主力撤 AND 趨勢線>90,0,35,10,0),colorblue;r0:=((IF(ISNULL(ZDMR[-1]),0,ZDMR)+IF(ISNULL(BDMR[-1]),0,BDMR))-(IF(ISNULL(ZDMC[-1]),0,ZDMC)+IF(ISNULL(BDMC[-1]),0,BDMC)))/SHGZG*100;MA5:=MA(r0,5);中位線:=1.75;最小值:=LLV(LOW,10);最大值:=HHV(HIGH,25);波動線:=EMA((CLOSE-最小值)/(最大值-最小值)*4,4);平均線=EMA(波動線,3);PARTLINE(0,平均線>=REF(平均線,1),colorred,平均線<REF(平均線,1),colorgreen);主力動能:=MA(r0,5);主力攻擊:=r0-(ABS(REF(r0,1))+ABS(REF(r0,2))+ABS(REF(r0,3))+ABS(REF(r0,4))+ABS(REF(r0,5))/2)>0 AND 平均線>=REF(平均線,1) AND REF(平均線,1)<REF(平均線,2);主力撤退:=-((r0+(ABS(REF(r0,1))+ABS(REF(r0,2))+ABS(REF(r0,3))+ABS(REF(r0,4))+ABS(REF(r0,5))/2)<0) AND 平均線<=REF(平均線,1) AND REF(平均線,1)>REF(平均線,2));DRAWTEXT(主力攻擊>0,主力攻擊+25,"主力攻擊"),colorF00FF0;DRAWTEXT(主力撤退<0,主力撤退+89,"主力撤退"),colorgreen;STICKLINE(主力撤退<0,100,50,10,0),colorblue,LINETHICK1;STICKLINE(主力攻擊>0,0,90,10,0),colorF00FF0,LINETHICK1;J:= EMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,5) ;BIAS1W :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;BIAS2W :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;BIAS3W :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;MM:=(BIAS1W+2*BIAS2W+3*BIAS3W)/6;MN:=MA(MM,3);VAR24:=LLV(LOW,36);VAR25:=HHV(HIGH,30);VAR26:=EMA((CLOSE-VAR24)/(VAR25-VAR24)*4,4)*25;/*股經:J,colorred,LINETHICK1;*/底觀察:=IF(MN<-4,10,0),colorliblue,LINETHICK1;底背離:IF((VAR26<10),90,100), colorred,LINETHICK1;頂背離:IF((VAR26>90),10,0), coloryellow,LINETHICK1;DRAWICON(VAR26>10 AND REF(VAR26,1)<10,95,1);DRAWICON(VAR26<90 AND REF(VAR26,1)>90,5,2);/*LC:=REF(C,1);WRSI:=SMA(MAX(C-LC,0),9,1)/SMA(ABS(C-LC),9,1)*100;DRAWICON(CROSS(20,WRSI),C,1);DRAWICON(CROSS(WRSI,80),C,2);*/RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;VARV:=(2*C+H+L)/4;VARU:=LLV(LOW,30);VARA1:=HHV(HIGH,30);B:=EMA((VARV-VARU)/(VARA1-VARU)*100,8);B1:=EMA(B,5);STICKLINE(B-B1>0,B,B1,8,1),colorred;STICKLINE(B-B1<0,B,B1,8,1),COLOR00FF00;LC:=REF(CLOSE,1);RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;低吸:=IF(CROSS(RSI,11),70,0),colorwhite,POINTDOT;STICKLINE(低吸,70,0,4,0),colorwhite;VAR7:=EMA(AMOUNT/VOL/100,3);VAR8:=EMA(VAR7,88);VAR9:=EMA(VAR7,88)*0.85;VARA:=VAR9*0.87;VARB:=LOW<VARA AND CLOSE>REF(CLOSE,1)*1.02;STICKLINE(FILTER(VARB,6),65,0,4,0),COLORFF00FF;堅決買進:=IF(FILTER(VARB,6),65,0),COLORFF00FF,POINTDOT;VARF:=(2*CLOSE+HIGH+LOW)/4;VA4:=LLV(LOW,34);VA5:=HHV(HIGH,34);VA6:=EMA((VARF-VA4)/(VA5-VA4)*100,6);VA7:=EMA(0.667*REF(VA6,1)+0.333*VA6,4);出擊:=IF(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND REF(LOW,1)=LLV(LOW,120) ANDCLOSE>OPEN,1,0),1,0),coloryellow,POINTDOT;STICKLINE(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) ANDREF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),60,0,4,0),coloryellow;A:=(3*CLOSE+LOW+OPEN+HIGH)/6;D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/211;///www..comD2:=EMA(D1,2);D3:=EMA(D2,2);K1:=EMA(D3,2);多方趨勢:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1),2,1);天線:=78.89;STICKLINE(CROSS(天線,多方趨勢),95,100,10,0),COLOR00FF00;

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

    可聯系技術人員 QQ: 1145508240  點擊這里給我發消息進行 有償 編寫!不貴!點擊查看價格!

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>