• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 同花順>> 同花順公式>>正文內容

    逍遙神器 追高神器[同花順公式]

    相關標簽:

    原理解析:

    輸出追高神器:0,畫黃色
    A01賦值:現價
    A03賦值:收盤價的有效數據周期數
    A04賦值:((收盤價/120日內最高價的最高值)的3日[1日權重]移動平均 * 100)
    A05賦值:如果(A03>20),返回A04,否則返回0
    A06賦值:如果(最低價>A01),返回0,否則返回如果(最高價<A01),返回1,否則返回(((A01-最低價)+0.009)/((最高價-最低價)+0.009))
    A07賦值:以(成交量(手)/當前流通股本(手))為權重A06的動態移動平均 * 60
    A09賦值:如果(((A07>0)AND(A07>1日前的A07))AND(A05<=88)),返回A07,否則返回0
    VAR1賦值:3*(收盤價-27日內最低價的最低值)/(27日內最高價的最高值-27日內最低價的最低值)*100的5日[1日權重]移動平均-2*(收盤價-27日內最低價的最低值)/(27日內最高價的最高值-27日內最低價的最低值)*100的5日[1日權重]移動平均的3日[1日權重]移動平均
    VAR2賦值:VAR1的8日指數移動平均
    VAR3賦值:3*(收盤價-55日內最低價的最低值)/(55日內最高價的最高值-55日內最低價的最低值)*100的5日[1日權重]移動平均-2*(收盤價-55日內最低價的最低值)/(55日內最高價的最高值-55日內最低價的最低值)*100的5日[1日權重]移動平均的3日[1日權重]移動平均
    趨勢賦值:VAR3的3日指數移動平均-10
    VAR4賦值:(趨勢-1日前的趨勢)/1日前的趨勢*100
    VAR5賦值:(趨勢<=13ANDVAR4>13)的10日過濾
    VAR6賦值:(趨勢>=90ANDVAR4)的10日過濾
    VAR7賦值:30日內最低價的最低值
    VAR8賦值:30日內最高價的最高值
    VAR9賦值:(收盤價-VAR7)/(VAR8-VAR7)*4的4日指數移動平均*25
    VAR10賦值:(VAR9-4日內VAR9的最低值)/(4日內VAR9的最高值-4日內VAR9的最低值)*100
    VAR11賦值:最低價-1日前的最低價的絕對值的3日[1日權重]移動平均/最低價-1日前的最低價和0的較大值的3日[1日權重]移動平均*100
    VAR12賦值:30日內VAR11的最高值*8
    VAR13賦值:(收盤價的1日簡單移動平均+收盤價的3日簡單移動平均+收盤價的5日簡單移動平均+收盤價的7日簡單移動平均+收盤價的9日簡單移動平均)/5
    VAR14賦值:(收盤價的2日簡單移動平均+收盤價的4日簡單移動平均+收盤價的6日簡單移動平均+收盤價的8日簡單移動平均+收盤價的10日簡單移動平均)/5
    趨勢線賦值:趨勢,COLORFF0000
    VAR16賦值:VAR13的2日指數移動平均-VAR14的5日指數移動平均和0的較大值*200
    VAR17賦值:VAR16的5日指數移動平均
    輸出主力拉高:VAR17,STICK,COLORFF00FF
    當滿足條件VAR17<1日前的VAR17時,在0和VAR17位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,COLOR00FF00
    VAR18賦值:趨勢線的8日簡單移動平均
    ?

    源碼:

    追高神器:0,coloryellow;A01:=DYNAINFO(7);A03:=BARSCOUNT(CLOSE);A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);A05:=IF((A03 > 20),A04,0);A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));A07:=DMA(A06,(VOL / CAPITAL)) * 60;A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);Var1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);Var2:=EMA(Var1,8);Var3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);趨勢:=EMA(Var3,3)-10;Var4:=(趨勢-REF(趨勢,1))/REF(趨勢,1)*100;Var5:=FILTER((趨勢<=13 AND Var4>13),10);Var6:=FILTER((趨勢>=90 AND Var4),10);Var7:=LLV(LOW,30);Var8:=HHV(HIGH,30);Var9:=EMA((CLOSE-Var7)/(Var8-Var7)*4,4)*25;Var10:=(Var9-LLV(Var9,4))/(HHV(Var9,4)-LLV(Var9,4))*100;Var11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;Var12:=HHV(Var11,30)*8;Var13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;Var14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;趨勢線:=趨勢,colorff0000;Var16:=MAX(EMA(Var13,2)-EMA(Var14,5),0)*200;Var17:=EMA(Var16,5);主力拉高:Var17,STICK,colorff00ff;STICKLINE(Var17<REF(Var17,1),0,Var17,4,0),color00ff00;Var18:=MA(趨勢線,8);

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

    可聯系技術人員 QQ: 1145508240  點擊這里給我發消息進行 有償 編寫!不貴!點擊查看價格!

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>