• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

    多空雙量指標公式代碼源碼[大智慧公式]

    相關標簽:

    ?

    原理解析:

    VAR1賦值:(成交量(手) / (((最高價 - 最低價) * 2) - (收盤價-開盤價)的絕對值))
    買盤賦值:如果(收陽線),返回(VAR1*(最高價-最低價)),否則返回如果(收陰線),返回(VAR1*((最高價-開盤價)+(收盤價-最低價))),否則返回(成交量(手)/2)
    賣盤賦值:如果(收陽線),返回(0-(VAR1*((最高價-收盤價)+(開盤價-最低價)))),否則返回如果(收陰線),返回(0-(VAR1*(最高價-最低價))),否則返回(0-(成交量(手)/2))
    買賣差賦值:(買盤 + 賣盤)
    當滿足條件(買賣差<0)時,在0和買賣差位置之間畫柱狀線,寬度為5,0不為0則畫空心柱.,COLOR33FF33
    JX1賦值:首次買盤距今天數
    JY1賦值:如果((121>JX1)AND(JX1>0)),返回JX1,否則返回120
    JY2賦值:如果((4>JX1)AND(JX1>0)),返回JX1,否則返回3
    VAR30賦值:成交量(手)的JY2日簡單移動平均
    神比賦值:(買盤 / VAR30)
    鬼比賦值:(賣盤 / VAR30)
    VAR2賦值:(最高價 - 最低價)
    VAR3賦值:(開盤價-收盤價)的絕對值
    VAR4賦值:(最高價 - 如果(收陽線),返回收盤價,否則返回開盤價)
    VAR5賦值:(如果(收陽線),返回開盤價,否則返回收盤價 - 最低價)
    VAR6賦值:((VAR3 / VAR2) * 成交量(手))
    VAR7賦值:((VAR4 / VAR2) * 成交量(手))
    VAR8賦值:((VAR5 / VAR2) * 成交量(手))
    VAR9賦值:如果((成交量(手)/當前流通股本(手))>0.001),返回1,否則返回((成交量(手)/當前流通股本(手))*100)的對數的絕對值的指數
    VARA賦值:(((收盤價 - 收盤價的5日簡單移動平均) / 收盤價的5日簡單移動平均) * 100)
    VARB賦值:(((收盤價的5日簡單移動平均 > 收盤價的10日簡單移動平均) AND (收盤價的10日簡單移動平均 > 收盤價的30日簡單移動平均)) AND (收盤價的30日簡單移動平均 > 收盤價的60日簡單移動平均))
    VARC賦值:((收盤價的5日簡單移動平均 < 收盤價的10日簡單移動平均) AND (收盤價的10日簡單移動平均 < 收盤價的30日簡單移動平均))
    VARD賦值:1日前的收盤價
    VARE賦值:(((收盤價-VARD)和0的較大值的6日[1日權重]移動平均 / (收盤價-VARD)的絕對值的6日[1日權重]移動平均) * 100)
    當滿足條件((日期>700101)ANDCROSS(84,VARE))時,在最高價位置書寫文字,COLORF2A3A4
    VAR40賦值:((如果(((VAR6>=VAR7)AND(VAR6>=VAR8))AND(收陽線)),返回VAR6,否則返回買盤 + 買盤) / 2)
    VAR41賦值:((如果((VAR7>VAR6)AND(VAR7>VAR8)),返回VAR7,否則返回買盤 + 買盤) / 2)
    VAR42賦值:((如果((VAR8>VAR6)AND(VAR8>VAR7)),返回VAR8,否則返回買盤 + 買盤) / 2)
    VAR50賦值:((如果(((VAR6>=VAR7)AND(VAR6>=VAR8))AND(收陰線)),返回VAR6,否則返回賣盤 + 賣盤) / 2)
    三日上攻賦值:(((VAR40+VAR41)+VAR42)/3)的JY2日簡單移動平均
    三日下攻賦值:VAR50的JY2日簡單移動平均
    輸出多頭:當滿足條件(收盤價>收盤價的30日簡單移動平均)時,在0和成交量(手)位置之間畫柱狀線,寬度為5,1不為0則畫空心柱.,COLOR0000FF
    輸出空頭:當滿足條件(收盤價<收盤價的30日簡單移動平均)時,在0和成交量(手)位置之間畫柱狀線,寬度為5,1不為0則畫空心柱.,COLOR00FF00
    當滿足條件(((VAR6>=VAR7)AND(VAR6>=VAR8))AND(收陽線))時,在0和VAR6位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,COLOR00FFFF
    當滿足條件(((VAR6>=VAR7)AND(VAR6>=VAR8))AND(收陰線))時,在0和VAR6位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,COLORFF0000
    當滿足條件((VAR8>VAR6)AND(VAR8>VAR7))時,在0和VAR8位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,COLORFFFFFF
    當滿足條件((VAR7>VAR6)AND(VAR7>VAR8))時,在0和VAR7位置之間畫柱狀線,寬度為4,0不為0則畫空心柱.,COLORFF00FF
    當滿足條件(成交量(手)>(成交量(手)的5日簡單移動平均*2.5))時,在0和成交量(手)位置之間畫柱狀線,寬度為2,0不為0則畫空心柱.
    當滿足條件(買盤>0)時,在買盤和0位置之間畫柱狀線,寬度為2,0不為0則畫空心柱.,COLOR0000FF
    上攻均量賦值:買盤的JY1日簡單移動平均
    下攻均量賦值:賣盤的JY1日簡單移動平均
    當滿足條件((((((((VAR7>VAR6)AND(VARA>2))AND(VAR9>VAR8))AND(收盤價>收盤價的5日簡單移動平均))AND(收盤價>收盤價的30日簡單移動平均))AND(最高價>收盤價的60日簡單移動平均))AND(成交量(手)>成交量(手)的5日簡單移動平均))AND(VAR7>=成交量(手)的5日簡單移動平均))時,在成交量(手)位置書寫文字
    當滿足條件((((((VAR8>VAR6)AND(VAR8>VAR7))AND(VARA<(0-2)))AND(收盤價<收盤價的30日簡單移動平均))AND(VAR8<(成交量(手)的5日簡單移動平均/2)))AND(成交量(手)的5日簡單移動平均<成交量(手)的10日簡單移動平均))時,在成交量(手)位置書寫文字
    當滿足條件(((((VAR6>(成交量(手)的5日簡單移動平均*2))AND(VAR6>=VAR7))AND(VAR6>=VAR8))AND(收陽線))OR((成交量(手)>(成交量(手)的5日簡單移動平均*3))ANDVARB))時,在成交量(手)位置書寫文字
    HSL賦值:換手率
    當滿足條件(((成交量(手)/1日前的(成交量(手)的5日累和/5))>=2)AND(HSL>1))時,在(成交量(手)*1.1)位置書寫文字,COLOR00FFFF
    輸出MA1:成交量(手)的5日簡單移動平均,畫白色
    輸出均線:成交量(手)的35日簡單移動平均,畫黃色
    輸出MA3:成交量(手)的135日簡單移動平均,畫藍色
    ?

    源碼:

    ?

    {多空雙量}
    VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
    買盤:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
    賣盤:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));
    買賣差:=(買盤 + 賣盤);
    STICKLINE((買賣差 < 0),0,買賣差,5,0),COLOR33FF33;
    JX1:=BARSSINCE(買盤);
    JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
    JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);
    VAR30:=MA(VOL,JY2);
    神比:=(買盤 / VAR30);
    鬼比:=(賣盤 / VAR30);
    VAR2:=(HIGH - LOW);
    VAR3:=ABS((OPEN - CLOSE));
    VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
    VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
    VAR6:=((VAR3 / VAR2) * VOL);
    VAR7:=((VAR4 / VAR2) * VOL);
    VAR8:=((VAR5 / VAR2) * VOL);
    VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
    VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
    VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60))); VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
    VARD:=REF(CLOSE,1);
    VARE:=((SMA(MAX((CLOSE - VARD),0),6,1) / SMA(ABS((CLOSE - VARD)),6,1)) * 100);
    DRAWTEXT(((DATE > 700101) AND CROSS(84,VARE)),HIGH,'■賣出'),COLORF2A3A4;
    VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,買盤) + 買盤) / 2);
    VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,買盤) + 買盤) / 2);
    VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,買盤) + 買盤) / 2);
    VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,賣盤) + 賣盤) / 2);
    三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);
    三日下攻:=MA(VAR50,JY2);
    多頭:STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,5,1),COLOR0000FF;
    空頭:STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,5,1),COLOR00FF00;STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),0,VAR6,4,0),COLOR00FFFF;
    STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),0,VAR6,4,0),COLORFF0000;
    STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,4,0),COLORFFFFFF;
    STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,4,0),COLORFF00FF;
    STICKLINE((VOL > (MA(VOL,5) * 2.5)),0,VOL,2,0);
    STICKLINE((買盤 > 0),買盤,0,2,0),COLOR0000FF;
    上攻均量:=MA(買盤,JY1);
    下攻均量:=MA(賣盤,JY1);
    DRAWTEXT(((((((((VAR7 > VAR6) AND (VARA > 2)) AND (VAR9 > VAR8)) AND (CLOSE > MA(CLOSE,5))) AND (CLOSE > MA(CLOSE,30))) AND (HIGH > MA(CLOSE,60))) AND (VOL > MA(VOL,5))) AND (VAR7 >= MA(VOL,5))),VOL,'▼出貨');
    DRAWTEXT(((((((VAR8 > VAR6) AND (VAR8 > VAR7)) AND (VARA < (0 - 2))) AND (CLOSE < MA(CLOSE,30))) AND (VAR8 < (MA(VOL,5) / 2))) AND (MA(VOL,5) < MA(VOL,10))),VOL,'●低進');
    DRAWTEXT((((((VAR6 > (MA(VOL,5) * 2)) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB)),VOL,'◆強勢');
    HSL:=DYNAINFO(37);
    DRAWTEXT((((VOL / REF((SUM(VOL,5) / 5),1)) >= 2) AND (HSL > 1)),(VOL * 1.1),'●量變'),COLOR00FFFF;
    MA1:MA(VOL,5),COLORWHITE;
    MA2:MA(VOL,35),COLORYELLOW;{http://cxh99.com}
    MA3:MA(VOL,135),COLORBLUE;

    {程序化交易 www.planetbokep.com }

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

    怎么收費,代編流程等詳情請點擊查閱!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>