• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 期貨公式>> 金字塔等>> 金字塔知識>>正文內容

    [求助]文華自定義指標轉換 [金字塔]

    • 咨詢內容: 文華上的自定義指標復制過來不顯示,幫我看看怎么轉換: 指標定義:取 k線高點比前后n根k線最高點高則在最高點畫紅線;取k線低點比前后n跟k線最低點低則在最低點畫綠線;紅綠線只標注近滿足條件的一次文華上的代碼為如下:HH3:=REF(H>=HV(H,N),N)&&REF(H,N)>HHV(H,N);LL3:=REF(L<=LV(L,N),N)&&REF(L,N)<LLV(L,N);
      DRAWSL(ISLASTBAR,VALUEWHEN(HH3,REF(H,N)),0,-BARSLAST(HH3)-N,0,COLORMAGENTA);DRAWSL(ISLASTBAR,VALUEWHEN(LL3,REF(L,N)),0,-BARSLAST(LL3)-N,0,COLORGREEN);
      HA:=VALUEWHEN(HH3,REF(H,N));LA:=VALUEWHEN(LL3,REF(L,N));

      ?

    • 金字塔客服: ?N:=5;
      Len:DATACOUNT-BARPOS;
      cd1:h>ref(hhv(h,n),1);
      cd2:h>refx(hhv(h,n),if(len<n-1,len,n));
      cdh:cd1 and cd2;//當前最高價大于前后N周期的最高價

      DRAWICON(cdh,h,1);
      cd3:l<ref(llv(l,n),1);
      cd4:l<refx(llv(l,n),if(len<n-1,len,n));
      cdl:cd3 and cd4;//當前最低價小于前后N周期的最低價
      DRAWICON(cdl,l,2);
      參考上面這個 ,需要注意的是必須使用序列模式。否則不行的。繪制圖形還是線,你可以自行嘗試改下。核心的判斷上面已經完成了。

      ?

      ?來源:程序化久久網( www.planetbokep.com )

    • 用戶回復: 你好,你這個版本用到未來函數,是不是不能引用作為交易條件了?還有我想要的高低點是顯示最后一次滿足條件的平行橫線這個在你的畫線函數沒找到,我在文華上的圖像顯示如附件
      此主題相關圖片如下:r@2(ebh}fkbt7%h(cz5vjyd.png


      ?

    • 網友回復: 老師拜托了,能不能不用未來函數,根據我文華現有的這表源碼改過來呢,因為我在后面程序化條件會用到個參數

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信號:cxh99cxh99  進行 有償收費 編寫!

    怎么收費,代編流程等詳情請點擊閱讀!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
    人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>