• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

    超級量能 副圖指標公式指標公式[大智慧公式]

    相關標簽: 量能飽和度指標公式 、 量化買盤副圖指標源碼 、 量能飽和度副圖指標 、 通達信量能飽和指標公式 、 通達信量能飽和度指標公式 、 麟龍量能飽和指標公式 、 量能飽和度指標用法 、 量能飽和度主圖指標 、 量能飽和度指標選股器 、 股票量能飽和度指標 、 量能飽和度指標圓圈 、 超級大單買賣指標公式 、

    ?

    公式內有未來函數,大家小心使用

    原理解析:

    輸出INPUT:N(20,1,100)
    SAT賦值:(成交額(元)/收盤價)/(N日內成交額(元)的最高值/N日內收盤價的最高值)
    輸出飽和度:如果SAT>1,返回1,否則返回SAT*100,COLOR9368FF,PRECIS0,線寬為0
    當滿足條件收盤價>0ANDBARSTATUS=2時,在5和100位置之間畫柱狀線,寬度為10,1不為0則畫空心柱.,畫白色
    輸出起點量能≤5:當滿足條件飽和度<=5ANDBARSTATUS=2時,在5和飽和度+20位置之間畫柱狀線,寬度為6,0不為0則畫空心柱.,畫紅色
    輸出溫和量5~80:當滿足條件(飽和度>5AND飽和度<80)ANDBARSTATUS=2時,在5和飽和度+8位置之間畫柱狀線,寬度為6,0不為0則畫空心柱.,COLOR5290FF
    輸出警量80~97:當滿足條件(飽和度>80AND飽和度<97)ANDBARSTATUS=2時,在5和飽和度位置之間畫柱狀線,寬度為6,0不為0則畫空心柱.,COLORFFCC00
    輸出放量≥97:當滿足條件飽和度>=97ANDBARSTATUS=2時,在5和飽和度位置之間畫柱狀線,寬度為8,0不為0則畫空心柱.,畫綠色
    條件判斷 數據位置狀態=2 AND(飽和度) THEN BEGIN DRAWTEXTABS(550,60,'■量能飽和度:'+NUMTOSTRN(飽和度,0)+'%'),COLOR9368FF
    END
    K賦值:(日期 < 1341230)
    XD1賦值:大盤的開盤價
    XD2賦值:大盤的最高價
    XD3賦值:大盤的最低價
    XD4賦值:大盤的收盤價
    對應指數開盤賦值:大盤的開盤價
    盤中最高點位賦值:大盤的最高價
    盤中最低點位賦值:大盤的最低價
    收盤點位賦值:大盤的收盤價
    大盤資金增減賦值:(100 * ((大盤的成交量 / 1日前的大盤的成交量) - 1))
    大盤上漲家數賦值:大盤的上漲家數
    平盤家數賦值:DYNAINFO(68)
    大盤下跌家數賦值:大盤的下跌家數
    昨收盤賦值:前收盤價
    今開盤賦值:開盤價
    漲幅賦值:漲幅*100
    JJ賦值:(((XD4 + XD2) + XD3) / 3)
    A賦值:JJ的10日指數移動平均
    B賦值:1日前的A
    買賣決策賦值:B
    DRAWTEXTABS(20,10,'【大盤盤口動態觀察】'),COLOR00FFFF
    輸出DRAWTEXTABS(20,25,'對應個股開盤:'+對應指數開盤+'點'),COLOR00FFFF
    輸出DRAWTEXTABS(20,40,'盤中最高點位:'+盤中最高點位+'點'),COLOR00FFFF
    輸出DRAWTEXTABS(20,55,'盤中最低點位:'+盤中最低點位+'點'),COLOR00FFFF
    輸出DRAWTEXTABS(20,70,'■大盤資金增減:'+NUMTOSTRN(大盤資金增減,0)+'%'),COLOR00FF00
    輸出DRAWTEXTABS(20,85,'大盤今日上漲:'+大盤上漲家數+'家'),COLOR00FFFF
    輸出DRAWTEXTABS(20,100,'大盤今日平盤:'+平盤家數+'家'),COLOR00FFFF
    輸出DRAWTEXTABS(20,115,'大盤今日下跌:'+NUMTOSTRN(大盤下跌家數,0)+'家'),COLOR00FFFF
    買入委托成交賦值:ORDER(1)
    賣出委托成交賦值:ORDER(2)
    當日成交總量賦值:總量
    成交總金額賦值:總金額/10000
    主動賣盤賦值:內盤
    主動買盤賦值:外盤
    成交筆數賦值:TICKCOUNT
    每筆手數賦值:應計利息/昨凈值
    DRAWTEXTABS(20,130,'【個股盤口成交量觀察】'),COLORD3A9FF
    輸出DRAWTEXTABS(20,145,'日成交總量:'+NUMTOSTRN(當日成交總量,0)+'手'),COLORD3A9FF
    輸出DRAWTEXTABS(20,160,'日主動買入量:'+NUMTOSTRN(主動買盤,0)+'手'),COLORD3A9FF
    輸出DRAWTEXTABS(20,175,'日主動賣出量:'+NUMTOSTRN(主動賣盤,0)+'手'),COLORD3A9FF
    輸出DRAWTEXTABS(20,190,'■當前成交概況:'+NUMTOSTRN(成交筆數,0)+'筆'),COLOR00FF00
    輸出DRAWTEXTABS(20,205,'每筆成交:'+NUMTOSTRN(每筆手數,1)+'手'),COLORD3A9FF
    輸出DRAWTEXTABS(20,220,'買入下單委托成交:'+NUMTOSTRN(買入委托成交,0)+'單'),COLORD3A9FF
    輸出DRAWTEXTABS(20,235,'賣出下單委托成交:'+NUMTOSTRN(賣出委托成交,0)+'單'),COLORD3A9FF
    N1賦值:上次收盤價上穿收盤價的60日簡單移動平均距今天數
    ?

    源碼:

    ?

    {超級量能}INPUT:N(20,1,100);
    SAT:=(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N));
    飽和度:IF(SAT>1,1,SAT)*100,Color9368FF,PRECIS0,LINETHICK0;{http://www.planetbokep.com}
    STICKLINE(C>0 AND BARSTATUS=2,5,100,10,1),COLORWHITE;
    起點量能≤5:STICKLINE(飽和度<=5 AND BARSTATUS=2,5,飽和度+20,6,0),COLORRED;
    溫和量5~80:STICKLINE((飽和度>5 AND 飽和度< 80) AND BARSTATUS=2,5,飽和度+8,6,0),COLOR5290FF;
    警量80~97:STICKLINE((飽和度>80 AND 飽和度< 97) AND BARSTATUS=2,5,飽和度,6,0),COLORFFCC00;
    放量≥97:STICKLINE(飽和度>=97 AND BARSTATUS=2,5,飽和度,8,0),COLORGREEN;{http://www.planetbokep.com}
    IF BARSTATUS=2 AND(飽和度) THEN BEGIN DRAWTEXTABS(550,60,'■量能飽和度:'+NUMTOSTRN(飽和度,0)+'%'),Color9368FF;END;
    K:=(DATE < 1341230);
    XD1:=INDEXO;
    XD2:=INDEXH;
    XD3:=INDEXL;
    XD4:=INDEXC;
    對應指數開盤:=INDEXO;
    盤中最高點位:=INDEXH;
    盤中最低點位:=INDEXL;
    收盤點位:=INDEXC;
    大盤資金增減:=(100 * ((INDEXV / REF(INDEXV,1)) - 1));
    大盤上漲家數:=INDEXADV;
    平盤家數:=DYNAINFO(68);
    大盤下跌家數:=INDEXDEC;
    昨收盤:=DYNAINFO(3);
    今開盤:=DYNAINFO(4);
    漲幅:=DYNAINFO(14)*100;
    JJ:=(((XD4 + XD2) + XD3) / 3);
    A:=EMA(JJ,10);
    B:=REF(A,1);
    買賣決策:=B;
    DRAWTEXTABS(20,10,'【大盤盤口動態觀察】'),Color00FFFF;
    DRAWTEXTABS(20,25,'對應個股開盤:'+對應指數開盤+'點'),Color00FFFF;
    DRAWTEXTABS(20,40,'盤中最高點位:'+盤中最高點位+'點'),Color00FFFF;
    DRAWTEXTABS(20,55,'盤中最低點位:'+盤中最低點位+'點'),Color00FFFF;
    DRAWTEXTABS(20,70,'■大盤資金增減:'+NUMTOSTRN(大盤資金增減,0)+'%'),Color00FF00;
    DRAWTEXTABS(20,85,'大盤今日上漲:'+大盤上漲家數+'家'),Color00FFFF;
    DRAWTEXTABS(20,100,'大盤今日平盤:'+平盤家數+'家'),Color00FFFF;
    DRAWTEXTABS(20,115,'大盤今日下跌:'+NUMTOSTRN(大盤下跌家數,0)+'家'),Color00FFFF;
    買入委托成交:=ORDER(1);
    賣出委托成交:=ORDER(2);
    當日成交總量:=DYNAINFO(8);
    成交總金額:=DYNAINFO(10)/10000;
    主動賣盤:=DYNAINFO(22);
    主動買盤:=DYNAINFO(23);
    成交筆數:=TICKCOUNT;
    每筆手數:=DYNAINFO(53);
    DRAWTEXTABS(20,130,'【個股盤口成交量觀察】'),ColorD3A9FF;
    DRAWTEXTABS(20,145,'日成交總量:'+NUMTOSTRN(當日成交總量,0)+'手'),ColorD3A9FF;
    DRAWTEXTABS(20,160,'日主動買入量:'+NUMTOSTRN(主動買盤,0)+'手'),ColorD3A9FF;
    DRAWTEXTABS(20,175,'日主動賣出量:'+NUMTOSTRN(主動賣盤,0)+'手'),ColorD3A9FF;
    DRAWTEXTABS(20,190,'■當前成交概況:'+NUMTOSTRN(成交筆數,0)+'筆'),Color00FF00;
    DRAWTEXTABS(20,205,'每筆成交:'+NUMTOSTRN(每筆手數,1)+'手'),ColorD3A9FF;
    DRAWTEXTABS(20,220,'買入下單委托成交:'+NUMTOSTRN(買入委托成交,0)+'單'),ColorD3A9FF;
    DRAWTEXTABS(20,235,'賣出下單委托成交:'+NUMTOSTRN(賣出委托成交,0)+'單'),ColorD3A9FF;
    {換手率--成交量--委賣委買量:綜合分析}
    n1:=barslast(cross(c,MA(c,60)));
    n2:=barslast(cross(MA(c,60),c));
    強勢股排序:if(n1<n2,n1+1,0),PRECIS0,Color00FFFF,LINETHICK0;{http://www.planetbokep.com}
    日換手率:=DYNAINFO(37)*100;
    5日換手率:sum(100*v/capital,5),ColorFFFFFF,PRECIS0,LINETHICK0;{http://www.planetbokep.com}
    5日均量:DYNAINFO(38),ColorFFFFFF,PRECIS0,LINETHICK0;{http://www.planetbokep.com}
    大單20萬買入:DYNAINFO(94)*100,ColorFFFFFF,PRECIS0,LINETHICK0;{http://www.planetbokep.com}
    大單20萬賣出:=DYNAINFO(97)*100;
    50萬大單買入:BIGORDER(1,3)*100,ColorFFFFFF,PRECIS0,LINETHICK0;{http://www.planetbokep.com}
    賣出50萬委托單:=BIGORDER(2,3)*100;
    建倉成本:=MAXCYC;
    壓力位:=DMA(AMOUNT/(100*VOL),VOL/(100*FINANCE2(37)))*1.12;
    avgbpx:=DYNAINFO(87);
    avgopx:=DYNAINFO(88);
    tbqty:=DYNAINFO(89);
    toqty:=DYNAINFO(90);
    bq:=DYNAINFO(89)/capital;
    oq:=DYNAINFO(90)/capital;
    bm:=tbqty/((DYNAINFO(7)-avgbpx)*2/DYNAINFO(7)*100);
    om:=toqty/((avgopx-DYNAINFO(7))*2/DYNAINFO(7)*100);
    bd:=(DYNAINFO(7)-avgbpx)/(avgopx-avgbpx)*120;
    od:=(avgopx-DYNAINFO(7))/(avgopx-avgbpx)*120;
    gy:=max(bm,om);DRAWTEXTABS(200,10,'【換手率--成交量--委賣委買量:綜合分析】'),ColorFFFF00;
    DRAWTEXTABS(200,25,'委賣→總量:'+str(toqty)+' 占流通盤比例:'+str(oq*100)+'%'+' 密度:'+str(INTPART(om))+'手 價寬:'+str(max(0,avgopx*2-DYNAINFO(7)*2))+'元 '+str(max(0,avgopx/DYNAINFO(7)*200-200))+'%'),ColorFFFF00,layer0;
    DRAWTEXTABS(200,40,'委買→總量:'+str(tbqty)+' 占流通盤比例:'+str(bq*100)+'%'+' 密度:'+str(INTPART(bm))+'手 價寬:'+str(if(avgbpx=0,0,DYNAINFO(7)*2-avgbpx*2))+'元 '+str(max(0,DYNAINFO(7)/avgbpx*200-200))+'%'),ColorFFFF00,layer0;
    DRAWTEXTABS(200,55,'委賣委買比:'+str((tbqty-toqty)/(tbqty+toqty)*100)+'%→'),layer0,Color0000FF;
    DRAWTEXTABS(200,85,'■個股對應大盤買賣決策點位:'+NUMTOSTRN(買賣決策,2)+'點'),Color00FF00;
    DRAWTEXTABS(200,155,'日換手率:'+NUMTOSTRN(日換手率,1)+'%'),ColorFFFF00;
    DRAWTEXTABS(200,110,'日成交總金額:'+NUMTOSTRN(成交總金額,0)+'萬元'),ColorFFFF00;
    DRAWTEXTABS(200,125,'20萬大單買入:'+NUMTOSTRN(大單20萬買入,0)+'%'),ColorFFFF00;
    DRAWTEXTABS(200,140,'20萬大單賣出:'+NUMTOSTRN(大單20萬賣出,0)+'%'),ColorFFFF00;
    DRAWTEXTABS(495,100,'50萬大單買入:'+NUMTOSTRN(50萬大單買入,0)+'%'),ColorFFFF00;
    DRAWTEXTABS(580,100,'50萬大單賣出:'+NUMTOSTRN(賣出50萬委托單,0)+'%'),ColorFFFF00;
    DRAWTEXTABS(390,155,'5日換手率:'+NUMTOSTRN(5日換手率,1)+'%'),ColorFFFF00;
    DRAWTEXTABS(200,170,'5日均量:'+NUMTOSTRN(5日均量,0)+'手'),ColorFFFF00;
    DRAWTEXTABS(390,170,'平均成本:'+NUMTOSTRN(建倉成本,2)+'元'),ColorFFFF00;
    DRAWTEXTABS(550,40,STKLABEL+' '+STKNAME),Color80FFFF,LINETHICK2;
    DRAWTEXTABS(550,80,'■股價上穿60均線:'+NUMTOSTRN(強勢股排序,0)+'天'),Color00FF00,LINETHICK1;
    DRAWTEXTABS(550,100,'■心理成本壓力位:'+NUMTOSTRN(壓力位,2)+'元'),Color00FFFF,LINETHICK1;
    DRAWTEXTABS(200,70,'昨收盤:'+NUMTOSTRN(昨收盤,2)+'元'),ColorFFFF00;
    DRAWTEXTABS(300,70,'今開盤:'+NUMTOSTRN(今開盤,2)+'元'),ColorFFFF00;
    DRAWTEXTABS(400,70,'漲跌幅度:'+NUMTOSTRN(漲幅,2)+'%'),ColorFFFF00;<!--++ plugin_code qcomic end-->

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

    怎么收費,代編流程等詳情請點擊查閱!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>