• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

    多空珍貴副圖指標公式[大智慧公式]

    相關標簽: 活躍度指標公式副圖 、 通達信副圖太準了指標公式 、 買點確認副圖指標公式 、 量柱3121副圖指標公式 、 黃藍帶副圖公式源碼 、 通達信黃藍帶指標公式 、 黃藍帶金盾指標公式 、 黃藍帶最好的公式指標 、 三劍合一選股公式 、 通達信三劍合一指標 、 黃藍帶三劍合一公式 、 黃藍帶三劍合一指標 、

    原理解析:

    N3賦值:4
    N4賦值:6
    輸出快:統計N3日中滿足收盤價>2日前的收盤價的天數/N3*100,畫綠色
    輸出慢:統計N4日中滿足收盤價>2日前的收盤價的天數/N4*100,畫紅色
    輸出買入: 如果1日前的慢=慢ANDREF(快,1)>快AND快=0,返回100,否則返回0,畫紅色,線寬為1
    當滿足條件買入ANDREF(買入,1)=0時,在100位置書寫文字
    輸出關注: 如果慢=0AND快=0,返回60,否則返回0,畫紅色,線寬為1
    當滿足條件關注ANDREF(關注,1)=0時,在60位置書寫文字,畫紅色
    0,畫深灰色
    100
    VAR1賦值:"DMI的PDI"(10,6)
    VAR2賦值:"DMI的MDI"(10,6)
    VAR3賦值:VAR1>65 AND VAR1>1日前的VAR1
    VAR4賦值:0日內VAR1的最低值
    VAR5賦值:上次VAR4=VAR1距今天數
    VAR6賦值:(0-4日前的VAR2)/(VAR4-VAR5日前的VAR2)>2
    VAR7賦值:VAR1>1日前的VAR1
    VAR8賦值:成交量(手)>2*成交量(手)的30日簡單移動平均
    VAR9賦值:"DMI的ADX"(10,6)
    VARA賦值:"DMI的ADXR"(10,6)
    VARB賦值:收盤價>收盤價的30日簡單移動平均 AND 收盤價<收盤價的30日簡單移動平均*1.04
    VARC賦值:收盤價的30日簡單移動平均>1日前的收盤價的30日簡單移動平均
    VARD賦值:上次收盤價的5日簡單移動平均上穿收盤價的10日簡單移動平均距今天數<上次收盤價的10日簡單移動平均上穿收盤價的5日簡單移動平均距今天數
    VARE賦值:0-"平滑異同平均的DIFF"(7,21,3)
    VARF賦值:收盤價15%之字轉向的前1個波谷位置<4
    VAR10賦值:收盤價的30日指數移動平均>2日前的收盤價的30日指數移動平均
    VAR11賦值:如果VARF=1,返回50,否則返回0
    VAR12賦值:VAR2上穿VAR1 AND VARA上穿VAR9
    VAR13賦值:VAR2上穿VAR1 AND VAR9上穿VARA
    VAR14賦值:VARB AND VARC AND VARD AND VAR10 AND VAR6 AND VAR7 AND VAR8*50
    VAR15賦值:上次VAR2上穿VAR1=1距今天數
    VAR16賦值:上次VAR1上穿VAR2=1距今天數
    VAR17賦值:VAR16日內VAR1的最高值
    VAR18賦值:上次VAR1=VAR17距今天數
    輸出多空:(收盤價-(2*收盤價+最高價+最低價)/4的30日簡單移動平均)/(2*收盤價+最高價+最低價)/4的30日簡單移動平均*100的3日指數移動平均,畫白色
    0,畫紅色
    當滿足條件VARF=1的5日過濾AND多空<-10時,在50和0位置之間畫柱狀線,寬度為15,0不為0則畫空心柱.,COLORF00FF0
    當滿足條件VARF=1的5日過濾時,在50和0位置之間畫柱狀線,寬度為8,0不為0則畫空心柱.,畫黃色
    VAR19賦值:VAR3 OR VAR12 OR VAR13*100
    VAR1A賦值:VAR13*100
    當滿足條件VARF=1的3日過濾時,在25位置書寫文字,畫紅色?
    當滿足條件多空<-10時,在0和多空位置之間畫柱狀線,寬度為0.85,0不為0則畫空心柱.,畫黃色
    當滿足條件多空>10時,在0和多空位置之間畫柱狀線,寬度為0.95,0不為0則畫空心柱.,畫紅色
    ?

    源碼:

    {珍貴副圖-值得你珍藏一生}
    N3:=4;N4:=6;
    快:COUNT(CLOSE>REF(CLOSE,2),N3)/N3*100,COLORGREEN;{http://www.planetbokep.com}
    慢:COUNT(CLOSE>REF(CLOSE,2),N4)/N4*100,COLORRED;
    買入: IF(REF(慢,1)=慢 and REF(快,1)>快 and 快=0,100,0),COLORRED,linethick1;
    DRAWTEXT( 買入 AND REF(買入 ,1)=0,100,'明');
    關注: IF(慢=0 and 快=0,60,0),COLORRED,linethick1;
    DRAWTEXT( 關注 AND REF(關注 ,1)=0,60,'關注'),COLORRED;
    0,COLORGRAY;
    100;
    VAR1:="DMI.PDI"(10,6);
    VAR2:="DMI.MDI"(10,6);
    VAR3:=VAR1>65 AND VAR1>REF(VAR1,1);
    VAR4:=LLV(VAR1,0);
    VAR5:=BARSLAST(VAR4=VAR1);
    VAR6:=(0-REF(VAR2,4))/(VAR4-REF(VAR2,VAR5))>2;
    VAR7:=VAR1>REF(VAR1,1);
    VAR8:=VOL>2*MA(VOL,30);
    VAR9:="DMI.ADX"(10,6);
    VARA:="DMI.ADXR"(10,6);
    VARB:=CLOSE>MA(CLOSE,30) AND CLOSE<MA(CLOSE,30)*1.04;
    VARC:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);
    VARD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))<BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5)));
    VARE:=0-"MACD.DIFF"(7,21,3);
    VARF:=TROUGHBARS(3,15,1)<4;
    VAR10:=EMA(CLOSE,30)>REF(EMA(CLOSE,30),2);
    VAR11:=IF(VARF=1,50,0);
    VAR12:=CROSS(VAR2,VAR1) AND CROSS(VARA,VAR9);
    VAR13:=CROSS(VAR2,VAR1) AND CROSS(VAR9,VARA);
    VAR14:=VARB AND VARC AND VARD AND VAR10 AND VAR6 AND VAR7 AND VAR8*50;
    VAR15:=BARSLAST(CROSS(VAR2,VAR1)=1);
    VAR16:=BARSLAST(CROSS(VAR1,VAR2)=1);
    VAR17:=HHV(VAR1,VAR16);
    VAR18:=BARSLAST(VAR1=VAR17);
    多空:EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),COLORWHITE;
    0,COLORRED;
    STICKLINE(FILTER(VARF=1,5) AND 多空<-10,50,0,15,0),colorf00ff0;
    STICKLINE(FILTER(VARF=1,5),50,0,8,0),COLORYELLOW;{http://cxh99.com}
    VAR19:=VAR3 OR VAR12 OR VAR13*100;
    VAR1A:=VAR13*100;
    DRAWTEXT(FILTER(VARF=1,3),25,'大量買入'),COLORRED ;
    STICKLINE(多空<-10,0,多空,0.85,0),COLORYELLOW;{http://cxh99.com}
    STICKLINE(多空>10,0,多空,0.95,0),COLORRED;

    {程序化交易 www.planetbokep.com }

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

    怎么收費,代編流程等詳情請點擊查閱!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>