• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

    DZH副圖指標公式代碼源碼[大智慧公式]

    相關標簽: 主圖指標與副圖指標 、 通達信副圖太準了指標公式 、 通達信主圖指標公式 、 最準幅圖買入指標公式 、 分時主圖買賣指標公式 、 最牛主力啟動副圖指標 、 買點確認副圖指標源碼 、 四大財富指標公式 、 通達信最貴的指標公式 、 通達信最牛副圖指標 、 通達信副圖公式源碼大全 、 通達信買點確認副圖指標 、

    ?

    DZH副圖


    {程序化交易 www.planetbokep.com }

    原理解析:

    輸出INPUT:N(9),M1(3),M2(3)
    RSV賦值:(收盤價-N日內最低價的最低值)/(N日內最高價的最高值-N日內最低價的最低值)*100
    輸出K:RSV的M1日[1日權重]移動平均,畫白色
    輸出D:K的M2日[1日權重]移動平均,畫黃色
    輸出J:3*K-2*D,COLORFF00FF
    RSW賦值:(收盤價-19日內最低價的最低值)/(19日內最高價的最高值-19日內最低價的最低值)*100
    KW賦值:RSW的4日[1日權重]移動平均
    DW賦值:KW的4日[1日權重]移動平均
    輸出JW:3*KW-2*DW,COLOR008F00,線寬為3
    當滿足條件JW上穿KWANDKW<45時,在JW位置書寫文字,畫紅色,線寬為2
    當滿足條件KW上穿JWANDKW>55時,在JW位置書寫文字,畫綠色,線寬為2
    RSM賦值:(收盤價-40日內最低價的最低值)/(40日內最高價的最高值-40日內最低價的最低值)*100
    KM賦值:RSM的5日[1日權重]移動平均
    DM賦值:KM的5日[1日權重]移動平均
    RSJ賦值:(收盤價-60日內最低價的最低值)/(60日內最高價的最高值-60日內最低價的最低值)*100
    KJ賦值:RSJ的6日[1日權重]移動平均
    DJ賦值:KJ的6日[1日權重]移動平均
    賦值: 最高價-最低價和最高價-1日前的收盤價的絕對值的較大值和最低價-1日前的收盤價的絕對值的較大值的14日累和
    賦值: 最高價-1日前的最高價
    賦值: 1日前的最低價-最低價
    DMP賦值: 如果HD>0ANDHD>LD,返回HD,否則返回0的14日累和
    DMM賦值: 如果LD>0ANDLD>HD,返回LD,否則返回0的14日累和
    PDI賦值:DMP*100/真實波幅
    MDI賦值:DMM*100/真實波幅
    輸出ADX: MDI-PDI的絕對值/(MDI+PDI)*100的6日簡單移動平均,畫紅色,線寬為2
    賦值: (最高價 + 最低價 + 收盤價)/3
    CCI賦值:(TYP-TYP的14日簡單移動平均)/(0.015*TYP的14日平均絕對偏差)
    買點0賦值:J+JW<68 AND J>1日前的J AND JW>1日前的JW AND ADX>28 AND CCI>1日前的CCI AND (CCI<-90 OR CCI>90) AND 收盤價>1日前的收盤價
    買點1賦值:J>1日前的J AND CCI>1日前的CCI AND 收盤價>1日前的收盤價 AND (1日前的J<5 OR 1日前的CCI<-180)
    輸出買點:買點0 OR 買點1
    DIBU賦值:K<20 AND D<20 AND KW<20 AND DW<20
    當滿足條件DIBU=1時,在100和80位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,畫紅色
    DIBU0賦值: KM<20 AND DM<20 AND KJ<20 AND DJ<20
    當滿足條件DIBU0=1時,在100和90位置之間畫柱狀線,寬度為4,1不為0則畫空心柱.,COLOR00008F
    TOBU賦值:K>80 AND D>80 AND KW>80 AND DW>80
    當滿足條件TOBU=1時,在20和0位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,畫綠色
    TOBU0賦值:KM>80 AND DM>80 AND KJ>80 AND DJ>80
    當滿足條件TOBU0=1時,在10和0位置之間畫柱狀線,寬度為4,1不為0則畫空心柱.,COLOR008F00
    輸出——:60,畫白色,DOTLINE
    0,畫紅色,DOTLINE
    100,畫綠色,DOTLINE
    PARTLINE(J,J<5 AND J>1日前的J,自定色,(J<5 AND J<1日前的J) OR (J>95 AND J>1日前的J),自定色,J>95 AND J<1日前的J,自定色),線寬為2
    PARTLINE(JW,JW<5 AND JW>1日前的JW,自定色,(JW<5 AND JW<1日前的JW) OR (JW>95 AND JW>1日前的JW),自定色,JW>5 AND JW<95 AND J>1日前的J AND JW>1日前的JW,自定色),線寬為3
    PARTLINE(ADX,ADX>1日前的ADX AND ADX>25 AND MDI>PDI,自定色,ADX<1日前的ADX AND ADX>25 AND MDI<PDI,自定色,ADX<25,自定色),線寬為2
    當滿足條件MDI>1日前的MDIANDMDI>25ANDCCI<-90ANDADX>1日前的ADXANDC>開盤價的3日過濾時,在ADX*1.0位置畫12號圖標
    當滿足條件買點的2日過濾時,在J+0和J+5位置之間畫柱狀線,寬度為6,0不為0則畫空心柱.,COLOR0000FF
    當滿足條件買點的2日過濾時,在J+5和J+10位置之間畫柱狀線,寬度為3,0不為0則畫空心柱.,畫白色
    當滿足條件買點的2日過濾時,在J+10和J+15位置之間畫柱狀線,寬度為1,0不為0則畫空心柱.,畫黃色
    ?

    源碼:

    ?


    input:N(9),M1(3),M2(3);

    RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
    K:SMA(RSV,M1,1),colorwhite;
    D:SMA(K,M2,1),COLORYELLOW;{http://cxh99.com}
    J:3*K-2*D,colorff00ff;

    RSw:=(CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100;
    Kw:=SMA(RSw,4,1);
    Dw:=SMA(Kw,4,1);
    Jw:3*Kw-2*Dw,color008f00,linethick3;

    DRAWTEXT(cross(jw,kw) and kw<45,jw,'周'),colorred,linethick2;
    DRAWTEXT(cross(kw,jw) and kw>55,jw,'周'),colorgreen,linethick2;

    RSm:=(CLOSE-LLV(LOW,40))/(HHV(HIGH,40)-LLV(LOW,40))*100;
    Km:=SMA(RSm,5,1);
    Dm:=SMA(Km,5,1);

    RSj:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
    Kj:=SMA(RSj,6,1);
    Dj:=SMA(Kj,6,1);

    TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);
    HD := HIGH-REF(HIGH,1);
    LD := REF(LOW,1)-LOW;
    DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),14);
    DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);
    {TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),7);
    HD := HIGH-REF(HIGH,1);
    LD := REF(LOW,1)-LOW;
    DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),7);
    DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),7);}
    PDI:=DMP*100/TR;
    MDI:=DMM*100/TR;
    ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,6),colorred,linethick2;

    TYP := (HIGH + LOW + CLOSE)/3;
    cci:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

    買點0:=j+jw<68 and j>ref(j,1) and jw>ref(jw,1) and adx>28 and cci>ref(cci,1) and (cci<-90 or cci>90) and c>ref(c,1);
    買點1:=j>ref(j,1) and cci>ref(cci,1) and c>ref(c,1) and (ref(j,1)<5 or ref(cci,1)<-180);

    買點:買點0 or 買點1;

    DIBU:=K<20 AND D<20 AND Kw<20 AND Dw<20;
    STICKLINE(DIBU=1,100,80,1,0),COLORRED;
    DIBU0:= Km<20 AND Dm<20 AND Kj<20 AND Dj<20;
    STICKLINE(DIBU0=1,100,90,4,1),COLOR00008f;
    TOBU:=K>80 AND D>80 AND Kw>80 AND Dw>80;
    STICKLINE(TOBU=1,20,0,1,0),COLORGREEN;{http://www.planetbokep.com}
    TOBU0:=Km>80 AND Dm>80 AND Kj>80 AND Dj>80;
    STICKLINE(TOBU0=1,10,0,4,1),COLOR008f00;

    ——:60,colorwhite,dotline;0,colorred,dotline;

    100,colorgreen,dotline;
    partline(j,j<5 and j>ref(j,1),rgb(255,0,0),(j<5 and j<ref(j,1)) or (j>95 and j>ref(j,1)),rgb(255,255,0),j>95 and j<ref(j,1),rgb(0,255,0)),linethick2;
    partline(jw,jw<5 and jw>ref(jw,1),rgb(128,0,0),(jw<5 and jw<ref(jw,1)) or (jw>95 and jw>ref(jw,1)),rgb(128,128,0),jw>5 and jw<95 and j>ref(j,1) and jw>ref(jw,1),rgb(128,0,128)),linethick3;
    partline(adx,adx>ref(adx,1) and adx>25 and mdi>pdi,rgb(0,255,0),
    adx<ref(adx,1) and adx>25 and mdi<pdi,rgb(0,255,0),
    adx<25,rgb(88,88,88)),linethick2;
    DRAWICON(FILTER(mdi>ref(mdi,1) and mdi>25 and cci<-90 and adx>ref(adx,1) and c>o,3),adx*1.0,12);
    STICKLINE(filter(買點,2),j+0,j+5,6,0),COLOR0000FF;
    STICKLINE(filter(買點,2),j+5,j+10,3,0),COLORWHITE;
    STICKLINE(filter(買點,2),j+10,j+15,1,0),COLORYELLOW;{http://cxh99.com}

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

    怎么收費,代編流程等詳情請點擊查閱!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>