• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

    四色彩帶,有圖,有買賣點[大智慧公式]

    相關標簽:

    ?

    自己搞的一個公式,比較直觀簡單,賣點不論出現在什么位置,最好先賣出,反正有機會買,以免被套.
    ?

    原理解析:

    LG賦值:收盤價-1日前的收盤價
    AA1賦值:LG-7日前的LG
    AA2賦值:LG-18日前的LG
    AA3賦值:LG-29日前的LG
    AA4賦值:LG-47日前的LG
    AA5賦值:LG-76日前的LG
    AA6賦值:LG-123日前的LG
    AA7賦值:LG-199日前的LG
    BB1賦值:(AA1+AA2+AA3+AA4+AA5+AA6+AA7)
    U賦值:BB1-1日前的BB1
    BB2賦值:U的5日[1日權重]移動平均
    YY1賦值:BB1-1日前的BB1
    輸出綠帶1:YY1的8日指數移動平均的8日指數移動平均的14日指數移動平均,COLOR00FA00,線寬為4
    輸出綠帶2:綠帶1的3日指數移動平均的3日指數移動平均,COLORFFFF00,線寬為3
    輸出紅帶1:綠帶2的3日指數移動平均的3日指數移動平均,畫紅色,線寬為3
    輸出紅帶2:紅帶1的11日指數移動平均,COLORFF00FF,線寬為3
    BB3賦值:15日前的最高價的1日簡單移動平均>15日前的最高價的60日簡單移動平均 AND 綠帶2<0
    DD1賦值:紅帶1的1日簡單移動平均>1日前的紅帶1的1日簡單移動平均
    DD2賦值:綠帶2的1日簡單移動平均>1日前的綠帶2的1日簡單移動平均
    DD3賦值:綠帶1的1日簡單移動平均>1日前的綠帶1的1日簡單移動平均
    DD4賦值:紅帶2的1日簡單移動平均>1日前的紅帶2的1日簡單移動平均
    畫帶狀線
    畫帶狀線
    當滿足條件綠帶1上穿綠帶2的5日過濾時,在綠帶1-0.04位置書寫文字,COLORFF00FF
    當滿足條件綠帶2上穿綠帶1的5日過濾時,在綠帶1+0.04位置書寫文字,畫白色
    輸出買點:綠帶1上穿綠帶2的5日過濾*0.01,COLOR808080
    ?

    源碼:

    ?

    LG:=C-REF(C,1);
    AA1:=LG-REF(LG,7);
    AA2:=LG-REF(LG,18);
    AA3:=LG-REF(LG,29);
    AA4:=LG-REF(LG,47);
    AA5:=LG-REF(LG,76);
    AA6:=LG-REF(LG,123);
    AA7:=LG-REF(LG,199);
    BB1:=(AA1+AA2+AA3+AA4+AA5+AA6+AA7);
    U:=BB1-REF(BB1,1);
    BB2:=SMA(U,5,1);
    YY1:=BB1-REF(BB1,1);
    綠帶1:EMA(EMA(EMA(YY1,8),8),14),COLOR00FA00,LINETHICK4;
    綠帶2:EMA(EMA(綠帶1,3),3),COLORFFFF00,LINETHICK3;
    紅帶1:EMA(EMA(綠帶2,3),3),COLORRED,LINETHICK3;
    紅帶2:EMA(紅帶1,11),COLORFF00FF,LINETHICK3;
    BB3:=REF(MA(H,1),15)>REF(MA(H,60),15) AND 綠帶2<0;
    DD1:=MA(紅帶1,1)>REF(MA(紅帶1,1),1);
    DD2:=MA(綠帶2,1)>REF(MA(綠帶2,1),1);
    DD3:=MA(綠帶1,1)>REF(MA(綠帶1,1),1);
    DD4:=MA(紅帶2,1)>REF(MA(紅帶2,1),1);
    DRAWBAND(紅帶2,RGB(0,0,220),紅帶1,RGB(252,10,265));
    DRAWBAND(綠帶1,RGB(255,255,0),綠帶2,RGB(50,100,10));
    DRAWTEXT(FILTER(CROSS(綠帶1,綠帶2),5),綠帶1-0.04,'買'),COLORFF00FF;
    DRAWTEXT(FILTER(CROSS(綠帶2,綠帶1),5),綠帶1+0.04,'賣'),COLORWHITE;
    買點:FILTER(CROSS(綠帶1,綠帶2),5)*0.01,COLOR808080;

    {程序化交易 www.planetbokep.com }


    以上代碼在老版本通達信可能出現測試錯誤
    請用以下公式即可:

    LG:=C-REF(C,1);
    AA1:=LG-REF(LG,7);
    AA2:=LG-REF(LG,18);
    AA3:=LG-REF(LG,29);
    AA4:=LG-REF(LG,47);
    AA5:=LG-REF(LG,76);
    AA6:=LG-REF(LG,123);
    AA7:=LG-REF(LG,199);
    BB1:=(AA1+AA2+AA3+AA4+AA5+AA6+AA7);
    U:=BB1-REF(BB1,1);
    BB2:=SMA(U,5,1);
    YY1:=BB1-REF(BB1,1);
    綠帶1:EMA(EMA(EMA(YY1,8),8),14),COLOR00FA00,LINETHICK4;
    綠帶2:EMA(EMA(綠帶1,3),3),COLORFFFF00,LINETHICK3;
    紅帶1:EMA(EMA(綠帶2,3),3),COLORRED,LINETHICK3;
    紅帶2:EMA(紅帶1,11),COLORFF00FF,LINETHICK3;
    BB3:=REF(MA(H,1),15)>REF(MA(H,60),15) AND 綠帶2<0;
    DD1:=MA(紅帶1,1)>REF(MA(紅帶1,1),1);
    DD2:=MA(綠帶2,1)>REF(MA(綠帶2,1),1);
    DD3:=MA(綠帶1,1)>REF(MA(綠帶1,1),1);
    DD4:=MA(紅帶2,1)>REF(MA(紅帶2,1),1);
    STICKLINE(綠帶1>綠帶2,綠帶1,綠帶2,0,0),COLORYELLOW;{http://cxh99.com}
    STICKLINE(綠帶1<綠帶2,綠帶1,綠帶2,0,0),COLORGREEN;{http://www.planetbokep.com}
    STICKLINE(紅帶1>紅帶2,紅帶1,紅帶2,0,0),colorred;
    STICKLINE(紅帶1<紅帶2,紅帶1,紅帶2,0,0),colorblue;
    DRAWTEXT(FILTER(CROSS(綠帶1,綠帶2),5),綠帶1-0.04,'買'),COLORFF00FF;
    DRAWTEXT(FILTER(CROSS(綠帶2,綠帶1),5),綠帶1+0.04,'賣'),COLORWHITE;
    買點:FILTER(CROSS(綠帶1,綠帶2),5)*0.01,COLOR808080;

    ?

    公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

    ?

     

    有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

    怎么收費,代編流程等詳情請點擊查閱!

    (注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>