• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 外匯現貨>> 倚天財經>> 倚天版公式>>正文內容

    第一密碼圖指標源碼[倚天版公式]

    第一密碼圖H1:EMA(CLOSE,8);
    H2:EMA(第一密碼圖H1,20);
    LH:EMA(CLOSE,240),COLORRED;
    VAR1:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
    VAR2:=SMA(VAR1,5,1);
    VAR3:=SMA(VAR2,8,1);
    VAR4:=CROSS(VAR2,VAR3) AND VAR3<20;
    VAR5:=CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR4;
    VAR6:=IF(CLOSE>1000,VAR4,VAR5);
    DRAWICON(CROSS(第一密碼圖H1,H2) AND CLOSE<EMA(CLOSE,60),LOW,1);
    DRAWICON(VAR6,H,2);
    STICKLINE(第一密碼圖H1>H2,第一密碼圖H1,H2,1,1),COLORYELLOW;
    STICKLINE(第一密碼圖H1<H2,第一密碼圖H1,H2,1,1),COLORBLUE;

     

    源碼解析:

    輸出第一密碼圖H1:收盤價的8日指數移動平均
    輸出H2:第一密碼圖H1的20日指數移動平均
    輸出LH:收盤價的240日指數移動平均,畫紅色
    VAR1賦值:(36日內最高價的最高值-收盤價)/(36日內最高價的最高值-36日內最低價的最低值)*100
    VAR2賦值:VAR1的5日[1日權重]移動平均
    VAR3賦值:VAR2的8日[1日權重]移動平均
    VAR4賦值:VAR2上穿VAR3 AND VAR3<20
    VAR5賦值:收盤價>60日內收盤價的最低值+0.3*60日內收盤價的最低值 AND VAR4
    VAR6賦值:如果收盤價>1000,返回VAR4,否則返回VAR5
    當滿足條件第一密碼圖H1上穿H2ANDCLOSE<收盤價的60日指數移動平均時,在最低價位置畫1號圖標
    當滿足條件VAR6時,在最高價位置畫2號圖標
    當滿足條件第一密碼圖H1>H2時,在第一密碼圖H1和H2位置之間畫柱狀線,寬度為1,1不為0則畫空心柱.,畫黃色
    當滿足條件第一密碼圖H1<H2時,在第一密碼圖H1和H2位置之間畫柱狀線,寬度為1,1不為0則畫空心柱.,畫藍色
     

     

    有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流進行 有償 編寫!不貴!點擊查看價格!

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>