• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 外匯現貨>> 倚天財經>> 倚天版公式>>正文內容

    均線多頭排列指標[倚天版公式]

    A11:=MA(CLOSE,5);
    A12:=MA(CLOSE,10);
    A13:=MA(CLOSE,20);
    A14:=MA(CLOSE,30);
    均線多頭排列:IF(A11>A12 AND A12>A13 AND CROSS(A13,A14) AND C>O,18,0),STICK,LINETHICK2,COLOR00BBFF;
    DRAWTEXT(A11>A12 AND A12>A13 AND CROSS(A13,A14) AND C>O,35,'均線多頭排列'),COLOR00FFFF;
    VAR1:=HHV(HIGH,9)-LLV(LOW,9);
    VAR2:=HHV(HIGH,9)-CLOSE;
    VAR3:=CLOSE-LLV(LOW,9);
    VAR4:=VAR2/VAR1*100-70;
    VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60));
    VAR6:=(2*CLOSE+HIGH+LOW)/4;
    VAR7:=SMA(VAR3/VAR1*100,3,1);
    VAR8:=LLV(LOW,34);
    VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
    VAR10:=IF(VAR9>100,VAR9-100,0);
    VAR11:=HHV(HIGH,34);
    VAR12:=EMA((VAR6-VAR8)/(VAR11-VAR8)*100,13);
    VAR13:=EMA(0.667*REF(VAR12,1)+0.333*VAR12,2);
    VAR13,COLOR000000;
    STICKLINE(VAR12-VAR13>0,VAR12,VAR13,8,0),COLOR0055FF;
    STICKLINE(VAR12-VAR13<0,VAR12,VAR13,8,0),COLOR00FF00;

     

     

    源碼解析:

    A11賦值:收盤價的5日簡單移動平均
    A12賦值:收盤價的10日簡單移動平均
    A13賦值:收盤價的20日簡單移動平均
    A14賦值:收盤價的30日簡單移動平均
    輸出均線多頭排列:如果A11>A12ANDA12>A13ANDCROSS(A13,A14)ANDC>開盤價,返回18,否則返回0,STICK,線寬為2,COLOR00BBFF
    當滿足條件A11>A12ANDA12>A13ANDCROSS(A13,A14)ANDC>開盤價時,在35位置書寫文字,COLOR00FFFF
    VAR1賦值:9日內最高價的最高值-9日內最低價的最低值
    VAR2賦值:9日內最高價的最高值-收盤價
    VAR3賦值:收盤價-9日內最低價的最低值
    VAR4賦值:VAR2/VAR1*100-70
    VAR5賦值:(收盤價-60日內最低價的最低值)/(60日內最高價的最高值-60日內最低價的最低值)
    VAR6賦值:(2*收盤價+最高價+最低價)/4
    VAR7賦值:VAR3/VAR1*100的3日[1日權重]移動平均
    VAR8賦值:34日內最低價的最低值
    VAR9賦值:VAR7的3日[1日權重]移動平均-VAR4的9日[1日權重]移動平均
    VAR10賦值:如果VAR9>100,返回VAR9-100,否則返回0
    VAR11賦值:34日內最高價的最高值
    VAR12賦值:(VAR6-VAR8)/(VAR11-VAR8)*100的13日指數移動平均
    VAR13賦值:0.667*昨日VAR12+0.333*VAR12的2日指數移動平均
    VAR13,COLOR000000
    當滿足條件VAR12-VAR13>0時,在VAR12和VAR13位置之間畫柱狀線,寬度為8,0不為0則畫空心柱.,COLOR0055FF
    當滿足條件VAR12-VAR13<0時,在VAR12和VAR13位置之間畫柱狀線,寬度為8,0不為0則畫空心柱.,COLOR00FF00
     
     

     

    有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

    可聯系技術人員 QQ: 262069696  點擊在線交流進行 有償 編寫!不貴!點擊查看價格!

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>