• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 外匯現貨>> 仟家信等>> 仟家信公式>>正文內容

    現貨穩賺趨勢指標源碼[仟家信公式]

    現貨穩賺趨勢指標完整源碼如下:

     

    Var1:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;

    Var2:=SMA(Var1,3,1);

    Var3:=SMA(Var2,3,1);

    Var4:=3*Var2-2*Var3;

    Var5:=LLV(LOW,5);

    Var6:=HHV(HIGH,5);

    Var7:=EMA((CLOSE-Var5)/(Var6-Var5)*100,4)*2;

    Var8:=EMA(0.667*REF(Var7,1)+0.333*Var7,2);

    Var9:=3*Var7-2*Var8;

    VarA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);

    VarB:=POW(MA(LOW,5),2)+MA(LOW,5);

    VarC:=POW(MA(HIGH,5),2)+MA(HIGH,5);{來源 CXH99.COM }

    VarD:=(VarA-LLV(VarB,64))/(HHV(VarC,64)-LLV(VarB,64))*150+65-10;

    VarE:=SMA(VarD,3,1)*1.5-100;

    VarF:=SMA(VarE,3,1);

    Var10:=3*VarE-2*VarF;

    Var11:=(HIGH+LOW+CLOSE*2)/4;

    Var12:=EMA(Var11,13);

    Var13:=STD(Var11,13);

    Var14:=(Var11-Var12)*100/Var13;

    Var15:=EMA(Var14,5);

    Var17:=EMA(Var15,13)+200-100;

    Var18:=EMA(Var17,10);

    Var19:=3*Var17-2*Var18;

    Var1A:=Var2+Var7+VarE+Var17;

    Var1B:=Var3+Var8+VarF+Var18;

    Var1C:=Var4+Var9+Var10+Var19;

    Var1D:=(HIGH+LOW+CLOSE)/3;

    Var20:=(Var1D-MA(Var1D,34))/(0.015*AVEDEV(Var1D,34));

    Var21:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);

    Var22:=(HIGH+LOW+CLOSE+Var1D)/4;

    Var23:=EMA(Var22,24);

    Var24:=STD(Var22,24);

    Var25:=(Var22-Var23)/Var24*100;

    Var26:=(Var1D-MA(Var1D,24))/(0.015*AVEDEV(Var1D,24));

    Var27:=EMA(Var25,5);

    Var2A:=((Var27+Var26+Var20)/3+165)/4;

    Var2B:=(EMA(EMA(EMA(Var2A,15),10),5)-25)*2+Var21;

    Var2C:=(Var1A+Var1B+Var1C*30)/32/5-15;

    Var2D:=EMA(Var2C,13);{13}

    Var2E:=(Var2A+Var2C)/2/1.1;  

    Var28:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

    Var29:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

    Var30:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

    Var31:=REF(CLOSE,1);

    Var32:=SMA(MAX(CLOSE-Var31,0),5,1)/SMA(ABS(CLOSE-Var31),5,1)*100;

    Var33:=(HIGH+LOW+CLOSE)/3;

    Var34:=(Var33-MA(Var33,14))/(0.015*AVEDEV(Var33,14));

    DRAWTEXT_FIX(C>O,0.01,0.9,0,' www.planetbokep.com '),COLORRED;
    DRAWTEXT_FIX(C>O,1,1,0,' cxh99.com 程序化交易模型'),COLORRED;

    超短:EMA(Var2E,3),colorred ;

    短線:EMA(超短,5),colorwhite;

    趨勢線:EMA((Var2B+Var2D)/2,2) ,coloryellow;

     

     

     

     

    源碼解析:

    VAR1賦值:(收盤價-80日內最低價的最低值)/(80日內最高價的最高值-80日內最低價的最低值)*200
    VAR2賦值:VAR1的3日[1日權重]移動平均
    VAR3賦值:VAR2的3日[1日權重]移動平均
    VAR4賦值:3*VAR2-2*VAR3
    VAR5賦值:5日內最低價的最低值
    VAR6賦值:5日內最高價的最高值
    VAR7賦值:(收盤價-VAR5)/(VAR6-VAR5)*100的4日指數移動平均*2
    VAR8賦值:0.667*昨日VAR7+0.333*VAR7的2日指數移動平均
    VAR9賦值:3*VAR7-2*VAR8
    VARA賦值:收盤價的5日簡單移動平均的2乘冪+收盤價的5日簡單移動平均
    VARB賦值:最低價的5日簡單移動平均的2乘冪+最低價的5日簡單移動平均
    VARC賦值:最高價的5日簡單移動平均的2乘冪+最高價的5日簡單移動平均
    VARD賦值:(VARA-64日內VARB的最低值)/(64日內VARC的最高值-64日內VARB的最低值)*150+65-10
    VARE賦值:VARD的3日[1日權重]移動平均*1.5-100
    VARF賦值:VARE的3日[1日權重]移動平均
    VAR10賦值:3*VARE-2*VARF
    VAR11賦值:(最高價+最低價+收盤價*2)/4
    VAR12賦值:VAR11的13日指數移動平均
    VAR13賦值:VAR11的13日估算標準差
    VAR14賦值:(VAR11-VAR12)*100/VAR13
    VAR15賦值:VAR14的5日指數移動平均
    VAR17賦值:VAR15的13日指數移動平均+200-100
    VAR18賦值:VAR17的10日指數移動平均
    VAR19賦值:3*VAR17-2*VAR18
    VAR1A賦值:VAR2+VAR7+VARE+VAR17
    VAR1B賦值:VAR3+VAR8+VARF+VAR18
    VAR1C賦值:VAR4+VAR9+VAR10+VAR19
    VAR1D賦值:(最高價+最低價+收盤價)/3
    VAR20賦值:(VAR1D-VAR1D的34日簡單移動平均)/(0.015*VAR1D的34日平均絕對偏差)
    VAR21賦值:以成交量(手)/當前流通股本(手)為權重成交額(元)/成交量(手)/100的動態移動平均
    VAR22賦值:(最高價+最低價+收盤價+VAR1D)/4
    VAR23賦值:VAR22的24日指數移動平均
    VAR24賦值:VAR22的24日估算標準差
    VAR25賦值:(VAR22-VAR23)/VAR24*100
    VAR26賦值:(VAR1D-VAR1D的24日簡單移動平均)/(0.015*VAR1D的24日平均絕對偏差)
    VAR27賦值:VAR25的5日指數移動平均
    VAR2A賦值:((VAR27+VAR26+VAR20)/3+165)/4
    VAR2B賦值:(VAR2A的15日指數移動平均的10日指數移動平均的5日指數移動平均-25)*2+VAR21
    VAR2C賦值:(VAR1A+VAR1B+VAR1C*30)/32/5-15
    VAR2D賦值:VAR2C的13日指數移動平均
    VAR2E賦值:(VAR2A+VAR2C)/2/1.1
    VAR28賦值:(收盤價-收盤價的6日簡單移動平均)/收盤價的6日簡單移動平均*100
    VAR29賦值:(收盤價-收盤價的12日簡單移動平均)/收盤價的12日簡單移動平均*100
    VAR30賦值:(收盤價-收盤價的24日簡單移動平均)/收盤價的24日簡單移動平均*100
    VAR31賦值:昨收
    VAR32賦值:收盤價-VAR31和0的較大值的5日[1日權重]移動平均/收盤價-VAR31的絕對值的5日[1日權重]移動平均*100
    VAR33賦值:(最高價+最低價+收盤價)/3
    VAR34賦值:(VAR33-VAR33的14日簡單移動平均)/(0.015*VAR33的14日平均絕對偏差)
    輸出超短:VAR2E的3日指數移動平均,畫紅色
    輸出短線:超短的5日指數移動平均,畫白色
    輸出趨勢線:(VAR2B+VAR2D)/2的2日指數移動平均 ,畫黃色

     

     

    如果以上指標公式不適用于您常用的行情軟件

    或者您想改編成選股公式,以便快速選出某種形態個股的話,

    可以聯系我們相關技術人員 QQ: 262069696  點擊在線交流進行 有償 改編!

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>