• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 外匯現貨>> 仟家信等>> 仟家信公式>>正文內容

    快慢多空或火車軌指標源碼[仟家信公式]

    快慢多空或火車軌指標公工源碼:

     

    S:=CROSS(CLOSE,EMA2(HIGH,30));
    X:=CROSS(EMA2(LOW,30),CLOSE);
    WS:=BARSLAST(S) 1;
    WX:=BARSLAST(X) 1;
    SS:=CROSS(SUM(S,WX),0.5);
    XX:=CROSS(SUM(X,WS),0.5);
    STICKLINE(CLOSE>EMA2(HIGH,30),EMA2(HIGH,30),EMA2(LOW,30),COLORMAGENTA,1);
    STICKLINE(CLOSE<EMA2(LOW,30),EMA2(LOW,30),EMA2(HIGH,30),COLORBLUE,1);
    STICKLINE(CLOSE>EMA2(HIGH,150),EMA2(HIGH,150),EMA2(LOW,150),COLORLIGHTRED,1);
    STICKLINE(CLOSE<EMA2(LOW,150),EMA2(LOW,150),EMA2(HIGH,150),COLORLIGHTGREEN,1);
    PARTLINE(CLOSE>EMA2(HIGH,30),EMA2(HIGH,30),COLORMAGENTA);
    PARTLINE(CLOSE<EMA2(HIGH,30),EMA2(HIGH,30),COLORBLUE);
    PARTLINE(CLOSE>EMA2(LOW,30),EMA2(LOW,30),COLORMAGENTA);
    PARTLINE(CLOSE<EMA2(LOW,30),EMA2(LOW,30),COLORBLUE);
    PARTLINE(CLOSE>EMA2(HIGH,150),EMA2(HIGH,150),COLORLIGHTRED);
    PARTLINE(CLOSE<EMA2(HIGH,150),EMA2(HIGH,150),COLORLIGHTGREEN);
    PARTLINE(CLOSE>EMA2(LOW,150),EMA2(LOW,150),COLORLIGHTRED);
    PARTLINE(CLOSE<EMA2(LOW,150),EMA2(LOW,150),COLORLIGHTGREEN);
    STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,COLORRED,0);
    STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,COLORCYAN,0);
    DRAWTEXT(SS,LOW,'買入');
    DRAWTEXT(XX,HIGH,'賣出');

     

     

     

     

    源碼解析:

     

    S賦值:收盤價上穿EMA2(最高價,30)
    X賦值:EMA2(最低價,30)上穿收盤價
    WS賦值:上次S距今天數 1
    WX賦值:上次X距今天數 1
    SS賦值:S的WX日累和上穿0.5
    XX賦值:X的WS日累和上穿0.5
    當滿足條件收盤價>EMA2(最高價,30)時,在EMA2(最高價,30)和EMA2(最低價,30)位置之間畫柱狀線,寬度為畫洋紅色,1不為0則畫空心柱.
    當滿足條件收盤價<EMA2(最低價,30)時,在EMA2(最低價,30)和EMA2(最高價,30)位置之間畫柱狀線,寬度為畫藍色,1不為0則畫空心柱.
    當滿足條件收盤價>EMA2(最高價,150)時,在EMA2(最高價,150)和EMA2(最低價,150)位置之間畫柱狀線,寬度為COLORLIGHTRED,1不為0則畫空心柱.
    當滿足條件收盤價<EMA2(最低價,150)時,在EMA2(最低價,150)和EMA2(最高價,150)位置之間畫柱狀線,寬度為COLORLIGHTGREEN,1不為0則畫空心柱.
    PARTLINE(收盤價>EMA2(最高價,30),EMA2(最高價,30),畫洋紅色)
    PARTLINE(收盤價<EMA2(最高價,30),EMA2(最高價,30),畫藍色)
    PARTLINE(收盤價>EMA2(最低價,30),EMA2(最低價,30),畫洋紅色)
    PARTLINE(收盤價<EMA2(最低價,30),EMA2(最低價,30),畫藍色)
    PARTLINE(收盤價>EMA2(最高價,150),EMA2(最高價,150),COLORLIGHTRED)
    PARTLINE(收盤價<EMA2(最高價,150),EMA2(最高價,150),COLORLIGHTGREEN)
    PARTLINE(收盤價>EMA2(最低價,150),EMA2(最低價,150),COLORLIGHTRED)
    PARTLINE(收盤價<EMA2(最低價,150),EMA2(最低價,150),COLORLIGHTGREEN)
    當滿足條件開盤價>=收盤價時,在收盤價和開盤價位置之間畫柱狀線,寬度為畫紅色,0不為0則畫空心柱.
    當滿足條件收盤價>=開盤價時,在收盤價和開盤價位置之間畫柱狀線,寬度為畫青色,0不為0則畫空心柱.
    當滿足條件SS時,在最低價位置書寫文字
    當滿足條件XX時,在最高價位置書寫文字
     

     

    如果以上指標公式不適用于您常用的行情軟件

    或者您想改編成選股公式,以便快速選出某種形態個股的話,

    可以聯系我們相關技術人員 QQ: 262069696  點擊在線交流進行 有償 改編!

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>