• <menu id="iiemy"><menu id="iiemy"></menu></menu>
    您現在的位置:程序化交易>> 外匯現貨>> 仟家信等>> 仟家信公式>>正文內容

    現貨進場提示指標源碼[仟家信公式]

    long:=26;   m:=9;   short:=12;
    DIFF1:=EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
    DEA1:=EMA(DIFF1,M);
    MACD:=2*(DIFF1-DEA1);
    DIFF:EMA(CLOSE,SHORT) - EMA(CLOSE,LONG),colorff00ff,linethick2;
    DEA:EMA(DIFF1,M),colorwhite,linethick2;
    AH:HHV(DIFF1,55),COLOR6600ff,linethick2;
    PARTLINE(ah,ah),COLORWHITE,POINTDOT,linethick2;
    DRAWICON( ref(aH=diff1,1) and DIFF<REF(DIFF1,1),AH,8),ALIGN1;
    AL:LLV(DIFF1,55),COLOR248a24,linethick2;
    PARTLINE(al,Al),COLORWHITE,POINTDOT,linethick2;
    DRAWICON( ref(al=diff1,1) and DIFF>REF(DIFF1,1),al,7),ALIGN1;
    {●60零上金叉:IF(CROSS(DIFF,DEA) AND DIFF>0,0.3,0),COLOR6600ff,POINTDOT;
    STICKLINE(●60零上金叉,DIFF,ah,4,0),COLOR6600ff;}
    ■零下金叉:IF(CROSS(DIFF,DEA) AND DIFF<-0.001,0.3,0),COLORWHITE,POINTDOT;
    STICKLINE(■零下金叉,0.1,0.15,6,0),COLORWHITE;
    JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
    ■二次金叉:IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,0.2,0),COLOR3C86CC,POINTDOT;
    STICKLINE(■二次金叉,0.15,0.2,6,0),COLOR3C86CC;
    A3:=CROSS(DIFF,DEA) AND DEA<0;
    ■零下二次金叉:IF(FILTER(COUNT(A3,21)=2,10) AND DEA<0,0.05,0),COLORF58F98,POINTDOT;
    STICKLINE(■零下二次金叉,0.25,0.3,6,0),COLORF58F98;
    A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
    ■底背離:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),0.1,0),COLORFFFF00;
    底背離1:STICKLINE(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),0,AL,4,0),COLOR00FF00;
    STICKLINE(■底背離,0.2,0.25,6,0),COLORFFFF00;
    {DRAWLINE(A1=0,DEA,■底背離,DEA,0),COLORYELLOW};
    {A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
    頂背離:STICKLINE(REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),0,DIFF,4,0),COLORBLACK;
    DRAWLINE(A2=0,DEA,頂背離,DEA,0),COLORGREEN;}
    DD:=C=HHV(C,100);
    EE:=DEA1< REF(DEA1,1) AND REF(DEA1< REF(DEA1,1),1)=1;
    CC:=C> REF(C,1) AND REF(C> REF(C,1),1)=1;
    上升背離:(CC AND EE)*AH,stick,linethick2,COLORff00FF;
    頂背離:(DD AND EE AND DEA1< HHV(DEA1,100))*AH,STICK,LINETHICK2,COLOrYELLOW;
    drawtext(頂背離,DEA1/2,'頂背離'),ALIGN1,colorYELLOW;
    FF:=C=LLV(C,100);
    GG:= DEA1> REF(DEA1,1) AND REF(DEA1> REF(DEA1,1),1)=1;
    LL:=C< REF(C,1) AND REF(C< REF(C,1),1)=1;
    下降背離:(LL AND GG)*AL,stick,linethick2,COLORwhite;
    底背離:(FF AND GG AND DEA1> LLV(DEA1,100))*AL,STICK,LINETHICK2,COLOR6600ff;
    drawtext(底背離,DEA1/2,'底背離'),ALIGN1,color6600FF;
    if(diff<0,diff,0),colorff00ff,linethick2;
    if(diff<0,0,diff),coloryellow,linethick2;
    if(diff<dea,diff,dea),colorffff00,linethick2;
    if(diff>dea,dea,dea),colorwhite,linethick2;
    {PARTLINE(DEA,bbDEA>0,RGB(255,0,255)),LINETHICK2;
    PARTLINE(DEA,bbDEA<0,RGB(255,255,225)),LINETHICK2;
    PARTLINE(DIFF,bbDIFF>0,RGB(255,255,0)),LINETHICK2;
    PARTLINE(DIFF,bbDIFF<0,RGB(0,0,255)),LINETHICK2;}
    VAR1:=HHV(DEA,53);VAR2:=LLV(DEA,30);VAR3:=DEA-(DIFF-DEA);
    UP:IF(DIFF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1),COLORbb9a00,LINETHICK2;
    DN:IF(DIFF<VAR2 AND DEA=VAR2,MIN(HHV(VAR2,10),VAR3),VAR2),COLORaa00bb,LINETHICK2;
    可以接多:=CROSS(DIFF ,DEA ) AND CROSS( DIFF,DN ) AND DN<0;
    可以接多a:可以接多*AL,stick,linethick4,COLOR8080ff;
    DRAWTEXT(可以接多,dn,'可以接多'),ALIGN1,COLOR8080FF,linethick2;
    可以做空:=CROSS(DEA ,DIFF ) AND CROSS( UP,DIFF ) AND DIFF<UP;
    可以做空a:可以做空*ah,stick,linethick4,COLOR9ca010;

     

     

     

    如果以上指標公式不適用于您常用的行情軟件

    或者您想改編成選股公式,以便快速選出某種形態個股的話,

    可以聯系我們相關技術人員 QQ: 262069696  點擊在線交流進行 有償 改編!

     


    【字體: 】【打印文章】【查看評論

    相關文章

      沒有相關內容
      人妻专区免费视频,俄罗斯啪啪到高潮喷水,国色天香社区直播在线观看
  • <menu id="iiemy"><menu id="iiemy"></menu></menu>